Jump to content


Photo

Unwanted Interface Popup


  • Please log in to reply
5 replies to this topic

#1 TonyB

TonyB

    New Member

  • Members
  • Pip
  • 5 posts

Posted 03 August 2010 - 02:46 AM

Hi all.

Since the last (large) definitions update (August 3 in Australia) I have restarted my pc on a few occasions running in the freeware mode. Since the update after a minute or so the Emsi user interface screen appears on the desktop without my clicking on the icon. As the configurations are greyed for freeware users (and I can't see a program auto run option anyway) it appears this behaviour has been initiated by the latest update.

It is annoying that after a fairly seamless transfer to the freeware version this has started to occur. I hope it is just a temporary glitch or something in the settings.

Please advise what should be done to resolve the issue, I really don't want to uninstall the program after many years but if this is a new default configuration I will have to.

Thanks,

TonyB

#2 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 03 August 2010 - 02:56 AM

Hi TonyB, welcome to the forum

Yes & that issue was reported already.

I hope that the developers will reply

After the latest transformation to the "free mode" using the latest Setup 0.67 that has the direct Free option without creating an account
you still has a2guard in Autorun

I disabled that by un-checking (whatever Autoruns manager you are using)

But again... I'm sure the developers will reply... probably it is by design and necessary
I don't see any ill effect after disabling the said Registry entry
at the same, time since it is free edition you can use that for the 1st Manual Update within current Windows session

My regards

XP Pro, SP3 (32-bit); EAM v8.1.0.40 (beta) ; Firewall: Comodo 3.14 FW only ("Defense+" HIPS)
Win 7 Home Premium x64, SP1; EAM v8.1.0.40 (beta); Firewall: Comodo as above

Win 7 Ultimate, SP1 (32-bit) testing EIS 9 beta


#3 TonyB

TonyB

    New Member

  • Members
  • Pip
  • 5 posts

Posted 03 August 2010 - 03:23 AM

Aha, thanks for that Lynx!

I disabled the link to the old A2 guard auto .exe and so far all is good!

BTW, I am still using a very old free startup control proggy called 'Startup Control Panel' by a guy called Mike Lins, have used it since W98 and it still works a treat if any other folks need to follow your advice but don't have an autorun manager.

Thanks again for the heads up (and I was here on the old forum a long time ago actually, just forgot my details).

#4 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 03 August 2010 - 03:42 AM

TonyB,

I am glad if that helped, but please keep in mind:

I am not entirely sure what kind of setup & Software you are using.

What I meant was a new fresh install of the latest EAM 5.0.0.67 when old version(s) are removed
and the new option as in the image posted here was used

In this case, the following:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run-]
has this entry
"a-squared"="\"C:\\Program Files\\Emsisoft Anti-Malware\\a2guard.exe\""

My regards

XP Pro, SP3 (32-bit); EAM v8.1.0.40 (beta) ; Firewall: Comodo 3.14 FW only ("Defense+" HIPS)
Win 7 Home Premium x64, SP1; EAM v8.1.0.40 (beta); Firewall: Comodo as above

Win 7 Ultimate, SP1 (32-bit) testing EIS 9 beta


#5 Fabian Wosar

Fabian Wosar

    Forum Veteran

  • Emsisoft Employee
  • 2958 posts
  • OS:Windows 8.1 x64
  • AV:Emsisoft Anti-Malware

Posted 03 August 2010 - 10:54 AM

The added a2guard.exe reference when installing in Freeware mode is actually a bug. It will be fixed in one of the next releases. You can simply remove it by checking and unchecking the "Enable Guard on system startup" option inside the Emsisoft Anti-Malware General Configuration.
Best regards,

Fabian Wosar [Development]
Emsisoft Team - www.emsisoft.com

#6 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 03 August 2010 - 11:27 AM

The added a2guard.exe reference when installing in Freeware mode is actually a bug. It will be fixed in one of the next releases.

Thanks for the reply, Fabian

You can simply remove it by checking and unchecking the "Enable Guard on system startup" option inside the Emsisoft Anti-Malware General Configuration.

Sure,
it was just was easier for me to use Autoruns by SysInternals

Not a big deal actually, & no questions - that will be fixed

My regards

XP Pro, SP3 (32-bit); EAM v8.1.0.40 (beta) ; Firewall: Comodo 3.14 FW only ("Defense+" HIPS)
Win 7 Home Premium x64, SP1; EAM v8.1.0.40 (beta); Firewall: Comodo as above

Win 7 Ultimate, SP1 (32-bit) testing EIS 9 beta





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users