Jump to content


Photo

EEK - crash during Update


  • Please log in to reply
13 replies to this topic

#1 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 27 August 2010 - 10:36 PM

Hi Guys,

Today's attempt to update EEK (v1.0.0.12) was unsuccessful (73MB gotta be delivered)

Posted Image

{added} I tried with another stick & found that sometimes after confirming the Access Violation message
Posted Image you can get this one

The only way is to kill the process (tried several times already)

Anybody else experiencing similar issue?

The updates of the EAM & Mamutu went smoothly including new modules

My regards

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#2 Rob R.

Rob R.

    Forum Regular

  • Emsisoft Employee
  • 982 posts
  • LocationNetherlands
  • OS:Other Windows version
  • AV:Emsisoft Anti-Malware
  • HIPS:Online Armor

Posted 28 August 2010 - 01:43 AM

Lynx,

I tested with .10 .11 and .12 versions of EEK on XP SP3 but was unable to replicate the error.
Tested with sigs from original releases and a week old sigs.

#3 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 28 August 2010 - 03:12 AM

Thanks for the reply, ctrlaltdelete

I will try a bit later, but as you can see the second unfortunate attempt (that I repeated few times as well) was a bit different:
- the older version - 0.11 & more to be delivered (~83MB compare to 73MB on another stick with 0.12 in place)

"Very replicable" here :)

Cheers!

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#4 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 28 August 2010 - 04:21 AM

In addition to my last reply above

Lucky me :) The client brought Win 7 x64 here

The update for full EAM (beta) was going on & ended successfully as you can see

But I connected the same Flash Stick (iPod) & ran the update – the result is the same

- different OS;
- different platform;
- no complains at the moment regarding MS Updates, which broke some Applications' functionality on XP;
- everything is up to shape currently on Win 7 in this respect;
- the very same stick was updated previously on Win 7 as well

Posted Image

Posted Image this one is different to what I've got on XP

Anyway... replicable indeed

Cheers!

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#5 ryerman

ryerman

    Member

  • Members
  • PipPip
  • 20 posts
  • LocationCanada
  • OS:Windows 7
  • AV:AVG Anti-Virus Free Edition 2013
  • HIPS:Windows Firewall
  • Other:Zemana AntiLogger Free v1.6.2.226

Posted 28 August 2010 - 02:29 PM

Anybody else experiencing similar issue?

Yes, I did: Numerous Access Violation messages and I had to kill the process.
My solution was to download a new copy of the Emergency Kit zip file and use the contained files.
I updated successfully, with no other problems so far.
Maybe this doesn't explain whatever problem existed, but it avoids the problem. :)

Jim

Windows 7 Home Premium SP1 64 bit, EEK version 4.0.0.12, AVG Anti-Virus Free Edition 2013, Windows Firewall


#6 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 28 August 2010 - 11:36 PM

Hi Jim,

Thank you for the confirmation.

Unfortunately downloading the whole package again is not a “complete workaround”
You have to update anyway. The package definitely contains the latest modules and Signatures are pretty much fresh, but not necessarily the very latest. You can get the latest update straight away after starting just downloaded EEK.
Sure, if you would unzip & run without updating the Software will not expose this particular misbehaviour

Needless to say that would be quite troublesome for the users with slower connection to download 102 MB (currently) every time

Thanks again
My regards

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#7 ryerman

ryerman

    Member

  • Members
  • PipPip
  • 20 posts
  • LocationCanada
  • OS:Windows 7
  • AV:AVG Anti-Virus Free Edition 2013
  • HIPS:Windows Firewall
  • Other:Zemana AntiLogger Free v1.6.2.226

Posted 29 August 2010 - 03:59 PM

Hi Lynx,

Needless to say that would be quite troublesome for the users with slower connection to download 102 MB (currently) every time

I agree. Not just troublesome but also unacceptable. However, after downloading the zip file once, I have been able to update successfully (as I said in my original post) without downloading a new zip file every time.

Everything seems to be working as it should. Doesn't that show that the problem is over for me?

Jim

Windows 7 Home Premium SP1 64 bit, EEK version 4.0.0.12, AVG Anti-Virus Free Edition 2013, Windows Firewall


#8 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 30 August 2010 - 01:33 AM

... Doesn't that show that the problem is over for me?...

"for me"? and what about "us"? :lol:

That is hard to say at this point.

When I downloaded EEK again yesterday the suggested on-line update did not bring anything new - the Software was up-to-date. Usually I am getting a small update straight away,
but I got one ~ 722k only this morning & it went fine.

The obvious differences was the big update at the time I was testing.
Most likely that was necessary cumulative update, since definitely 50 subsequent updates of the Additional Signatures were not missed that time.

I will leave one of the flash sticks with EEK “as is” for a few days in order to get big update that will includes whole t3sigs.vdb and probably some modules (if there are fixes & improvements)

My regards

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#9 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 13 September 2010 - 09:17 AM

Greetings,

The update of EEK is still not working properly

The Flash Stick with EEK that wasn't updated for several days was connected
I've got the same stack of “Access Violations” as in the initial post and later confirmed by ryerman here

The version of EEK is (was) the latest 1.0.0.12; The update size was ~ 72MB

After killing the process & trying to update again there was a message about some files having wrong versions
After confirming a necessity to update there was another (new) crash:

Posted Image

The process was killed again & the next attempt brought this:

Posted Image

Therefore I did not have any other option, but trying to download the whole Package again (~92MB)

That went fine and since (almost all) new signatures were included I updated straight after the unzipping and got just ~242KB of differential Additional Signatures, which was expected and ended successfully.

My regards

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#10 Mike Buxton

Mike Buxton

    Member

  • Validating
  • PipPip
  • 10 posts
  • LocationSunny England

Posted 13 September 2010 - 06:22 PM

Hi,

EEK has never worked for me using Linux and Wine as I always get a missing file message (whereas the discontinued a² version did work - except for the Command Line option which, in any case, I don't use).

If anyone has used EEK successfully with Linux and Wine (currently I use Wine v 1.2) I would be interested to know.

My regards

Lynx, you are always a huge help to me, but this is neither urgent nor vital to me; so please treat this post accordingly.
Triple boot W98SE, Xubuntu(with Wine-Doors and Wine configured as XP) and the frugal, lean and fast Lucid Puppy

#11 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 13 September 2010 - 11:43 PM

... EEK has never worked for me using Linux and Wine...

Hi Mike,

I am not aware of any plans by the developers re: supporting the above

I am sure that the priority in any case is to address the specific problem reported, concerning MS Windows (different OSes/platforms)

Let's hope the developers will answer the initial question
...and hopefully adding some words about Linux/Wine

My regards

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#12 Mike Buxton

Mike Buxton

    Member

  • Validating
  • PipPip
  • 10 posts
  • LocationSunny England

Posted 14 September 2010 - 01:11 AM

Hi Lynx,

I didn't rush to report this. However, as the former a² USB version worked with Wine I was just enquiring if EEK has worked with Wine.

I may be the isolated instance and I'm sure to be one of very few, so I don't expect EMSI to fix it for me.

Cheers to all
Triple boot W98SE, Xubuntu(with Wine-Doors and Wine configured as XP) and the frugal, lean and fast Lucid Puppy

#13 Lynx

Lynx

    Forum Veteran

  • Members
  • PipPipPipPipPip
  • 2546 posts
  • LocationAustralia

Posted 14 September 2010 - 01:58 AM

Mike,

You may consider to create a separate thread about working a²/not working EEK in Wine/Linux,
because the "missing file" message is different to what was reported here, despite it's happening during the update in your case as well.

Cheers!

XP Pro, SP3 (32-bit); EAM Full Suite v8.1.0.19(beta) ; Firewall: Comodo 3.14 FW only! (Defense+ HIPS)
Win 7 Home Premium x64, SP1; Firewall: Comodo 3.14 FW only! (Defense+ HIPS); EAM Full Suite v8.1.0.19(beta)


#14 Mike Buxton

Mike Buxton

    Member

  • Validating
  • PipPip
  • 10 posts
  • LocationSunny England

Posted 14 September 2010 - 11:15 AM

Hi Lynx,

It is not worth raising a new thread for an item of such minor interest. You are sure to be right about the lack of correlation with your recent post on download problems; so sorry for any unnecessary confusion.

Cheers

The good news is MalaWare does work with Wine v 1.2, it downloads instantaneously and only takes about 30 seconds to run.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users