FriendlyTester

Member
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About FriendlyTester

  • Rank
    Member

Profile Information

  • Gender
    Not Telling
  1. Hallo Herr Peters, Ihr Vorschlag in der Batch über die cmd.exe zu gehen, anstatt die a2cmd.exe direkt anzusprechen, hat letztendlich zum Erfolg geführt. Es ist also offenbar nicht möglich, die a2cmd selbst so aufzurufen, dass das Fenster offen bleibt. Der Auruf über die cmd.exe klappt jedoch. Allerdings muss man dann die Batch-Datei mit Adminrechten ausführen, sonst verhält es sich auch über diesen Weg nicht wie gewünscht und a2cmd selbst fragt nach Adminrechten und startet in einem separaten Fenster außerhalb der cmd! Vielen Dank für Ihre Hilfe!
  2. Hallo Herr Peters, ich habe mir das nun noch mal genauer angesehen und zwischen den Infos auf Ihrer Webseite und dem Programm selbst gibt es doch inzwischen ein paar Unterschiede, vorallem betreffend die Parameter. Das ist für die Benutzer meiner Meinung nach verwirrend, vorallem wenn man von einer alten Version her ein anderes Verhalten der Parameter gewohnt war. In der Parameterübersicht im Programm selbst werden die alten Befehle "/deep" und "/smart" gar nicht mehr genannt. Dafür gibt es einen neuen Befehl "/malware". Man kann diese beiden alten Befehle zwar noch ausführen, aber dann wird einfach der Parameter "/malware" gestartet! Laut Beschreibung in a2cmd scheint mir der neue Parameter "/malware" identisch zum alten "/smart" zu sein, korrekt? Jedenfalls ist die Beschreibung bei beiden identisch. Dass Smartscan nun offenbar Malwarescan heißt, ist kein großes Thema, aber jetzt gibt es dann wohl garkeinen Parameter mehr um einen kompletten Systemscan zu machen, oder doch? Warum wurde der Deepscan denn komplett gestrichen (ist ja auch im EEK und beim Anti Malware entfallen)? Oder gibt es dafür noch einen undokumentierten Befehl? Soweit zu den Unterschieden. Wäre meiner Meinung nach also schon sinnvoll die Webseite anzupassen, da die Parameter zum Teil ja garnicht mehr das machen, was dort beschrieben ist. Eine weitere Bitte bzgl. a2cmd (möchte dafür nicht extra noch einen Thread aufmachen): Wenn man einen Scan durchführt, erscheinen in der Konsole zuerst folgende Zeilen: Emsisoft Commandline Scanner v. 10.0.0.5366 © 2003-2015 Emsisoft - www.emsisoft.com Emsisoft Commandline Scanner - Version 10.0 ...danach folgen weitere Scandetails. In den Logfiles wird aber immer nur der Inhalt ab der dritten Zeile abgespeichert. Es ist also nicht ersichtlich mit welcher genauen Programmversion gescannt wurde, sondern man sieht immer nur die Hauptversion "10.0" aus der dritten Zeile. Das ist nicht sehr praktisch, falls man Logfiles länger aufbewahrt und man später nachvollziehen will, was da mit welcher Version ausgeführt wurde. Würde mich freuen, wenn der Inhalt des Logfiles auch die oberen ersten Zeilen enthalten würde oder die exakte Versionsnummer in die dritte Zeile geschrieben wird. Lieben Dank.
  3. Hallo Emsisoft-Team, dieses Thema hatte ich im Februar hier schon mal gestartet: http://support.emsisoft.com/topic/16751-commandline-scanner-verhalten-nach-beendigung-einer-aktion/ Da der Thread inzwischen leider archiviert wurde und man nicht mehr darauf antworten kann, starte ich das Thema noch mal neu. Mein Problem ist, dass sich a2cmd nach z. B. einem Scan sofort beendet wenn man es über eine Batch ausführt. Es bleibt also keine Zeit das Ergebnis des Scans durchzulesen. Über die Eingabeaufforderung bleibt es hingegen offen und so hätte ich es auch gerne per Batch. Christian Peters konnte dieses Verhalten reproduzieren und wollte es weitergeben aber seitem habe ich dazu leider nichts mehr gehört. Ist a2cmd also wirklich nur per Eingabeaufforderung so aufrufbar, dass es offen bleibt bis der Benutzer per Tastendruck o.ä. reagiert? Mich würde mal interessieren, wie andere Benutzer a2cmd aufrufen. Per Batch oder über andere Scripts? Kann mir nicht vorstellen dass sich jeder immer erst per Eingabeaufforderung zur EXE durchhangelt und es so "umständlich" aufruft. Startet ihr es über andere Wege und verwendet dann nur den Rückgabewert für weitergehende Aktionen? Würde mich freuen wenn jemand vom Emsisoft-Team nochmal Rückmeldung zu meinem Problem gibt. Lieben Dank!
  4. Hallo Emsisoft-Team, laut Fabian Wosar sollte beim Commandlinescanner ab Version 10 unter anderem der Parameter "/deep" wegfallen: http://support.emsisoft.com/topic/17160-eek-cmd-über-gpos/?p=130038 Auf der Produktseite ist dieser Parameter aber weiterhin aufgelistet. Ist "/deep" also immer noch nutzbar oder die Seite nur nicht auf dem neuesten Stand? Falls letzteres, bitte mal die Seite um alle neuen oder veränderten Parameter aktualisieren. Lieben Dank!
  5. Hallo Herr Peters, wegen einer Zeile Text müssen wir nicht extra die Mailprogramme bemühen. Hier der Inhalt meiner Batch für den Quickscan: start "" "C:\Emsisoft a2cmd\a2cmd.exe" /quick Dies dann einfach als .bat speichern und ausführen.
  6. Hallo Emsisoft-Team, ich habe mich gerade mal mit dem Commandline Scanner beschäftigt und mir gefällt das Tool soweit gut. Allerdings habe ich folgendes Problem: Wenn ich a2cmd.exe per Batch-Datei anspreche (z. B.: start "" "Pfad zum Programm\a2cmd.exe" /quick) und z. B. einen Scan starten lasse, dann meldet sich die Benutzerkontensteuerung von Windows und wenn ich den Zugriff erlaube, startet a2cmd.exe und der Scan wird auch wie gewünscht durchgeführt. Nach dem Scan schließt sich das Fenster aber sofort, so dass keine Zeit bleibt um sich die Anzeigeinfos durchzulesen. Auch nach einem Update oder wenn ich a2cmd ohne weitere Befehle aurufe (dann sollte ja der Text mit allen verfügbaren Befehlen erscheinen), schließt das Fenster gleich wieder. Bei Scans habe ich mir erstmal so beholfen, dass ich ein Logfile schreiben lasse und dieses dann durchlese. Wäre aber schöner, wenn das Fenster offen bliebe, bis ich eine Taste drücke o.ä. Wenn man a2cmd.exe über die Eingabeaufforderung (mit Adminechten) aufruft, dann bleibt das Fenster hingegen offen. Geht das per Batch also nicht anders? Ist es also relevant, ob a2cmd direkt per Batch angesprochen wird oder über die cmd.exe? Die nötigen Rechte bekommt es über die Benutzerkontensteuerung ja eigentlich ebenfalls. Ist das nun ein Bug? Oder gibt es noch einen Befehl den ich beim Aufruf per Batch anhängen kann, damit das Fenster offen bleibt? Zumindest bei einem Update würde ich schon gerne lesen, ob selbiges geklappt hat oder keine Updates verfügbar sind o.ä. Falls dieses Verhalten aktuell nicht zu ändern ist, wäre es toll, wenn ihr ggf. noch einen Befehl integrieren würdet, der das Fenster bei Bedarf offen hält. Würde mich freuen von euch zu hören.
  7. In Ordnung Fabian, dann liegt mein beschriebenes Porblem also an meiner Konfiguration und ist kein Bug. Sollte mir doch mal wieder ein echter Bug über den Weg laufen, melde ich mich wieder. Norgetroll, Danke für den Tipp, aber mit dem EEK hätte ich das Kontextmenü ja gar nicht und dieses bisschen Komfort wollte ich dann doch nicht missen. Aber da es ja wie erwähnt nicht mehr so funktioniert wie ich es gerne hätte, wäre EEK vielleicht eine gute Option
  8. Hallo Fabian, Danke für diese Infos. So kann ich das Verhalten besser nachvollziehen. Verwundert hat mich nur, dass es beim Kontextmenü-Scan ohne oder mit vorherigem Öffnen vom EAM-Fenster einen Unterschied macht. Dass der Dienst normalerweise auf automatisch steht, war mir garnicht mehr bewusst, denn ich benutze EAM nur als on Demand Scanner und ich kann mich nicht erinnern den Dienst erst kürzlich umgestellt zu haben. Müsste also schon lange auf manuell gewesen sein aber mein Problem tritt erst seit ein paar Versionen auf! Habt ihr in diesem Zusammenhang in letzter Zeit etwas umprogrammiert? Naja, zur Not lass ich den Dienst eben immer laufen, wollte ich aufgrund meiner Verwendung von EAM aber nicht unbedingt.
  9. Hallo Emsisoft-Team, ich hoffe, folgender Fehler wurde im Forum nicht bereits erwähnt, habe jedenfalls nichts dazu gefunden. Es tritt folgendes Problem auf, was ich auch mehrmals reproduzieren konnte: Wenn der EAM-Dienst "a2service.exe" aus ist (Starttyp ist manuell), man nun zunächst EAM öffnet und dann eine Datei per Kontextmenü scannt, startet der Scan nicht. Der Mauszeiger ändert sich kurz zum Lade-Icon aber mehr passiert nicht. Erst wenn man das EAM-Fenster schließt und dann noch mal eine Datei per Kontextmenü scannen will, klappt es und der Scan startet. Sobald der Dienst aber läuft, tritt dieser Fehler nicht mehr auf. Man kann EAM öffnen und dann Scannen und alles funktioniert wie gewünscht. Weitere Beobachtung: Wenn der Dienst aus ist und man nicht erst EAM öffnet sondern gleich per Kontextmenü scannt, funktioniert der Scan! Fehler tritt auf mit EAM 8.1.0.33 unter Windows 7.
  10. Hallo Emsisoft-Team, Habe ein seltsames Problem beim manuellen Scannen festgestellt (benutze den Freeware-Modus): Wenn ich eine oder mehrere Dateien per Kontextmenü scannen lasse und EAM zu diesem Zeitpunkt noch nicht offen ist, dann stimmt alles. Wenn ich dann per Kontextmenü gleich nochmal Dateien scannen lasse ohne EAM nach dem ersten Scan zu schließen, läuft der Scan zwar durch (kommt mir dann etwas zu schnell vor als ob nichts gescannt wird), oben steht dann aber gescannte Objekte: 0. Schließe ich EAM nach dem ersten Scannen jedoch und scanne dann ein zweites mal Dateien per Rechtsklick, wird auch wieder bei gescannte Objekte was angezeigt und es scheint normal zu laufen. Dass der zweite Scandurchlauf scheinbar nichts scannt, passiert auch wenn ich einen "eigenen Scan" übers Programm starte und danach dann gleich noch einen per Kontextmenü. Auch dann steht beim zweiten wieder gescannte Objekte: 0. Lasse ich jedoch einen "eigenen Scan" laufen und gehe danach auf "neuer Scan" um wieder zur Scanauswahl zu kommen und mache dann nochmal einen "eigenen Scan", klappt das jedesmal normal und gescannte Objekte werden entsprechend auch gezählt. Diesen Punkt "neuer Scan" hat man ja auch nach einem Scandurchlauf per Kontextmenü dann unten rechts zum anklicken... klicke ich dort nach einem Scan per Kontextmenü um in der Scanauswahl zu landen und mache dann noch einen Scan per Kontextmenü, klappts wieder nicht: gescannte Objekte: 0. Da scheint sich also je nach Kombination irgendwas nicht zurückzusetzen o.ä. Bisschen umständlich das kurz und knapp zu erklären aber ihr wisst sicher was ich mit den vielen Worten hier zu beschreiben versuche Vermute ja mal ich bin nicht der einzige mit diesem Phänomen... Hilfe!
  11. Hallo Emsisoft-Team, zunächst einmal mein Lob für das neue Anti-Malware 6.0. Nutze es zur Zeit zwar nur im Freeware-Modus und profitiere von einigen guten Neuerungen daher nicht aber zumindest die Sachen wie bessere Performance, die lizenzunabhängig sind, finde ich schon mal super. Auch die Benutzeroberfläche weiss hier und da nun besser zu gefallen Nun aber zu meinem Anliegen: Im Freeware-Modus wird beim Ausführen von EAM auch der Wächter mitgestartet (a2guard.exe) und residiert dann sichtbar als Trayicon. Wenn EAM beendet wird, bleibt der Wächter jedoch gestartet und weiterhin im Tray. Da man im Freeware-Modus jedoch keine Funktionen des Wächters nutzen kann, frage ich mich warum die a2guard.exe überhaupt mitgestartet wird. Die einzigen Nutzen des Trayicons scheinen mir im Freeware-Modus die dadurch erscheinenden Popups bei Updates usw. zu sein und die Menüpunkte bei Rechtsklick, letzteres hat man aber auch in der Aufgabenliste z.B. übers Startmenü. Mag sein, dass es die meisten heutzutage nicht stört wenn ein Prozess mehr oder weniger unnötig läuft aber sofern die a2guard.exe im Freeware-Modus keine wichtige Funktion haben sollte, wäre es super wenn sie sich beim Schließen von EAM mitbeendet (ggf. auch optional über die Einstellungen festzulegen). Denn gerade bei der Freeware-Variante ohne Aktivschutz scheint mir das immer anbleibende Trayicon (noch dazu, dass in dessen Rechtsklickmenü "Wächter beenden" steht, der ja eh nicht nutzbar ist) etwas irreführend. Würde mich über eine Rückinfo freuen
  12. Hallo Emsi, finde ich gut, dass ihr sofort auf Feedback reagiert! Falls es bzgl. meiner 2 letzten Punkte zu Änderungen im Programm kommen sollte, wäre eine Info darüber hier im Thread super. Habe des weiteren meinem Nickname alle Ehre gemacht und mir die deutsche Sprachdatei genauer angesehen. Folgende Fehler/Korrekturen sind mir noch aufgefallen: Variable: msgStatusUpdate1-4 Fehler: "Password" Korrektur: "Passwort" (damit einheitlich, in anderen Variablen ist es auch auf deutsch) Variable: msgObjectsNotQuarantined Fehler: "ausgwählten" Korrektur: "ausgewählten" Variable: chkIDSHosts Fehler: "Hosts file" Korrektur: "Hosts Datei" (damit einheitlich, in anderen Variablen ist es auch auf deutsch) Variable: labSettingsVista Fehler: "verfügar" Korrektur: "verfügbar" Variable: labMalwareIDSVista Fehler: "verfügar" Korrektur: "verfügbar" Variable: msgID_ROOTKITMemo Fehler: "The diagnosed behavior is similar to that of Rootkits." Korrektur: Satz löschen oder übersetzen (befindet sich nämlich inmitten einer deutschen Beschreibung) Variable: labThanks Fehler: "Ihrers PCs" Korrektur: "Ihrer PCs" oder "Ihres PCs" Variable: msgDonwloadingProgress Fehler: "upgeloaded" Korrektur: "upgeloadet" (ist auch nicht ideal aber nicht ganz so schlimmer Anglizismus, ansonsten evtl. "hochgeladen") Variable: msgRunWizard Fehler: "Sicherheits-Assisenten" Korrektur: "Sicherheits-Assistenten" Variable: msgID_DIALERMemo Fehler: "ausserhalb" Korrektur: "außerhalb" Würde mich freuen wenn diese Änderungen auch noch eingepflegt würden. MfG, FriendlyTester
  13. Hallo allerseits, bin seit neuestem Benutzer von "a-squared Free". Läuft soweit alles super, mein Dank an das Emsi-Team für diese super Software! Habe allerdings folgende Mängel entdeckt: 1. Schreibfehler in der deutschen Sprachdatei (de-de.lng vom 05.10.09): im Menü "PC Scannen" -> Wählen Sie bitte die GEWÜNSCHE Scan Methode... 2. Bevor ich einzelne Dateien über das Kontextmenü scannen lasse, führe ich meistens unmittelbar davor zuerst ein Update aus. Wenn ich nach dem Update a2free geöffnet lasse und per Kontextmenü eine Datei scannen will, wird der Scan allerdings nicht durchgeführt! Das Programmfenster wird lediglich in den Vordergrund gebracht und a2free reagiert ca. 3 Sekunden garnicht. Um per Kontextmenü zu scannen, muss ich also nach dem Update immer erst a2free schließen und dann per Kontextmenü neu öffnen und scannen lassen. Das gleiche Verhalten besteht auch wenn a2free ohne zu updaten einfach so vor einem Kontextmenü-Scan geöffnet wird. Könnte dieses Verhalten evtl. geändert werden? Vorallem wenn der A2Service Dienst ausgeschaltet ist, werden so ja anscheinend 2x unnötig die Signaturen in den Speicher geladen wegen a2free starten -> schließen -> starten (erkläre ich mir jedenfalls so aufgrund des jeweils langen Programmstarts, auch wenn unmittelbar hintereinander ausgeführt). Zum Schluss noch eine Frage bzgl. des Scans von Archiven. Werden nur die 3 beschriebenen Formate (cab, rar, zip) vollstädnig unterstützt? Beim Scan von 7-Zip Archiven (.7z) ist mir etwas aufgefallen: Ich habe z.B. ein 7z Archiv mit 29 Dateien (überwiegend DLLs). Scanne ich dieses als Archiv, zeigt das Scanergebnis, dass nur 2 Dateien gescannt wurden. Entpackt, werden alle 29 gescannt. Zum Vergleich ein zip Archiv mit 6 Dateien. Gepackt werden alle 6 im Scanergebnis genannt. Entpackt genauso. Funktioniert bei a2free die Untersuchung von 7-Zip Archiven also noch nicht richtig oder entsteht dieses Ergebnis irgendwie durch verschiedene Scanalgorithmen zwischen 7z und zip?