Jump to content

andrewek

Member
  • Content Count

    1073
  • Joined

  • Last visited

  • Days Won

    13

Posts posted by andrewek

  1. Hello!

    I agree that reinstalling is unlikely to help😔
    Apparently, I have to wait ... Thanks for the desire to help!
     
    ...Trying to exclude all possible causes of the problem, I want to ask again:
    Can the application O&O ShutUp settings (such as, for example, access to the file system) cause a crash a2guard?
    I ask because on that day (when the crash started) only 2 events happened:
    EAM was updated to version 2020.6.0. and I applied ShutUp settings.
    p.s. Of course, I returned the changed settings back, but to no avail.
    p.p.s.
    I want to say that now, after disabling notifications, the a2guard.exe crash has stopped!
     

    0.jpg

  2. Hello!

    What am I supposed to do?
    So live and work with this problem?
     
    You have not received my crash dump sent from the EAM interface?
    Very curious, what's there? What is the reason?
     
    I see  for myself 3 ways of further developments of events:
    1) Wait for the decryption of the crash dump logs ( app.terminated - a2guard.exe.)
    2) Wait for the new version of EAM to appear.
    3) Reinstall EAM.
     
    If you think that reinstalling EAM will help me, which installation file should I choose to download?

    0 (2).jpg

  3. Hello all!

    I tried on a laptop - disabled Core Isolation.
    Crash problem  (a2guard.exe) - persisted 🙄 (when the notification about removable devices is On)
    If notifications are turned Off, there is no crash.
     
    Of course, I'm not an expert, but, probably, the reason is really in Sciter ( modern UI Development) - after all, only this NEW one appeared in EAM?

    https://sciter.com/

    p.s. For the sake of the experiment:

    I turned On the Core Isolation on a stationary computer - there is no crash of a2guard.exe.

    This is evidence that this Windows setting has nothing to do with it!

    However, it is incomprehensible - notifications about removabledevice are included On a stationary computer - but there is no crash ...

    It seems this is some kind of local EAM problem on my LAPTOP😔

  4. 4 hours ago, GT500 said:

    It could be related to the new version of Sciter (the framework we use to build EAM's UI) we updated to in EAM 2020.6. When we do that, there's always the possibility of new UI related bugs, and the content of the notifications is displayed using Sciter just like everything else in the UI.

     

    My assumption would be that it probably isn't, however we haven't tested this recently so I can't know for certain.

    If you turn it off and restart the computer, does that have any effect on the issue?

    Hello!

    Exactly this is something new at EAM!
    Because BEFORE the EAM update (Sciter) (2020.6) - I had NO problems with the crash of a2guard.exe😒
     
    Ok, I’ll try to turn off isolation and look at the crash problem.
    Then can you turn Core Isolation back On without harming the system?
     
    p.s. EAM has been working for me for a whole year (!) with Core Isolation turned On without crash problems.
    So, the reason, most likely, is not in this setting of Windows, but with a new element in EAM😌
    Agree, this is a logical argument?
  5. ok, I'll do it and look

    Done!

    I turned off removable notifications on the laptop (!) - and surprisingly 😉- the a2guard.exe crash did not happen when the device was connected!

    However, I again sent a message to Emsisoft about the crash.

    It was successfully sent to my mailing address. Screen, of course, in Russian.

    Of course, the situation is completely incomprehensible to me:

    on a stationary PC today everything is fine,

    but on a laptop - the problem of disabling the message about external media fixed the problem!

    I wonder what’s the matter here?

     

    2020-06-03 11_49_22-Application terminated.png

    2020-06-03 12_05_08-Emsisoft Anti-Malware Home.jpg

  6. 23 minutes ago, GT500 said:

    Something is preventing the computer from resolving the IP addresses for arctic.emsisoft.com and dl.emsisoft.com. Have you already checked this computer's HOSTS file for any lines containing "emsisoft"?

    Also, is there any other security software installed that could be filtering DNS requests? Adguard for Windows perhaps?

    Yes, AdGuard 7.4.1

    But can this possibly be the reason for the crash of a2guard.exe  when connecting to USB?

  7. Ok, done!

    I have three logs: a log from a stationary computer (1), a log from a laptop (2), and a third - from a laptop when the usb is connected, when a2guard.exe crashed again (3).🤥
     
    I will add also that today on a stationary computer, even when connecting a USB - there are no problems.
    Only on a laptop!
    p.s. I did not make any changes to the system settings and EAM.
    In general, everything is somehow incomprehensible ...

    EmsisoftDiagLog.txt EmsisoftDiagLog.txt EmsisoftDiagLog.txt

  8. 2 hours ago, JeremyNicoll said:

    What does the eventlog record for a2guard.exe terminating look like?  (hopefully it's in English) but more to the point should show the type of exception and address in the module...

    Also, did EAM offer to send a dump to Emsisoft?

     

    Yes, I managed to send a message with my mailing address!
  9. Yes, I suggested sending a dump, but all the time an error occurred while sending! is not sent.
    Unfortunately, the message is only in Russian!
     
    I tried several times, and each time after connecting the USB, the program stopped working.
     
    The problem is only when connecting something.
    Otherwise, EAM works without problems.
     
    Specifically: I plug in a flash, EAM displays a message about the need for verification (or not) and after a few seconds it stops working.
    But it easily starts again manually.
     
    p.s. The only new app is O&O ShutUp with the recommended settings. Can this application cause this crash?

    2020-06-02 20_29_51-Application terminated.jpg

  10. Hello all!

    This is me again)😌
    At first I thought it was an accident ...
    But no - the error is repeated on two (!) systems after each connection of any external storage medium (USB, external SSD, etc.)
     
    a2guard.exe stops working after connecting an external device. In the previous version of EAM this was not)
    It seems that this is some kind of error of the new version?

    2020-06-02 18_04_51-Application terminated.jpg

×
×
  • Create New...