Czarlii

Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Czarlii

  • Rank
    New Member
  1. When Google Chrome updated to version 31 an issue appeared when running Online Armor (and it continues in latest Chrome versions). It seems it has to do with the new sandboxing features introduced in Chrome. The problem appears only when using Online Armor HIPS features. I have OA configured to let me decide which applications can connect to Internet and which to trust. After updating to the new Chrome it stopped working. From debug logs you can find out that Chrome fails to launch child processes. Here are OA logs when launching Chrome: Program Guard: chrome.exe,14/8/2014 3:23:08 PM,Allowed,C:\Program Files (x86)\totalcmd\TOTALCMD64.EXE -> c:\Program Files (x86)\Google\Chrome\Application\chrome.exe Program Guard: chrome.exe,14/8/2014 3:23:08 PM,Allowed,c:\Program Files (x86)\Google\Chrome\Application\chrome.exe wants to get a list of the files C:\Windows\Performance\WinSAT\DataStore\* * Formal.Assessment (*).WinSAT.xml Program Guard: kernel event,14/8/2014 3:23:08 PM,None,"OADriver: OB_OPERATION_HANDLE_DUPLICATE, PID: 5040, pid: 2512, SP: 274352944, TP: 274352944, Mask: 1FFFFF - 1FF414",2512 - chrome.exe 5040 - chrome.exe Program Guard: kernel event,14/8/2014 3:23:08 PM,None,"OADriver: OB_OPERATION_HANDLE_DUPLICATE, PID: 5040, pid: 2512, SP: 274352944, TP: 274352944, Mask: 1FFFFF - 1FFBCC",2512 - chrome.exe 5040 - chrome.exe Program Guard: chrome.exe,14/8/2014 3:23:09 PM,Allowed,c:\Program Files (x86)\Google\Chrome\Application\chrome.exe -> c:\Program Files (x86)\Google\Chrome\Application\chrome.exe Program Guard: kernel event,14/8/2014 3:23:09 PM,None,"OADriver: OB_OPERATION_HANDLE_DUPLICATE, PID: 5040, pid: 4736, SP: 274352944, TP: 274352944, Mask: 1FFFFF - 1FFBCC",4736 - chrome.exe 5040 - chrome.exe Program Guard: kernel event,14/8/2014 3:23:09 PM,None,"OADriver: OB_OPERATION_HANDLE_DUPLICATE, PID: 5040, pid: 4736, SP: 274352944, TP: 274352944, Mask: 1FFFFF - 1FF414",4736 - chrome.exe 5040 - chrome.exe This did not occur in Chrome 29. The solution to this problem was to add "chrome.exe" to trusted programs in OA. Then it works fine. But this issue continues to occur in other application that use Chromium Embedded Framework. In earlier versions of Chrome it was enough to Allow for internet connections and program worked fine. Now I have to completely trust all programs that embed Chromium engine, for them to work. There is a lot of applications that internally embed Chromium engine, so this issue is not limited only to Google Chrome. It's not a big issue for me now, since I understand where the problem lies. But for other users this might be troublesome and would be great if there was a fix for that in OA. Thank you for the great software. Using latest OA 7.0.0.1866 on Win7 x64.
  2. I have text size set to 144 dpi (Larger 150% in Control Panel > Appearance and Personalization > Display) and fonts in Online Armor GUI are very tiny, it's hard to read. Is there any fix for that? It seems that OS display scaling is disabled, but there is no support for High DPI displays. Looks like SetProcessDpiAware is called, as I couldn't find DPI awareness manifest embedded in oaui.exe. Thank you for this great software. Using Online Armor Free version 7.0.0.1866 (latest). On Win7 64bit.