trujwin

No hyperlinks formed for this exe file

Recommended Posts

The latest CNET download app does not create any hyperlink in the history tab. Is it because it is unusually located in the User appdata area outside the program files. In fact none of the occurence of appstore main.exe created any traceable link. Just for info.

Share this post


Link to post
Share on other sites

Would it be possible for you to send me a copy of your history.dat file in a private message? You will find it in the directory you installed Online Armor to (normally C:\Program Files\Online Armor). Note that you will have to close and shutdown Online Armor in order to access the file.

Also, you will probably have to ZIP the file to attach it to a private message, so if you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to "Send To", and clicking on "Compressed (zipped) Folder".

Share this post


Link to post
Share on other sites

Would it be possible for you to send me a copy of your history.dat file in a private message? You will find it in the directory you installed Online Armor to (normally C:\Program Files\Online Armor). Note that you will have to close and shutdown Online Armor in order to access the file.

 

 I think this is coded into the program and not an unique occurence and I am not too sure if this is a normal behavior by OA. Can you please check how it is at your end.

Share this post


Link to post
Share on other sites

Strangely the main application whose image name is CBSI.AppStore.Main.exe does not find a place in the Programs >> Program name. I checked it while running and it did not generate any history event too.

Share this post


Link to post
Share on other sites

OK, we'll probably need some logs to see what the problem is. Open Online Armor, go to 'Options' in the menu on the left, click the little check box to enable debug mode, restart your computer, then try running this CNet download manager again, and then check the history in OA to verify the issue is still happening. After that, please ZIP your entire logs folder (normally C:\Program Files\Online Armor\Logs) and attach it to a reply for me. Note that, if you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to "Send To", and clicking on "Compressed (zipped) Folder".

Share this post


Link to post
Share on other sites

Hi,

I have updated to OA 1860. Even with this unfortunately the application CBSI.AppStore.Main.exe is neither flagged nor finds a mention in the History or Programs list. I am logged in as the admin. Could be system specific but wanted to bring it  your kind attention. Thanks.

Share this post


Link to post
Share on other sites

I don't think we were ever able to reproduce the issue. I'll bring it to Andrey's attention, and see if he has any ideas.

Share this post


Link to post
Share on other sites

Could you please send us the history.dat file that has this broken link in it? You can ZIP the file and send it to me in a private message.

The history.dat file should be in the main Online Armor folder.

Share this post


Link to post
Share on other sites

Presently when I click History in OA it is fully blank. And anyway if run the suspected program it is not listed. Would it help in any way if I send it now? Ok I am sending it right now to your box....

Share this post


Link to post
Share on other sites

Hi Andrew and GT 500, OA 1866, the said file CBSI.AppStore.Main.exe which resides in C:\Users\XXXX\AppData\Roaming\CBS Interactive\Download App does not create an alert. I tried putting some other batch file in the above folder and started it , which is duly flagged. So no issue about the folder.

Next I tried changing the CBSI.AppStore.Main.exe  to test.exe and this is also not flagged. So obviously OA is disregarding the fingerprint of the software. I have just for the sake attached the main.exe file. It will not run due to lack of other files , but do note that OA does not raise an alert before it is started...

 

I think you need to sort out this too...

Share this post


Link to post
Share on other sites

Just wanted to correct myself. Today I installed the upgraded version of the CNET app and since there was no alerts , out of curiosity I checked the exclusions and it was there! Perhaps since the program would not function properly earlier , I had that excluded and it stayed that way. :blush: :blush: Apologies!! Once I removed it out of exclusions OA duly alerted. :thumbs:

 

GT 500 can you include this as a suggestion. Can the history be made to list even the excluded alerts with a tag of excluded (like you have allowed or blocked) and the hyperlink made to point to the folder in the excluded list. That way users will be sure of the actions..  BTW do we see any result to the History list bug.. :)

Share this post


Link to post
Share on other sites

GT 500 can you include this as a suggestion. Can the history be made to list even the excluded alerts with a tag of excluded (like you have allowed or blocked) and the hyperlink made to point to the folder in the excluded list. That way users will be sure of the actions..  BTW do we see any result to the History list bug.. :)

There may be an issue with that. Exclusions means that Online Armor completely ignores everything in that folder, so no monitoring of the process is done at all, and thus there would be nothing to log.

As for the history list bug, I'm not sure where Andrey is on that. I haven't seen any updates on the bug report.

Share this post


Link to post
Share on other sites

You have got a point. But In effect OA verifies everything and when it finds it is excluded it stays quiet. So technically it should be possible to include an entry of the excluded items too..

Share this post


Link to post
Share on other sites

You have got a point. But In effect OA verifies everything and when it finds it is excluded it stays quiet. So technically it should be possible to include an entry of the excluded items too..

My understanding, from what Andrey has told me in the past, is that when something is excluded Online Armor will completely ignore it. It is possible that Online Armor is still aware on some level that a program in an excluded folder has launched, however I don't know the technical details in regards to how it actually works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.