JakeHardy

Don't alert for update to this executable file

Recommended Posts

Hey everyone,

i have a small problem with Emsisosft anti-malware,

when a alert pop up saying the the program has changed i tick (Don't alert for update to this executable file), then press ok, but during the next update it happens again,

i have gone to the guard and found the exe's(Don't alert for update to this executable file) is not ticked, when i do maunally tick it i think it stops alerting me

Share this post


Link to post
Share on other sites

May I ask what programs you are having this issue with? Also, is this just on Windows 7 x64, or is it on other versions of Windows as well?

Share this post


Link to post
Share on other sites

Please allow me to apologize for taking so long to get back to you. I thought I had already replied to your post on April 19th.

I'll let our developers know about this, and see what kind of debugging information they would like me to collect for them.

Share this post


Link to post
Share on other sites

Please allow me to apologize for taking so long to get back to you. I thought I had already replied to your post on April 19th.

I'll let our developers know about this, and see what kind of debugging information they would like me to collect for them.

ok, thank you

Share this post


Link to post
Share on other sites

Our developers have asked for a DebugView log. Before running DebugView, we'll need to set a registry entry that will tell Emsisoft Anti-Malware to output debug information that DebugView can see and save in its log. The following file eam_debug_output.zip contains two batch files. One of the will enable debug mode, and the other will disable it. Please download this file, extract the batch files from it, and run the batch file named eam_enable_debug_output (if your computer is running Windows Vista or Windows 7 then please make sure to right-click on the batch file and select to Run as administrator):

After that, please restart your computer, and then proceed with the instructions below:

  • Download DebugView from this link:
  • When downloading, make sure to save it on your Desktop instead of clicking 'Run' or 'Open'.
  • Right-click on the 'DebugView' file that you just saved on your Desktop, and select "Extract All".
  • Before running DebugView, you will need to add a process exclusion to Emsisoft Anti-Malware to prevent crashing issues. Here are the instructions:
    • Please go ahead and open Emsisoft Anti-Malware from the icon on the desktop.
    • click on Guard in the menu on the left.
    • Go to the File Guard tab.
    • Click on the Manage whitelist link on the left, just above 'Alerts'.
    • On the left, under where it says Type, click on where it says File and change it to Process.
    • Click in the white space to the right of where you just changed 'File' to 'Process', under where it says Item, and a little button with three dots on it will appear to the right.
    • Click on the button with the three dots.
    • Navigate to the folder where DebugView is saved (this should be on your desktop), select the Dbgview file, and click the Open button in the lower-right.
    • Click OK at the bottom to save the settings, and then close Emsisoft Anti-Malware.
  • Open the new DebugView folder that was created on your Desktop after extracting.
  • Windows XP and 2000 users should double-click on the file named 'Dbgview'. Windows 7 and Vista users should right-click and select "Run as Administrator".
  • Click on the 'Capture' menu, and select everything except "Log Boot" (you will have to open the menu again after clicking to select an item).
  • Do whatever it is you need to in order to replicate the issue with the warning about changes to a program.
  • After that, please go to 'File' and save the log on your desktop.
  • Please attach that log file to a reply so that we may analyze it for errors. You will need to use the More Reply Options button to the lower-right of where you type in your reply in order to access the attachment controls.
  • Note: You may need to ZIP the log file in order to attach it. If you do not have a program such as 7-Zip, WinZip, WinRar, etc. then you can right-click on the log file, go to Send to, and click on Compressed (zipped) folder. You will be able to attach the ZIP archive to a reply.
After that, you can run the eam_disable_debug_output batch file to disable debug mode. Note that your computer will need to be restarted after running the batch file.

Share this post


Link to post
Share on other sites

OK, I have let our developers know that you have posted logs, and they will take a look at them as soon as possible. ;)

Share this post


Link to post
Share on other sites

I got an e-mail from one of our developers earlier today, and they are confident that they were able to determine the cause of the issue. Hopefully a fix will be forthcoming soon. ;)

Share this post


Link to post
Share on other sites

I got an e-mail from one of our developers earlier today, and they are confident that they were able to determine the cause of the issue. Hopefully a fix will be forthcoming soon. ;)

thats awesome, thanks!

Share this post


Link to post
Share on other sites

You're quite welcome. ;)

You may want to keep an eye on this forum for the next week or two, just in case a beta update is released that deals with this issue.

Share this post


Link to post
Share on other sites

It looks like Andrey hasn't been able to get a new beta of Online Armor ready yet. Unfortunately we don't have any ETA's (mostly because, in the software industry, you can never meet an ETA and still produce a quality product).

Share this post


Link to post
Share on other sites

There have been a number of beta updates to Emsisoft Anti-Malware, and the current beta version is 8.0.0.7. Does the issue still happen with the latest beta installed?

Share this post


Link to post
Share on other sites

I've created a new bug report in our system on this. Hopefully it will get some more attention now. ;)

Share this post


Link to post
Share on other sites

One of our developers just let me know that they had already fixed this, and they are not able to reproduce the issue in the latest version of Emsisoft Anti-Malware. If you are still having issues, then follow the instructions I posted earlier to get us a fresh DebugView log so that I can send it to our developers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.