ruirib

OA taking up 100% CPU

Recommended Posts

Lately OAserve.exe has been causing my system to become unresponsive, as it starts using one full core of the CPU. It only stops if I shut down OA. Internet access is frequently lost or slows to a crawl when this happens.

 

What do I need to do to determine what is causing this?

 

Running OA Pro 6.0.0.1736 on Windows 7 x64.

Share this post


Link to post
Share on other sites

We'll probably need some logs to see what the problem is. Please open Online Armor, go to Options in the menu on the left, click the little check box to enable debug mode, restart your computer, and then try reproducing your problem. After that, please ZIP your entire logs folder (normally C:\Program Files\Online Armor\Logs), upload it to a website such as RapidShare/DepositFiles/BayFiles/etc (which one you use is up to you), and then copy and paste the link to download the file into a reply (or you can send it to me in a Private Message if you don't want the link posted publicly on the forums). Note that, if you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to Send To, and clicking on Compressed (zipped) Folder.

Note that RapidShare and BayFiles have been having issues lately, and we may not be able to download the files from them. If you have DropBox, Google Cloud Storage, or Microsoft SkyDrive then those services would be more reliable. Also, you can attach files to private messages on these forums, and I would believe the limit is up to 128MB, so if the file is smaller than 128MB then you can just attach it to a private message to me on these forums.

Share this post


Link to post
Share on other sites

I'll be trying to reproduce it. It was easier before, now after applying the monthly Windows patches, that I had postponed, it hasn't happened yet. When it does, I will update the topic.

 

Thanks.

Share this post


Link to post
Share on other sites

I have forwarded your link to our developers, and I will let you know once they have had a chance to look at the logs.

Share this post


Link to post
Share on other sites

If you have new nvidia card with somewhat latest drivers, it comes with streamer service. I noticed that the executable doesnt take any cpu in itself but while blocked from internet, it spiked my online armor cpu usage to almost max with one core (zone alarm does the same). Killing that file from task manager (nvstreamsvc.exe) lowers online armor cpu usage to 0.

 

you can disable it from running by pressing windows key + r, typing in services.msc. find NVIDIA Streamer Service and setting the start up type to Disabled.

Share this post


Link to post
Share on other sites

The latest version didn't improve this a bit, and actually made it worse. Now the problem occurs not only in Windows 7, but also in Windows 8.1. 

My Core 2  Duo CPU grinds to a standstill, with CPU usage above 50%. My laptop is an i5, dual core, dual threaded. Frequently CPU spikes to around 25% and although this is a recent processor and there is a full core doing nothing, internet access still crawls because of OA.

 

It's really a shame, I love OA and I have been a vocal advocate of the benefits of running OA at the forum I admin, but I fear I will have to stop recommending it, because this behavior makes it unreliable. It makes no sense to run a HIPS that needs to be restarted every hour or so or that needs to be shutdown in older machines, in order to get work completed.

  • Upvote 1

Share this post


Link to post
Share on other sites

Lets get an OTL log, and see if it shows the cause of the issue. Please run OTL by following the instructions below:

  • Click this link to save OTL onto your desktop (please make sure to click 'Save' instead of 'Run').
  • Double click on the OTL icon on your desktop to run it. Make sure all other windows are closed and to let it run uninterrupted.
  • Click the Run Scan button. Do not change any settings unless otherwise told to do so. The scan will take a few minutes.
  • When the scan completes, it will open two Notepad windows. OTL.Txt and Extras.Txt. The first one (OTL.txt) will be automatically saved on your desktop next to OTL, and the second one will need to be saved manually.
  • Please make sure that both OTL.txt and Extras.txt are saved on your desktop, and then attach both of them to a reply so that we can take a look at them.

Share this post


Link to post
Share on other sites

Lets try this:

  • Click on the Start button, go to All Programs, go to Online Armor, and click on the Online Armor icon to open it.
  • Click on Options in the menu on the left.
  • Go to the Exclusions tab.
  • Click on the Add button.
  • Use the little [+] and [-] icons to the left of folder names to open and close them, find the TeamViewer folder (C:\Program Files (x86)\TeamViewer), click on it to highlight it, and then click OK at the bottom.
  • Close the Online Armor window.
  • Restart the computer.

Share this post


Link to post
Share on other sites

That was done long ago, so that is not the problem. Meanwhile, I can state that the exclusion of TeamViewer didn't solve the issue on Windows 8.1, either.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.