Jump to content

OA doesn't start automatically


Recommended Posts

Hello,

 

I have windows 7 64bits.

I have Microsoft security essential and OA version 6.0.0.1736 installed on my PC.

I use an administrator account.

At the moment, I can start OA manually, but when I go to the services, if I try to activate the automatic start for OA service (oasrv.exe), I get an error message saying "access refused".

I would like to have OA to start automatically, when windows starts.

If possible, I would like Microsoft Security essential to be deactivated, but not removed.

 

--> How is it possible to do this ?

Link to post
Share on other sites

Hello,

 

first disable the MSE real time protection.

 

1. Open MSE

2. Click the Settings tab.

3. Click Real-time protection.

4. Uncheck the box next to Turn on real-time protection (recommended).

5. Click the Save changes button.

 

Now disable the MSE service.

 

1. Press the WIndows key + R.

2. Type in services.msc and press OK.

3. Look for the entry Microsoft Antimalware Service.

4. Double-click the entry and set the start up type to disabled.

 

Now please reboot the computer. Now you are able to start the Online Armor service oasrv.exe?

Link to post
Share on other sites

Christian,


Thanks for your very clear answer.

I followed each step carefully.


1/ No probs with deactivating the real time protection for the MSE.

When i accessed the services, I double clicked on Microsoft Antimalware Service :

"c:\Program Files\Microsoft Security Client\MsMpEng.exe"

but the popup window is dimmed. It is not possible to change the settings from automatic to manual.

2/ I reboot the computer in the hope that sth might happen. The MSE is deactivated now.

I tried to access the services.msc and change the settings of OA to automatic. That time it worked.

 

3/ I rebooted the computer again. The OA is now running automatically.

 

Thanks again.

Link to post
Share on other sites

If you would like MSE and OA to be able to coexist, then here are instructions on how to add exclusions to resolve the performance/freezing issues cause by having both installed and running.

To create an exclusion in Microsoft Security Essentials, please follow these instructions (note that you may need to restart your computer in Safe Mode before doing this, and you can find instructions for that at this link):

  • Open Microsoft Security Essentials.
  • Go to the Settings tab.
  • Select Excluded processes from the menu on the left.
  • Click the Add button on the right.
  • Using the little [+] and [-] buttons to the left of folder names to open and close them, navigate to the Online Armor folder, select the file you wish to exclude, and click OK to add it.
  • Repeat the last two steps until you have added each of the following files:
    • oacat
    • oahlp
    • oasrv
    • oaui
  • Be sure to click the Save changes button in the lower-right corner when all of the files have been added.
Please note that the Online Armor folder should be as follows:

C:\Program Files\Online Armor

On 64-bit editions of Windows, it will be a bit different:

C:\Program Files (x86)\Online Armor

Here are instructions to add Microsoft Security Essentials to the exclusions in Online Armor (be sure to restart your computer if it is running in Safe Mode, as Online Armor will not run in Safe Mode):

  • Open Online Armor.
  • Go to Options in the menu on the left.
  • Go to the Exclusions tab.
  • Click on the Add button.
  • Using the little [+] and [-] buttons to the left of folder names to open and close them, navigate to the Microsoft Security Essentials folder, click on the folder to select it, and click OK to add it.
  • Be sure that the option to also exclude subfolders is selected before closing Online Armor.
The Microsoft Security Essentials should be in C:\Program Files or C:\Program Files\Common Files, and it may be named Microsoft Security Client.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...