marzametal

EAM - tabs are not populating

Recommended Posts

Hi...

 

I am having a bit of an issue with tabs that can be populated... such as Logs (File Guard, Quarantine, Update, Scan), Guard (Host Rules). I left out Logs (Behavior Blocker, Surf Protection) because for some reason they still populate.

 

I think this started a couple of weeks ago, maybe thee. Thinking back a couple of weeks, I haven't installed any applications or done anything out of the ordinary to my system that could cause this little issue.

 

The Host Rules tab does not populate automatically, nor does it provide me with that little box saying something about populating. I have to manually uncheck the "My Own" option in that tab, then check it again for the list to populate. In relation to the Logs tabs, it takes about 20-30 seconds for them to populate, and the entries are provided line by line, or all at once. It varies.

 

This happens regardless of how long my PC is running, or whether or not the EAM screen is on-screen or in the taskbar. The issue occurs even if I have MalwareBytes fully disabled and shut down (do not load at restart). I have exceptions for EAM, OA, MBAM and AdMuncher Pro placed in exceptions tabs as recommended by other posts on this forum.

 

Any ideas?

 

My details:

EAM 8.1.0.19

Windows 7 Home Premium SP1 64bit (no updates to install, well critical ones that is...)

OA Premium 7.0.0.1866

MBAM Pro 1.75.0.1300

AdMuncher Pro 4.93.33707/4956

Share this post


Link to post
Share on other sites

I had a similar issue on my machine and what I did was under Configuration-logging, I changed the figure for each to 300 instead of 3000 and rebooted.

 

However the size of my logs.db3 file was over 3MB and had become corrupted so I deleted the log.db3 file and rebooted. EAM re-creates it on re-boot.

 

That solved the issue for me although I have lowered the figure from the 3000 default.

 

(of course make sure you only delete the log.db3 file which is inside the logs folder under EAM Program Files)

Share this post


Link to post
Share on other sites

lmao... yours were 3000, mine are 30000! Lets give this a shot...

 

EDIT:

I changed the values to 300.

I rebooted into Safe Mode to delete the log.db3 file, then properly rebooted.

 

RESULTS:

I still need to click on the "My Own" checkbox to populate my Hosts list.

The Logs tab and sub-tabs appear to be working fine now. The "File Guard" and "Quarantine" sub-tabs are empty. I think this is the case because those two issues have no new entries.

 

In relation to the custom host rules I have created, the a2user.dat file in the EAM directory is only 9kb, so the filesize cannot be the issue that is causing the delay in populating. It opens up in notepad successfully, so I think it isn't corrupt.

 

Thanks for your help stapp, now I am just left with this last issue and all is well!

Share this post


Link to post
Share on other sites

The problem is solved, however only after 2 other problems happened...

 

Not long after I posted the above message, OA kicked up a fuss yet again about svchost.exe, which stalled my PC. I waited 5 minutes then forced a reboot. Upon reboot, I noticed that EAM was not loaded, so I went into the Start Menu and loaded it. The licence had disappeared again so I inputted it and went through the wizard.

 

Now the Host Rules list loads up automatically... *sigh*

 

Man, how the hell do I avoid these destructive svchost popups? I don't think it would be safe to ignore them though...

Share this post


Link to post
Share on other sites

Hi GT500, no I did not. The Hosts File contains blocked hosts that I have collected as I browse. They have not been imported, just created on-the-fly.

Share this post


Link to post
Share on other sites

OK, lets get some debug logs from Emsisoft Anti-Malware. In order to do this, you will first need to run a batch file to enable debug logging. This batch file is contained in the ZIP archive at the this link (this ZIP archive also contains a batch file to disable debug logging).

Please save that ZIP archive on your desktop, extract its contents, and then follow these instructions:

  • Run the enable_debug_output batch file (if your computer has Windows Vista, Windows 7, or Windows 8 then please right-click on the batch file and select Run as administrator).
  • You will see a black window pop up, and then disappear very quickly. After that happens, please restart your computer.
  • Reproduce the issue you are having with the Host Rules list not populating.
  • Once you have reproduced the issue, hold down the Windows key on the keyboard (the one with the Windows logo on it, usually in between the Ctrl and Alt keys) and tap the R key to open the Run dialog.
  • Type the following into the Run dialog, and then click OK:

    %ALLUSERSPROFILE%\Emsisoft
  • A window should open and you should see a Logs folder. Right-click on that Logs folder, go to Send to, and select Compressed (zipped) folder.
  • Move the new ZIP archive you created with the logs folder in it to your desktop.
  • Attach the ZIP archive containing the logs to a reply by using the More Reply Options button to the lower-right of where you type in your reply.
Note: If you get an error message when trying to send the Logs folder to a Compressed (zipped) folder then you may need to try a utility such as 7-Zip or WinRar to compress the folder. Both 7-Zip and WinRar have options to create an archive and save it in another location (such as on your desktop), which should prevent the error message. Here are links to the download pages for 7-Zip and WinRar.

After posting the debug logs, you can run the disable_debug_output batch file (be sure to run it as administrator as well) and restart your computer again to disable debug logging.

Share this post


Link to post
Share on other sites

Thanks GT500 for the response and the smooth instructions.

I have created the Zip file that you requested.

 

I did the following when I was asked to to replicate the problem...

1) Maximised EAM via Task Bar

2) Clicked on Guard

3) Clicked on Host Rules

4) Empty list - unticked then reticked My Own and my custom rules were returned.

 

I did this twice.

 

Share this post


Link to post
Share on other sites

OK, I have created a bug report on this, and our developers will take a look at it as soon as they can.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi GT500...

Did the Emsisoft Team manage to fix this bug? I've been checking the Hosts tab for the past 2 days, and it is now working like a charm... just wondering if that is due to the teams efforts or not... take care bud!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.