worgeordie

Anti Malware Guard will not load.

Recommended Posts

Today one of my computers has a problem,when I start everything loads up

OK, after a few minutes Windows 7 reported that Emsisoft was not working,

then a pop up occurred on screen saying    A major problem has prevented the 

application from starting        The Anti Malware Guard cannot connect to the service application. 

Please reboot your PC and try again,or contact support.

 

So I rebooted same problem, so I uninstalled  ALL of Emsisoft and reinstalled from scratch,

going through everything nothing found in the scan. after few minutes still has same problem

 

It was working OK this morning, switched off, rebooted couple hours later have this problem.

Its a Win 7 ultimate 32 bit, other security,windows firewall, Hitman Pro (scan only),WinPatrol Plus,

 

Its like everything is frozen in Emsisoft ,click icon system tray,not work, same icon on desktop.

 

Have installed no new programs lately

 

Hope someone can help, in simple terms please, this pc I am posting from Ok will check my others. 

kind regards Worgeordie

Share this post


Link to post
Share on other sites

I  have had to  remove Emsisoft completely for my computer, 

scanned with lots anti virus engines and they found no infections 

at all.my other 3 PC s with Emsisoft are working OK, but on this

one I have had to install Avast free and it is working fine.will use

this until I can get help with why Emsisoft will not work.

regards Worgeordie

Share this post


Link to post
Share on other sites

We are working on collecting debug information about the issue. If you wish to try and reinstall Emsisoft Anti-Malware on the computer that is having the issue and help by collecting Debug Logs, then please let me know.

Share this post


Link to post
Share on other sites

We have determined that this issue is related to our Host Rules. On certain computers running Windows 7 (specifically slower computers such as netbooks, or ones that are older or having performance issues for other reasons) the Emsisoft Anti-Malware service does not start in time, and the Windows system that controls services terminates the service because it took too long to start.

It is possible to replace the Host Rules with an older (and smaller) version to temporarily get Emsisoft Anti-Malware working again, however please note that once Emsisoft Anti-Malware updates its database it will download a new copy of the Host Rules, and if you restart your computer you will once again not be able to start Emsisoft Anti-Malware. If you want to try this workaround to the issue in order to get Emsisoft Anti-Malware working again, then you would either have to leave your computer on all the time (at least until we are able to release a fix for the issue), or you would need to disable automatic updates in order to prevent the Host Rules from being updated.

If you would like to try the workaround, then I have attached an older version of the Host Rules (host_rules.zip) to this message. You can simply save it on the desktop of the computer that is having the issue, and follow the instructions below:

  • Right-click on the host_rules file you saved on your desktop, and select to extract it.
  • Find the Emsisoft Anti-Malware folder, which should be in one of the following locations:
    • C:\Program Files\Emsisoft Anti-Malware
    • C:\Program Files (x86)\Emsisoft Anti-Malware
  • Copy the a2hosts.dat file that you extracted from the file on your desktop into the Emsisoft Anti-Malware folder (you can right-click on the file to copy, and then when looking at the contents of the Emsisoft Anti-Malware folder you can click on Organize and select Paste).
  • Select to Copy and replace when it asks you about the existing file.
  • When Windows asks you to provide administrator permission to copy the file, click on Continue to finish copying the file.
  • Once the file has been copied, please try launching Emsisoft Anti-Malware from the icon on the desktop, and that will also start the protection.

Share this post


Link to post
Share on other sites

Please note that a fix for this issue has been released in a beta update, and you can enable beta updates in Emsisoft Anti-Malware to download and install the update. Here's how to do that:

  • Open Emsisoft Anti-Malware.
  • Go to Configuration in the menu on the left.
  • Go to the Update Settings tab.
  • Enable the Use beta updates option.
  • Run an update in Emsisoft Anti-Malware.

Share this post


Link to post
Share on other sites

Please note that a fix for this issue has been released in a beta update, and you can enable beta updates in Emsisoft Anti-Malware to download and install the update. Here's how to do that:

  • Open Emsisoft Anti-Malware.
  • Go to Configuration in the menu on the left.
  • Go to the Update Settings tab.
  • Enable the Use beta updates option.
  • Run an update in Emsisoft Anti-Malware.

 

How am I supposed to do this when every Emsisoft  icon i click will NOT open anything,

so cannot get to GUI ?, 

regards Worgeordie

Share this post


Link to post
Share on other sites

Try deleting the following file, and then launching Emsisoft Anti-Malware to enable Beta Updates:

C:\Program Files\Emsisoft Anti-Malware\a2hosts.dat

Or, on 64-bit editions of Windows:

C:\Program Files (x86)\Emsisoft Anti-Malware\a2hosts.dat

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.