Sign in to follow this  

A major problem has prevented the application from starting

Recommended Posts

I am having the same error message.  I also had the message that indicated the program could not connect to the server.  So far I have just uninstalled and reinstalled. No difference.  Please help.


os is windows 7 professional

Share this post

Link to post
Share on other sites

Lets get some debug logs from Emsisoft Anti-Malware. In order to do this, you will first need to run a batch file to enable debug logging. This batch file is contained in the ZIP archive at the this link (this ZIP archive also contains a batch file to disable debug logging).

Please save that ZIP archive on your desktop, extract its contents, and then follow these instructions:

  • Run the enable_debug_output batch file (if your computer has Windows Vista, Windows 7, or Windows 8 then please right-click on the batch file and select Run as administrator).
  • You will see a black window pop up, and then disappear very quickly. After that happens, please restart your computer.
  • Try opening Emsisoft Anti-Malware.
  • Once you have tried to open Emsisoft Anti-Mawlare, hold down the Windows key on the keyboard (the one with the Windows logo on it, usually in between the Ctrl and Alt keys) and tap the R key to open the Run dialog.
  • Type the following into the Run dialog, and then click OK:

  • A window should open and you should see a Logs folder. Right-click on that Logs folder, go to Send to, and select Compressed (zipped) folder.
  • Move the new ZIP archive you created with the logs folder in it to your desktop.
  • Attach the ZIP archive containing the logs to a reply by using the More Reply Options button to the lower-right of where you type in your reply.
Note: If you get an error message when trying to send the Logs folder to a Compressed (zipped) folder then you may need to try a utility such as 7-Zip or WinRar to compress the folder. Both 7-Zip and WinRar have options to create an archive and save it in another location (such as on your desktop), which should prevent the error message. Here are links to the download pages for 7-Zip and WinRar.

After posting the debug logs, you can run the disable_debug_output batch file (be sure to run it as administrator as well) and restart your computer again to disable debug logging.

  • Upvote 1

Share this post

Link to post
Share on other sites

We have determined that this issue is related to our Host Rules. On certain computers running Windows 7 (specifically slower computers such as netbooks, or ones that are older or having performance issues for other reasons) the Emsisoft Anti-Malware service does not start in time, and the Windows system that controls services terminates the service because it took too long to start.

It is possible to replace the Host Rules with an older (and smaller) version to temporarily get Emsisoft Anti-Malware working again, however please note that once Emsisoft Anti-Malware updates its database it will download a new copy of the Host Rules, and if you restart your computer you will once again not be able to start Emsisoft Anti-Malware. If you want to try this workaround to the issue in order to get Emsisoft Anti-Malware working again, then you would either have to leave your computer on all the time (at least until we are able to release a fix for the issue), or you would need to disable automatic updates in order to prevent the Host Rules from being updated.

If you would like to try the workaround, then I have attached an older version of the Host Rules ( to this message. You can simply save it on the desktop of the computer that is having the issue, and follow the instructions below:

  • Right-click on the host_rules file you saved on your desktop, and select to extract it.
  • Find the Emsisoft Anti-Malware folder, which should be in one of the following locations:
    • C:\Program Files\Emsisoft Anti-Malware
    • C:\Program Files (x86)\Emsisoft Anti-Malware
  • Copy the a2hosts.dat file that you extracted from the file on your desktop into the Emsisoft Anti-Malware folder (you can right-click on the file to copy, and then when looking at the contents of the Emsisoft Anti-Malware folder you can click on Organize and select Paste).
  • Select to Copy and replace when it asks you about the existing file.
  • When Windows asks you to provide administrator permission to copy the file, click on Continue to finish copying the file.
  • Once the file has been copied, please try launching Emsisoft Anti-Malware from the icon on the desktop, and that will also start the protection.
  • Upvote 1

Share this post

Link to post
Share on other sites

Please note that a fix for this issue has been released in a beta update, and you can enable beta updates in Emsisoft Anti-Malware to download and install the update. Here's how to do that:

  • Open Emsisoft Anti-Malware.
  • Go to Configuration in the menu on the left.
  • Go to the Update Settings tab.
  • Enable the Use beta updates option.
  • Run an update in Emsisoft Anti-Malware.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.