Jump to content

Problem with Firefox file dialog when Online Armor is active


torob
 Share

Recommended Posts

Hi.

 

A while ago I got problems with Firefox was not able to save pages. When I use File -> Save Page As the file dialog / requester never pops up. It's the same issue with Open file, and when downloading or uploading. The box where you select the file does not appear.

 

First i though this was a problem with Firefox and tried many things, but the problem is still the same. But if I quit Online Armor everything works fine. When I start Online Armor again, the problem is back.

 

I have tried to delete firefox.exe from both the Firewall and Programs listings, and let Online Armor automatically add it, but still the same.

 

I use the latest version of both Online Armor (7.0.0.1866) and Firefox (27.0.1).

 

Anyone have any tips how to solve this issue?

 

Link to comment
Share on other sites

Please try the following:

  • Right-click on the little Online Armor icon in the lower-right corner of the screen (to the left of the clock).
  • Select Learning Mode from the list.
  • Try launching Firefox and save a webpage.
  • Close Firefox.
  • Turn off Learning Mode.
  • Open Firefox again, and try saving a webpage again to see if it works without Learning Mode now.
Let me know if that helps.
Link to comment
Share on other sites

Hi, and thank you for the reply.

 

I followed these instructions, but it doesn't work either in learning mode or when returning to normal mode.

But I also tried to quit and shut down Online Armor afterwards, and then it work fine again. But when I start Online Armor again, the problem is back.

Link to comment
Share on other sites

Have you added exclusions for avast! yet? It may be related to recent issues between avast! and Online Armor rather than just Online Armor blocking a function in Firefox.

If you haven't, then here are some instructions for adding a folder to the Exclusions list in Online Armor:

  • Click on the Start button, go to All Programs, go to Online Armor, and click on the Online Armor icon to open it.
  • Click on Options in the menu on the left.
  • Go to the Exclusions tab.
  • Click on the Add button.
  • Use the little [+] and [-] icons to the left of folder names to open and close them, find the folder you want to add, click on it to highlight it, and then click OK at the bottom.
  • Close the Online Armor window.
The folder would be something like "C:\Program Files\AVAST".
Link to comment
Share on other sites

Adding exclusions to avast! for Online Armor might help. You may have to contact their support for instructions on setting global exclusions, but I am fairly certain that you can exclude the entire Online Armor folder, which should be in the following location:

C:\Program Files\Online Armor

Link to comment
Share on other sites

I tried this too, at the same time when added exclusions in Online Armor, but problem is still the same.

 

But when I upgraded Firefox to version 28.0 yesterday, it was working fine the first time I started Firefox after the upgrade. But when I closed it, and started it again, the problem is back. Still, if I shutdown Online Armor temporary, then it works as it should, but not when I start Online Armor again.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...