Jump to content

Firewall Not Running on Windows Login


Recommended Posts

On seeing the message of the releasing getting close, I gave the EIS 9 a try and found the same problem.


With the latest built got from the website, the installation was fine and everything ran, until I restarted the machine to find out the firewall being the only component not running.

Manually I can activate it again and it seems to be working, but then if I restart it won't run on its own, once again.


Running a Windows 8.1 Surface Pro without any other software except office 2013, let me know if there is anything useful I can provide.

Link to comment
Share on other sites

Hello, I split your post into another topic since it appears to be a different issue.

Lets get some debug logs from Emsisoft Internet Security. In order to do this, you will first need to run a batch file to enable debug logging. This batch file is contained in the ZIP archive at the this link (this ZIP archive also contains a batch file to disable debug logging).

Please save that ZIP archive on your desktop, extract its contents, and then follow these instructions:

  • Run the enable_debug_output batch file (if your computer has Windows Vista, Windows 7, or Windows 8 then please right-click on the batch file and select Run as administrator).
  • You will see a black window pop up, and then disappear very quickly. After that happens, please restart your computer.
  • Reproduce the issue you are having with the firewall not loading on startup, and then try activating it manually.
  • Once you have reproduced the issue, hold down the Windows key on the keyboard (the one with the Windows logo on it, usually in between the Ctrl and Alt keys) and tap the R key to open the Run dialog.
  • Type the following into the Run dialog, and then click OK:

  • A window should open and you should see a Logs folder. Right-click on that Logs folder, go to Send to, and select Compressed (zipped) folder.
  • Move the new ZIP archive you created with the logs folder in it to your desktop.
  • Attach the ZIP archive containing the logs to a reply by using the More Reply Options button to the lower-right of where you type in your reply.
Note: If you get an error message when trying to send the Logs folder to a Compressed (zipped) folder then you may need to try a utility such as 7-Zip or WinRar to compress the folder. Both 7-Zip and WinRar have options to create an archive and save it in another location (such as on your desktop), which should prevent the error message. Here are links to the download pages for 7-Zip and WinRar.

After posting the debug logs, you can run the disable_debug_output batch file (be sure to run it as administrator as well) and restart your computer again to disable debug logging.

Link to comment
Share on other sites

Btw, one more thing, in Win8.1 the Windows firewall is necessarily on in order to install apps, kind of non-sense but that's simply the case.

With EIS 9 it no longer stops me from installing the Windows Apps, but then it automatically switch off my firewall, even I manually turn it back on, EIS shut it down again.


Is there a way to make them co-exist?

Link to comment
Share on other sites

We are aware of the issue with installing apps and the Windows Firewall. I don't think there is currently any way to make the two coexist so that you don't have problems with installing apps. Our developers will have to look into this further and see if they can find a way around this issue. ;)

Link to comment
Share on other sites

Thanks for noting that down, and in fact this is a more serious issue than any others:

Many users simply don't know how to turn the Windows Firewall back on, or it usually needs admin rights; this means many people by using EIS 9 will then suffer from not being able to install any apps, it would be almost a must to take care of.


Actually, I remember when I installed Symantec Endpoint Security, they do also turn off the Windows Firewall, but the message is sth like "The Firewall is now being handled by Symantec Endpoint Security", so Windows actually recognized that as a firewall opened. Maybe this is rather a interfacing issue? Hope you can get it solved shortly.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...