vertigo262

OpenVPN connection issues

Recommended Posts

Hi,

 

I am using online Armor, but there seems to be a problem using OpenVPN.

 

The VPN seems to connect, taking longer the usual, but eventaully connects. It looks like their is no DNS information. It can't transfer any packets.

 

I'm not sure what is the cause of this, but things I've tried, is bypassing the folder in the exclusions, didn't work

I tried putting it in learning mode, or standard to see if it would configure something I was missing. didn't work

 

made sure the programs are allowed in program and firewall. didn't work.

 

I looked at debug mode, but didn't really understand what I was doing,  but the default IP, netmask, and dns were wrong so I put them to 0.0.0.0

 

I have no idea what it is, but any help would be appreciated.

 

 

Share this post


Link to post
Share on other sites

If you are running Online Armor Premium, you can switch Online Armor into "Advanced Mode" and disable the "Filter invalid MAC addresses" option under Options/Firewall. Most VPNs use MAC addresses for the virtual devices that are non-standard. So this option which is enabled by default can cause all kinds of problems when using a VPN.

Share this post


Link to post
Share on other sites

That doesn't seem to be it. If I turn off the firewall component it works, but on it doesn't.

If I delete all the rules and let it create them, and allow everything, it still doesn't work

Share this post


Link to post
Share on other sites

Can you please enable logging under Options/Firewall. Set it to log blocked events only. That should give us some insight what exactly is blocked on your system to prevent your OpenVPN from working. You can find the logs in the Online Armor installation directory under Logs.

Share this post


Link to post
Share on other sites

Ok, here are the logs while trying to connect. It connects, but no packets can traverse. I then try a ping, and connecting through filemanager.

 

this is what I would guess is the problem, but even if I allow all ICMP in the ICMP tab, same problem

 

ICMP -> Destination unreachable(Network unreachable error) 192.168.3.48 50.20.42.146
Blocked by ICMP rule
 
 

OpenVPN Logs.txt

Share this post


Link to post
Share on other sites

I've tried everything with this. Am I the only one having this problem?

 

I tried standard mode. learning mode,

 

I've erased all the firewall rules and set it on autoconfigure

 

I've enables all icmp

 

I made sure filter invalid mac is off

 

I've added the OpenVPN folder to the excludes rules.

 

It will only connect if I turn off the firewall module. And this is on multiple computers.

 

has to be others with the same problem?

Share this post


Link to post
Share on other sites

it's the Tap network

 

if I recall, but not 100% sure. if I install online armor, leave all default settings, with auto-configure, I think it may work. But if I turn auto configure on after specifying my own rules, it does not work.

 

Something I should double check. other then that, after locking things down or opening them up, it won't connect

Share this post


Link to post
Share on other sites

I don't think Online Armor supports bridged networking, which is what TAP is based upon. The main issue is that it can't assign the packets properly and just discards it. Any chance you can switch to a TUN based connection?

Share this post


Link to post
Share on other sites

In that case you may want to try the Emsisoft Internet Security 9.0 beta, which does support network bridging just fine. That is only an option if you don't care about the HIPS features of Online Armor though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.