Recommended Posts

Hi

When I try to update A-squared free, a connection error appears at the bottom saying "Could not connect to the update server. Please check your connection and proxy settings."

I don't use any proxy and my internet connection is fine as all other programs work and I can surf the web. I have tried uninstalling and disabling my firewall and antivirus and a whole alot of other things. I have even tried completely erasing them and all their related files off the registry using revo-uninstaller, but nothing seems to work.I've tried installing and uninstalling a-squared free, but that doesn't work neither.

My operating system is Vista 32bit

I use shaw secure antivirus and firewall

I'd appreciate your help with this very much.

Share this post


Link to post
Share on other sites

Hi Armin Shayegi Nick,

Welcome to the forum

Usually the message you posted displayed when EMSI server is overloaded or having other temporary problems

Users are able to update after several consequent attempts

There could be conflict with you Firewall.

I don't remember references to Shaw Secure in "Compatibility threads" in our old Forum.

Currently there is only one incompatible Firewall known - Ashampoo Firewall.

The later has to be uninstalled in order allow a-squared updates

First please answer these questions:

Can you successfully update any other security programs?

Are you experiencing any connection problems and/or issues with downloading Software... etc.?

Below are some common advices

1) Irrespectively - I hope that your native Windows Firewall is disabled.

If not, please disable it. It is necessary when 3rd party Firewall is active;

Then, one-by-one:

2)- remove all a-squared related rules from the Firewall settings;

- recreate them at the subsequent update attempt;

3) Disable you Firewall completely and see what happen;

4) Reboot into Safe Mode with Networking and try updating

That's for a start.

I hope some of those experiments may clear the situation

Keep in mind that disabling Firewall from SysTray may not give needed result.

That sometimes require additional steps as disabling related services / startup entries/ device(s) created/ etc. (you may need to contact Shaw Secure Firewall Support or their forum regarding that since new versions can bring some flavours)

... but first this first

My regards

Share this post


Link to post
Share on other sites

I've been trying for the past 10 days now so I don't think it could be bacause of an overloaded server. I've also tried updating it in safe mode which didn't work. All other security programs work and update without any problems and I don't have any problems with the internet connection or softwares. As I stated before I have already tried updating with the firewall disabled and even uninstalled. I've tried deleting a-squared free from the firewall allow list and allowing it again. but nothing seems to work. By the way I didn't disable it from the system tray.

Share this post


Link to post
Share on other sites

Hi Armin Shayegi Nick,

From your description seems to me that you have a conflict with the Firewall.

Since

... By the way I didn't disable it from the system tray.

it would be premature to state yet that it is incompatibility issue.

Please try that and what was suggested regarding "completely" disabling it.

As it was mentioned referring to Ashampoo Firewall disabling it the ordinary way did not work since

problem is your ashampoo firewall. The Layer Service Provider spi.dll provided by ashampoo blocks a-squared to update.

Currently you can only update a-squared if you uninstall ashamppo, a temporary shutdown of ashampoo does not help

http://forum.emsisoft.com/Default.aspx?g=posts&t=6313

If disabling of your Firewall is unsuccessful you (we) can report that to EMSI developers.

They will advise whether they need some additional information and the address for sending the request.

My regards

Share this post


Link to post
Share on other sites

I said it before!!! I didn't temporarily disable the firewall. I uninstalled it and cleaned off every trace of it with revo uninstaller. I've also tried ending all the related processes to the firewall from the task managers under processes!!! So again not Only I've tried updating with the firewall completely disabled, I've even tried while it didn't even exist on my computer anymore!!!

Share this post


Link to post
Share on other sites

Sorry, don't be so upset.

I was referring to the last “..I didn't disable it from the system tray” statement.

Please read this thread from the old forum.

http://forum.emsisoft.com/Default.aspx?g=posts&t=4437

Scroll down to one of the replies from Thursday, 5 February 2009 4:20:21 PM

where I posted detailed instruction for using Fiddler Utility.

note: since your OS is Vista you most likely have the latest MS .NET Framework

so you can skip the note about it there

Please try that. It helped in few occasions.

You can post results here

I will ask developers whether the address for sending data if necessary was changed.

My regards

P.S. are you using any other security with real-time residents in addition to "shaw secure antivirus and firewall"?

{added} few other things ask:

- for how long are you using a2-Free?

- during the installation there is an invitation for performing on-line update.

Was that update successful?

- Were there any successful updates after that (signatures and/or modules)?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.