dwathle

Blocking WMP crashes WinXp (solved)

Recommended Posts

I'm running WMP10 (WMP means Windows Media Player) on a WinXp Sp3 system, but research suggests that this entry probably applies to most versions of WMP/Windows.  I don't like WMP (or anything else) communicating with external systems without permission; and I blocked WMP's only listed entry by blocking wmp_setup.exe in Online Armour's  [Configuration.Firewall.Programs] listing. The system would run run fine for a while, but would eventually generate an exception.  I extracted the following info from one of the resultant Event Viewer entries.

 

  Event 26
  Application popup: oasrv.exe - Application Error : The exception unknown software
  exception (0x0eedfade) occurred in the application at location 0x7c812fd3.

 

The system would lock up in such a way that I was unable to access the Task Manager or Online Armour. I wasn't able to reset the system, and usually had to pull the plug to recover.  Testing showed that I could avoid these problems by disabling Online Armour.  Subsequent research and testing showed that WinXp ALWAYS locks up if you try to block wmp_setup.exe.from accessing the internet.  So this problem wasn't really Online Armour's fault: It was just the middle man. The bottom line is this: WinXp will eventually lock up if you try to block wmp_setup.exe via a firewall (eg. Online Armour). 

 

Further research shows that you CAN prevent wmp_setup.exe from accessing the internet as follows.

 

  Open the Microsoft Management Console (MMC) via [start Menu.Run].
  Type in "mmc", and press ENTER.
  Select [File.Add/Remove Snap In...].
  Select [Add...] from the [standalone] tab.
  Select [Group Policy] from the snap-in's selection menu.
  Select [Finish] in the Welcome-To-The-Group-Policy-Wizard. Close that window.
  The Group Policy snap-in will be added the MMC console.
  Press OK to show the updated MMC console.
  Click on "+" signs to open up [Computer Configuration.Administrative Templates.Windows Components].
  Select [Windows Media Player] in the left panel.
  Right click on [Prevent Automatic Updates] in the right-hand panel.
  Select [Properties] from the drop-down menu.
  Select [Enabled] for Prevent Automatic Updates.
  Press OK, and close the MMC console.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.