Jump to content

having a problem with firewall rule, ICMP blocking all downloads

Recommended Posts

I was exploring the firewall and permissions recently.

I had set permissions for some unknown programs from allowed to ask.

now I can not download any pdf or program installers,

when I looked into history log I saw events that were blocked by icmp rule.


I tried shutting down both Eis and Eam and downloading but the download still failed.



Is there a way to reset Eis  back to the installed condition?

I tried reset in a place or two but it didnt help.


Sould I uninstall/ clean install?


Is there an online manual for Eis, Oa. That might help for  user questions like this?


Os win 7 64 bit

Eis and Oa firewall

Link to post
Share on other sites

I bought a 2 year Eis bundle, it loaded Eam and then Oa, I activated with two keys.


The error looks like this

ICMP-> Destination unreachable(Network unreachable error)

Blocked by ICMP rule


I temporarily disabled Oa and Eam leaving the win firewall in charge but still couldn't download pdf's or cryptoprevent update.


I am puzzled by how this rule showed up, The only new activity I have been messing with was uninstalling microsoft office 2010 and its annoying




That key has been stuffing my autorun panel with 2500 copies.


Link to post
Share on other sites

Ah, so you are using Online Armor as part of the retired Emsisoft Internet Security Pack instead of the new Emsisoft Internet Security product that we released on Monday. I have moved your thread accordingly.

The rule you see in your logs is part of the default rule set of Online Armor. It isn't accessible in Standard or Banking Mode though. Instead you need to put the firewall into "Advanced Mode" first by right clicking the tray icon and selecting "Advanced Mode". After that you can go to Firewall and find a few additional tabs there. Under ICMP you will find the ICMP rules. You can just allow the ICMP packet associated with the "network unreachable" message there. That being said, this should not be the cause for CryptoPrevent being unable to update. Can you please check under Firewall/Rules/Programs and Firewall/Rules/Ports if you blocked CryptoPrevent there by accident?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...