viadud

Online Armor Service Cannot Start, But Blocks Network

Recommended Posts

Hi Online Armor team,

 

Last night, I had restarted the computer after a Windows Update. I immediately got an error from OA saying "The Online Armor Service cannot start". The effect of this was:

 

- the computer could not connect to the home network (router) anymore

- it was finding an "Unidentified Network" and was classifying it as "Public"
- it was unable to connect to the network it found

- it would not let me change the network type or anything related to the network

 

I then figured that it must have been one of the Windows Updates that was messing with the network settings. Long story short, I was up all night trying manual IPV4 Gateway overrides, uninstalling Windows Updates, reconfiguring the network adapter, rebooting constantly, replacing cables, downloading Windows hotfixes via tablet and transferring them to the computer via USB to run them, and so on. Nothing helped.

 

After 4 hours of that, I decided that I would reinstall Windows from scratch. That would mean nearly an entire day lost, but I saw no other way. Just before I did that though, I was going to try one last thing: uninstall Online Armor, just to rule out that it was the cause of the issue and not just an effect of the failed Windows Update that I thought was responsible.

 

Surprise surprise, after uninstalling OA and rebooting: everything worked again, perfectly. The computer was back online.

 

So Online Armor was the cause after all. So now, I have a couple questions regarding this.

 

1) Is there a possible explanation for the generic error message "The OA Service cannot start" - why did it keep showing the same error, even after I rolled back all Windows Updates I had done that day? This error has never appeared before.

 

2) I want to reinstall OA because I do like the program, even though I lost a night over this mess. How likely is this to happen again if I do that now?

 

3) IF this error happens again, and the computer cannot connect to the network again, and I cannot start Online Armor in the first place, what can I do to a) restore internet access and b) restore/fix Online Armor without having to do a full uninstall like this time?

 

4) I'm pretty sure I lost all my OA settings and learned rules with the uninstall. Are they retained anywhere on the system after an uninstall, so I can re-apply them when I reinstall? It will be a headache to configure new rules for all installed programs again, from scratch.

 

I hope you can help me understand these points, as I really like Online Armor. I think it's a solid piece of software that beats most others out there, and I'd like to keep using it. So I want to make sure I know how to handle such a hiccup in the future... in case it happens again.

 

Thank you.

 

 

Share this post


Link to post
Share on other sites

Hello viadud,

1) Is there a possible explanation for the generic error message "The OA Service cannot start" - why did it keep showing the same error, even after I rolled back all Windows Updates I had done that day? This error has never appeared before.

I have tried to replicate the problem on my Windows test systems but haven't been able to. Since you removed the Online Armor installation already, there is unfortunately no way to figure out what is wrong in hindsight.

 

2) I want to reinstall OA because I do like the program, even though I lost a night over this mess. How likely is this to happen again if I do that now?

That depends on what the original cause was, which is unfortunately unknown.

 

3) IF this error happens again, and the computer cannot connect to the network again, and I cannot start Online Armor in the first place, what can I do to a) restore internet access and b) restore/fix Online Armor without having to do a full uninstall like this time?

Most likely nothing. That is due to the fact that OA will continue to think it is still booting and will try to defend itself from being manipulated.

 

4) I'm pretty sure I lost all my OA settings and learned rules with the uninstall. Are they retained anywhere on the system after an uninstall, so I can re-apply them when I reinstall? It will be a headache to configure new rules for all installed programs again, from scratch.

Online Armor does not create any automatic backups of your rules. However, you can do them manually if you are using the paid version. Online Armor Free has no way of exporting or importing settings/rules.

Share this post


Link to post
Share on other sites

This may or may not be related but during the application of Windows Update KB2972216 I had a funny (funny weird not funny ha ha) alert from OA from a funny process. I blocked while I studied and it kept coming up so it must have been the MS update which was occuring then. Allowing it allowed the update to finally succeed. Update history shows it failed twice. I twice blocked.

The process and name were v4.0.30319 dated 1899-12-30 MD5 1b95e2fb7d7be30765ba575319ae06e0 Nothing found in EMSI knowledgebase

 

Forgot to mention this occured on sept 11 so it is close to the original poster's update date.

Share this post


Link to post
Share on other sites

In general it is strongly advised to run all Windows updates in Learning Mode. There can be unforeseen consequences when you end up blocking updates during the update process. Putting Online Armor into learning mode first prevents that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.