Jump to content

Cannot add/remove files to behaviour blocker!

Recommended Posts

Current fully licensed version of Anti-Malware 9.0, all stable updates as of 11AM EST today. Trial version of Online Armor, with a view to buying a license and then updating (free?) to the latest version of Internet Security (is that scenario possible?). Windows 8.1 Pro x64 (Hyper-V enabled), all MS Updates as of today.


See attached screenshot: all action buttons are grayed out, even when one list entry is selected. So I can't add or delete files in the list, I can only edit their entries by double clicking on the file path line.


What I expect: at all times the Add button should be enabled (even when a list entry is highlighted); the Edit and Remove button should be enabled when a line is highlighted. Keyboard accelerators should be similarly available: INS at all times for adding a file, and ENTER or DELETE to Edit or Remove a highlighted file entry.


Link to comment
Share on other sites


Can you please check under Settings/Permissions that your user has the permissions to edit the application list? Thanks.

I logged out of my usual account (limited user) and logged on an Administrative User (I always work in a limited regular user account) and on the Permissions page all privileges were already ticked for my limited user account.


What I then did to attempt to solve the problem was to systematically toggle all of the permissions off/on for that user account. When I logged back into my usual account, all of the greyed-out buttons on the Application Rules and Surf Protection were working correctly when no line entry was selected and when one was selected. There was just one inconsistency: when no Surf Protection line was selected, the "Add new rule" button was still grey.


So the problem could be solved by the toggle procedure, but it suggests something needs review in the UI<-->action code for those pages.

Link to comment
Share on other sites

O.K., as an experiment I uninstalled Anti-Malware and installed the latest Internet Security. Some observations:


I do all my installations while logged on my regular unprivileged account and assume (unless nothing works) that the installer will ask for elevation at the appropriate point(s) in the process.


Once I rebooted my computer after the installation and logged on to my regular account, Internet security had already created a couple of Application Rules, but the issue was the same as my original post: selected rules cannot be edited, nor is the "Add new rule" button activated. (And maybe there were anomalies on other application screens, I did not check everything.)


I then exited my usual account and loggon onto my administrative account, in order to check the Permissions screen for my regular account. Every permission was check-marked by default. I made no changes.


Finally, I returned to my regular account and lo-and-behold: the Application Rules screen now actually worked correctly, i.e "Edit rule" and ""Remove rule" were active only if a rule was selected, and "Add new rule" was active by default.


So it seems that at least one explicit log-on by an administrative user is required on my machine before the installation process fully concludes and the Internet Security defaults are entirely active.


Maybe this whole thing is unique to my environment (but I haven't do any special tweaks to Windows 8.1, it's all pretty vanilla), however this kind of thing might frustrate a lot of potential users if it happened to them.


UPDATE: Just read the thread http://support.emsisoft.com/topic/15637-grayed-out-buttons-on-windows-81-pro-x64/ and I think I might be not entirely alone on this issue. Maybe something extra is needed in the installation process, or perhaps additional per-user sanity checking when the application UI starts at log-on.

Link to comment
Share on other sites

We actually released a bug fix for this particular issue via beta updates yesterday. At least on our test systems using limited accounts it fixes the problem you are experiencing. It would be great if you could verify whether it fixes it on your system as well. You just need to enable beta updates under Settings/Updates in order to receive the fix.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...