Koosharem

Installation Issue

Recommended Posts

I'm running Win 7 Pro/64bit and SP1.  I just finished "converting" from EAM + OA Premium to EIS.  I use a 256GB SSD as the "C-drive" for the OS (primarily) and, a 2TB HD as the "D-drive" for application programs and data.   I have found some program installers do not allow the user to select the "target" drive for installation.  EAM was one of these!  I got help from the EAM Forum that told me how to use the Windows Command-Prompt function (with appropriate parameters) to direct the installation to a desired drive and folder/subfolder.

 

I attempted this same approach with EIS but was greatly disappointed!!  I very carefully went through the procedure, directing the installation to "D:\Program Files\Emsisoft Internet Security".  Instead, EIS was installed in "C:\Program Files (x86)"!! 

 

What am I  missing??  Why does the Command-Prompt approach work as expected in one instance and not another??  (It is extremely frustrating to be forced to load-up a fast, SSD with programs that do lots of "read/writes" (i.e., updates) when there is a high-capacity disk-drive available!)

Share this post


Link to post
Share on other sites

Hello,

 

this commandline switch should also work to install EIS in a specific path.

 

Can you please try to use the path D:\Program Files x86\Emsisoft Internet Security instead of the path D:\Program Files\Emsisoft Internet Security.

Share this post


Link to post
Share on other sites

Hello Christian,

 

Thank you for your prompt reply!  I appologize for my delay in responding -- I  was away on business for the rest of last week after sending my post.

 

In the  meantime, I had an opportunity to carefully review my "failed" installation process that resulted in not getting EIS installed on the D-drive -- I failed to place quotation marks ("   ") around the target-drive parameters as follows:  /DIR="D:\Program Files\Emsisoft Internet Security" !

 

I have just finished uninstalling EIS (from C-drive) and re-installing it on the D-drive using the parameter-string as above -- and, the installation was fully successful!!  So, it seems I was the "problem" all along!!

 

However, after reading your reponse regarding use of the D:\Program Files x86 path instead, raises a follow-on question/concern.  I have attempted to install all 64 bit software in the D:\Program Files path;  all other software (i.e., 32 bit) in D:\Program Files x86 path.  Since I have had no problem running EAM in the 64 bit path before changing over to EIS,  I  thought that path would be appropriate for EIS also.  I scanned the on-line EIS Help File but did not find any mention of program word-size.   Do you have any comment on my choice of installation folders??

Share this post


Link to post
Share on other sites

Hello Christian,

 

Again, I applogize for the long delay in responding -- I've been away from home again!

 

I now have no issues regarding getting EIS installed on and running from the D:\Program Files\ path.  All is well!!

 

I may have confused things by bringing up the topic of "64bit programs" vs "32bit programs" as it relates to the Windows 7 practice of segregating them on different paths for a given drive:  "Program Files\" for 64bit software and,  "Program Files x86\" for 32bit software.

 

Your first response to  this post suggested I try using the "Program Files x86" path (i.e., as though EIS was programmed for 32bit words and should be there.)  By the time I got to read your response, I had discovered my error and, proceded to compose the command-prompt correctly -- BUT -- I installed it in the "Program Files\ path (i.e., along with other 64bit programs) as this was my original intention.  

 

Everything seems to be working fine with this arrangement, as-is.  But, have I placed EIS in the "wrong path" as far as running under Windows 7 is concerned??  Is there any operational drawback to "misplacing" it there if that is the case??  More specifically, what word size is EIS programmed for??

 

Thank you for your patience in answering my questions.
                          

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.