JeremyNicoll

Shutdown & Restart of OA didn't work properly

Recommended Posts

XP Home, OA Premium V7.0.0.1866

 

I regulalry suffer from the OAsrv 50% cpu problem discussed at length elsewhere.  Some days it's much worse than other, don't know why.  Today it was making a connection to a streaming TV service impossible, so I used the systray icon's 'Close & Shutdown OA' option to stop it.

 

I've done this before and been able to restart it. But this time when I used Start - Programs - Online Armor... I saw a small animated message pane showing a progress bar and saying "synchronising with service" for maybe a minute or two.

 

After the pane was removed from the screen I found task manager showed only OAsrv & OAcat running and the systray ico did not appear.

 

I tried Start - Prohgrams - Online Armor... again.  The 'synchronising' animation was displayed again and I noticed that while it was visible TM also showed OAui running... but again when the syncing message vanished so did the OAui task.

 

Despite OAsrv and OAcat running, when I looked at Control Panel - Security Centre, it said that the windows firewall was running. 

 

I rebooted and OA started ok, as far as I can tell.

 

Did I do something wrong attempting to stop & start OAsrv in the way I did?

 

Share this post


Link to post
Share on other sites

Usually this indicates that the service didn't initialize properly for whatever reason. In general stopping OA will remove all hooks it set on the various running programs. However, in some cases hooks can't be removed without risking system instabilities. In those cases hooks may only be unloaded partially which can result in the behavior you described if you try to run Online Armor again later.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.