Emsisoft Internet Security not updating

Recommended Posts

I just merged my Emsisoft Anti-Malware & Online Armor licences together to make a unified EIS licence key, this went fine.

I then uninstalled EAM & OA, restarted the computer, installed EIS, entered the license, it seemed to accept the license fine.


Then when I tried to update EIS, its like it can't connect to the update server, even though my internet is working fine, i'm on ethernet.


Here is a screenshot to show you what I see, it tried to update for about 1-2 seconds, then fails with that screen.


Download Image

Share this post

Link to post
Share on other sites

Its says, "License Expires in: Not Available", but clicking "Show License" next to "License Key" DOES show my newly combined license, as in the picture i've attached.


I don't connect to the internet thought a proxy, I connect via an ethernet cable to an all-in-one modem/wireless router [Virgin Media Superhub 2].


Thanks for the quick reply mate

Share this post

Link to post
Share on other sites



i removed the screenshot from your posting because the key is readable.


Please click on my avatar and press the button "Send me a message". Send me your key via the personal message editor.


It looks like there is a typo error in your key.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.