Arto

High CPU usage by oasrv.exe when browsing

Recommended Posts

Whenever I am browsing the net, oasrv is hovering at around 50% CPU usage.  It stays around there until the entire page is loaded, plus about another 15 seconds.  I know it hasn't always been this way.  There are no other real apps running.  Just various drivers, etc. 

My setup:

- Windows XP SP3

- OA v 7.0.0.1866

- Avast v 7xxx

- IE 8

- Firefox 33.x

 

In Avast, the OA folder/programs are excluded everywhere there is an exclusion option.  In OA, I have excluded the avast folder.

 

Until last week, I was running OA v 6.x.  When I noticed the problem, I figured it was time to upgrade, hoping that the problem would be resolved.  However, it didn't help.  I haven't installed anything new in a long time.

 

I tried disabling the Intercept Loopback Interface option, but that didn't help.  Even when I disable Avast completely, the problem remains.

 

Regardless of the browser the result is pretty much the same. 

 

Thanks;

 

Share this post


Link to post
Share on other sites

That usually indicates that one process on your system causes an excessive amount of HIPS events causing the high CPU load. Once your system booted up, can you please try to stop processes one by one to try to figure out which of your processes causes the excessive CPU load in OA? Once you identified the process that way, you can just exclude it so OA no longer pays any attention to it.

Share this post


Link to post
Share on other sites

I think you might have misunderstood what I mean by right after boot up.  The oasrv process is fine after a reboot.  It only starts going nuts when I am browing the internet.  The more varied content on the page, the longer the process is using a lot of cpu.  CPU usage stays high for about 15 seconds after the page is fully loaded.

Share this post


Link to post
Share on other sites

So, I disabled the web shield.  There was a small improvement.  I then tried disabling the firewall (with the web shield re-enabled).  That too showed a small improvement.  I then disabled both, and performance was great, but I was unprotected.  Finally, I tried disabling Avast's shields.  That made no difference.

 

Thanks;

Share this post


Link to post
Share on other sites

Can you please check whether or not your browser's main executable or either of the browser's DLLs are listed as anything but trusted in the Programs list? If they do, does changing them to "Trusted" improve the situation?

Share this post


Link to post
Share on other sites

Both browsers' executable (plus a dll that seems to be part of IE) are all set as trusted.  I have the browsers set in 'Run Safer' mode, but even disabling that doesn't help.

 

Thanks;

Share this post


Link to post
Share on other sites

Can you please try to recreate the issue with debug logs enabled and send us the logs? Instructions on how to create those logs can be found here:

http://support.emsisoft.com/topic/3819-how-to-configure-online-armor-debug-logs/

Make sure to reboot after you enable debug logging and also remember to turn it off once you are done. Debug logs can get quite large otherwise.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.