JustMe

CLOSED EIS Firewall component - UDP blocked ping/trace?

Recommended Posts

PingPlotter and plain ol tracert and ping can't seem to get out. I have not changed any settings in the firewall screen from the defaults (still trying to understand the layout of this new firewall coming from OA). 

 

It did previously show up in the (logs,firewall) log as having automatically added it with "IN/OUT - All Allowed" HOWEVER it didn't work. While this was happening I switched over to cmd prompt and tried tracert both programs show request timed out.

 

I then tried to manually add the program via (Protection, Application rulews)  the first time it simply wouldn't add, I went to the application rules and it wasn't there.

I closed and re-opened the EIS dialog and went back to Application Rules and this time it stuck but pingplotter still failed to be able to get out, I confirmed in the log that it is there (IN/OUT - All Allowed) for the pingplotter.exe, same with tracert still times out.

 

If I disable the EIS Firewall (Protection, Firewall, Uncheck OR the Protection screen) and then re-enable the windows firewall in action center both programs work properly (tracing and pinging is not longer blocked).

 

I have attached the Protection Firewall screen and I don't recall ever modifying any rules directly on this screen, are they defaults?

 

Any ideas would be appreciated, I keep suspecting I am just not used to this layout (brain is still in OA mode) and might be missing something.

 

EIS 9.0.0.4799

Windows 8.1 pro 64bit

post-112-0-62607400-1422430443_thumb.png
Download Image

Share this post


Link to post
Share on other sites

Yes, once I realized that EIS had changed I uninstalled both EAM and OA and installed the EIS.

Are you saying that your rules screen shows the same as mine? Thanks.

Share this post


Link to post
Share on other sites

Yes, once I realized that EIS had changed I uninstalled both EAM and OA and installed the EIS. Are you saying that your rules screen shows the same as mine? Thanks.

Yes, my rules look the same.

 

Fabian's point is spot on. He is pretty good at coming up with great answers that are easy to understand.

 

It doesn't appear like there is a global rule that allows icmp out on a public network.

post-25668-0-61289300-1422555178_thumb.png
Download Image

post-25668-0-50970700-1422556193_thumb.png
Download Image

  • Upvote 1

Share this post


Link to post
Share on other sites

It doesn't appear like there is a global rule that allows icmp out on a public network.

I wanted to go back in and delete this but couldn't. This should not be interpreted that a rule should be added. It's just an observation.

Share this post


Link to post
Share on other sites

Okay, I think I found what the problem is. Please make sure that your "Traceroute replies" rule looks exactly like this:

1KCzwEe.png

It looks like the default rule set has the wrong ICMP packet type set. You will have to turn the firewall off and on again for the change to become active. We will fix the default set in one of the next updates.

  • Upvote 1

Share this post


Link to post
Share on other sites

The type of the network you are in may make a difference. Is your local network set as a public or private network?

That was it, when set to private it works properly (Protection, Firewall, Manage Networks).

Thanks for the info on the traceroute rule, I will just wait for the update as I am not sure why I even set it to public.

Share this post


Link to post
Share on other sites

Thanks for the info on the traceroute rule, I will just wait for the update as I am not sure why I even set it to public.

Per default EIS uses the Windows network settings. So if you said Windows the network is a public network, EIS will automatically set it as a public network as well.
  • Upvote 1

Share this post


Link to post
Share on other sites

Strage. Maybe that is why I have the blocked not stealhed Port issue. My current network is ID'd by EMIS 9 as being a "private network" - Ethernet-Local Area Connection

 

As far as I know I have not made any changes in Windows Default settings and it was a totally fresh install of Windows 8.1.

 

For any new connections,  EMIS says it's set for 'PUBLIC NETWORK" AND TO USE WINDOW'S DEFAULT SETTINGS.

 

During my most recent use of a fresh/virgin/use  of Windows 8.1 on a new PC, during set-up, Windows was unable to detect my internet connection - said something about invalid DNS or IP address. It only was able to detect my connection after I reset/restsrted/rebooted my modem. So when I did that did I unknowingly set up a private network?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.