nunnbt473

OA Doesn't Show all connections / programs blocked?

Recommended Posts

Long story short I have an application which has a particular UDP port being blocked that I cannot identify.

I run a popular gaming platform for some of my games, steam. This in turn launches the actual game(s) I've selected. The only problem is, since installing OA, I can't play one of my games. OA has allowed the steam.exe app on multiple protocols / ports. It has allowed the game on multiple protocols / ports.. but suddenly I cannot join a lobby, even after allowing TCP/UDP in/out on all port (0-65535) in steam.

The game (Call of Duty, Black Ops II Multi-player or "t6mp.exe") never shows in the history as being blocked.

Disabling OA firewall allows me to instantly join a game however. Learning mode doesn't seem to help. Allowing t6mp.exe on UDP 0-65535 fixes the problem.

 

Share this post


Link to post
Share on other sites

My recommendation is to add both the Steam folders and the game folder to the exclusions in Online Armor. Here are some instructions for adding a folder to the Exclusions list in Online Armor:

  • Click on the Start button, go to All Programs, go to Online Armor, and click on the Online Armor icon to open it.
  • Click on Options in the menu on the left.
  • Go to the Exclusions tab.
  • Click on the Add button.
  • Use the little [+] and [-] icons to the left of folder names to open and close them, find the folder you want to add, click on it to highlight it, and then click OK at the bottom.
  • Close the Online Armor window.
On Windows 7 x64, the Steam folders should be as follows:
  • C:\Program Files (x86)\Steam
  • C:\Program Files (x86)\Common Files\Steam
Most Steam games can be found in the following folder (unless you had Steam install them somewhere else):
  • C:\Program Files (x86)\Steam\SteamApps\common
Please note that when you add the Steam folders, you don't need to check the box to include subfolders, but I do recommending checking the box to include subfolders for the game folder.

Share this post


Link to post
Share on other sites

I find if i disable program guard when Im in the "library" before starting the game, then turning it back on after the game's overlay and intro window comes up has worked, I think because Battleeye, the anti cheat system has needed alot of permissions, like to use the boot editor, and pops the command prompt window up and prints out that it has blocked oasrv and another OA file, i forget which at the moment.

 

But to get into Steam itself, I need to turn off the firewall, then I turn it back on when Im in the library, otherwise it will always say "no connection" at the bottom.I have to turn it off again when I get to the multiplayer server search screen to enter the game, it can usually be turned back on once Im in the multiplayer game.

 

Hope this info helps someone for something :)

Share this post


Link to post
Share on other sites

Per default Online Armor does not log blocked or allowed packets. These logs will grow huge over time and they rarely include useful information. If you do want Online Armor to keep logs about blocked or allowed connections, you have to enable them first under Options/Firewall.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.