itman

EAM 9 Update Problems

Recommended Posts

First, I am not using beta version.

 

EAM update appears to be "stuck." It keeps trying to update and just keeps resetting itself. Gets to 18% then back to 1%. This started around 4 PM EST or so. A reboot doesn't help. It just starts updating again. Also saw a weird domain being used; wordpress.emsisoft.com. 

 

How can I fix this?

Share this post


Link to post
Share on other sites

Are you still having update trouble?

No. Update this morning was fine.

 

BTW - this updating issue has occurred two evenings in a row. Hope its finally straightened out.

Share this post


Link to post
Share on other sites

There still might be an issue on first update after resuming from WIN 7 sleep mode. EAM update sat at 96% for a while until it finally completed. Hourly updates thereafter ran fine.

Share this post


Link to post
Share on other sites

It's possible that it was downloading a large file, or that something else was using bandwidth at the same time and slowing down the update process. You can use the Resource Monitor in Windows to check and see what is using your Internet connection. Here's a link to information on using the Resource Monitor to check network/Internet usage.

Share this post


Link to post
Share on other sites

I'll just add to this thread instead of creating another, if that's all right?

 

Recently decided to try Emsisoft Anti-Malware, combined with Comodo Firewall, and tonight (for me) I see an update issue. I have it set to update automatically till midnight, and now (around 3:20 AM) I did a manual update and it said it required a reboot. All right, rebooted, then did another manual update to be sure and again asked for reboot. Odd, said yes again, then the same thing happened. All 3 times, it downloaded emalware.204 twice, the first time along with other files, the other two times alone. Guessing that for some reason it can't update this, or it's listed twice in the update list and tries to overwrite itself twice over at once, prompting a file already in use error?

Either way, when will it get fixed?

Share this post


Link to post
Share on other sites

I'll just add to this thread instead of creating another, if that's all right?

 

Recently decided to try Emsisoft Anti-Malware, combined with Comodo Firewall, and tonight (for me) I see an update issue. I have it set to update automatically till midnight, and now (around 3:20 AM) I did a manual update and it said it required a reboot. All right, rebooted, then did another manual update to be sure and again asked for reboot. Odd, said yes again, then the same thing happened. All 3 times, it downloaded emalware.204 twice, the first time along with other files, the other two times alone. Guessing that for some reason it can't update this, or it's listed twice in the update list and tries to overwrite itself twice over at once, prompting a file already in use error?

Either way, when will it get fixed?

 

Should be fixed now :)

Share this post


Link to post
Share on other sites

I have been having update issues that start after 4 PM EST in the U.S.. Been going on for over a week. Yesterday was OK for a change, but today it started again! EAM starts to update and just appears to hang in some type of loop. It gets to 25% or so and then reverts to 1% and repeats again, and again, and again ................ Then it just quits and doesn't attempt any further updating. Correction - its trying again like that little red train engine that wouldn't quit.

 

Prior to 4 PM EST, updates complete with no problem. Also no problem with other software updates, so this is not a bandwidth issue with my ISP.

Share this post


Link to post
Share on other sites

Please download and install Fiddler 2 from this link (this is the version that requires the Microsoft .NET Framework 2.0), and then follow the instructions below:

  • After installing Fiddler, please open it from the Start Menu.
  • Launch Emsisoft Anti-Malware.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top
  • Click on the Proxy settings button on the right side, in the middle.
  • Check the box that says Use proxy.
  • Enter localhost in the Server field, and then enter 8888 in the Port field.
  • Click OK.
  • Click the Update now button above the Proxy settings button.
  • After the update fails, go back to Fiddler, and to File, then Save, and select All Sessions (please save it on your desktop).
  • Please send me the Fiddler log in a Private Message (do not post in in a reply).
Note that you may need to ZIP the log to be able to attach it to a Private Message. If you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to Send To, and clicking on Compressed (zipped) Folder.

Share this post


Link to post
Share on other sites

Please download and install Fiddler 2 from this link (this is the version that requires the Microsoft .NET Framework 2.0), and then follow the instructions below:

  • After installing Fiddler, please open it from the Start Menu.
  • Launch Emsisoft Anti-Malware.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top
  • Click on the Proxy settings button on the right side, in the middle.
  • Check the box that says Use proxy.
  • Enter localhost in the Server field, and then enter 8888 in the Port field.
  • Click OK.
  • Click the Update now button above the Proxy settings button.
  • After the update fails, go back to Fiddler, and to File, then Save, and select All Sessions (please save it on your desktop).
  • Please send me the Fiddler log in a Private Message (do not post in in a reply).
Note that you may need to ZIP the log to be able to attach it to a Private Message. If you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to Send To, and clicking on Compressed (zipped) Folder.

 

Fantastic! I have been wanting to install Fiddler anyway and you just provided all the info I needed.

 

For what it is worth, the message in the EAM update log when these hung update episodes occur is "unable to retrieve update information from the server." Pretty self-explanatory to me.

 

I will install Fiddler and send you the log file tomorrow morning(EST) most likely.

Share this post


Link to post
Share on other sites

OK. Hopefully the HTTP headers logged by Fiddler will give us an idea of why this is happening. ;)

Share this post


Link to post
Share on other sites

As luck would have it, I have not had any further issues with updating since I posted this. So I will just post a quick reply if it happens again and that I am PM you with the Fiddler log.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.