Offline Sword

Some bugs found in Emsisoft Internet Security 10 (EIS)‏

Recommended Posts

1. Exclusion. When I add a file to the white list, it still appears in the behavior blocker panel as a "not fully trusted application".

2. Context menu. The scanning option in the context menu is "Scanning with Emsisoft Anti-malware". Since what I installed is not EAM but EIS, here should be revised.

 

I have submitted these two bugs via Email, but get no response after more than 24 hours. So I post them here.smile.png 

 

By the way, I find that the activation key is displayed in plaintext in the license panel. Maybe it is not a bug. But I think that such a design may not be safe. Please consider to encrypt it.

 

Best regards.

 

 

Share this post


Link to post
Share on other sites

I already answered this via e-mail, so I'll copy and paste my reply below:

The reputation listed in the Behavior Blocker list is from our Anti-Malware Network, and not from rules/exclusions that you create yourself. Those rules do influence the reputation on our Anti-Malware Network, unless you've turned off "Submit application and host rules" in the Privacy settings.

The context menu entry on my Windows 7 x64 system (a recent install of version 10.0.0.5366) says "Scan with Emsisoft Internet Security". May I ask what version you installed from? Have you tried turning off the "Explorer integration" in the settings to see if the context menu entry was removed, and then turning it back on to see if it had the correct product name?

As for the license key being in plain text, that is done on purpose so that people can read their license key. You can restrict which user accounts have access to that information, however Administrator accounts will always have access to it since it isn't safe to restrict Administrator accounts from functions or features of the software.

  • Upvote 1

Share this post


Link to post
Share on other sites

I already answered this via e-mail, so I'll copy and paste my reply below:

The reputation listed in the Behavior Blocker list is from our Anti-Malware Network, and not from rules/exclusions that you create yourself. Those rules do influence the reputation on our Anti-Malware Network, unless you've turned off "Submit application and host rules" in the Privacy settings.

The context menu entry on my Windows 7 x64 system (a recent install of version 10.0.0.5366) says "Scan with Emsisoft Internet Security". May I ask what version you installed from? Have you tried turning off the "Explorer integration" in the settings to see if the context menu entry was removed, and then turning it back on to see if it had the correct product name?

As for the license key being in plain text, that is done on purpose so that people can read their license key. You can restrict which user accounts have access to that information, however Administrator accounts will always have access to it since it isn't safe to restrict Administrator accounts from functions or features of the software.

 

 

Sorry but I have not received any response letter from Emsisoft's Support.

In fact, until now, I have sent 3 mails to the support, two on the language option bug, one on the two bugs mentioned above. But I could not find the response letter, even after checking the "spam" folder carefully......sad.png

 

Attached please find a screenshot of the information of EIS that I installed.

The product version is 10.0.0.5409.

Please note that the product name shows to be "Emsisoft Anti-malware", not "Emsisoft Internet Security". I think it is very strange.

I also put a screenshot of the main window of EIS in the attachment. You can find that the firewall is active. This can prove that what I am using is actually EIS.

 

I have tried to turn off "Explorer integration", and then to turn it on. But this bug still exists.

post-34940-0-29244400-1433250111_thumb.png
Download Image

post-34940-0-45628800-1433250418_thumb.png
Download Image

Share this post


Link to post
Share on other sites

Sorry but I have not received any response letter from Emsisoft's Support.

In fact, until now, I have sent 3 mails to the support, two on the language option bug, one on the two bugs mentioned above. But I could not find the response letter, even after checking the "spam" folder carefully......sad.png

Interesting. It looks like you sent your message to our support e-mail address from an Outlook.com mail address. Can you send me a Private Message on these forums to confirm that e-mail address, and I'll go ahead and contact our server admin to see if he can find any issues.

Please note that the product name shows to be "Emsisoft Anti-malware", not "Emsisoft Internet Security". I think it is very strange.

There is a very good reason for this. Both products share the same files, with the major exception being the firewall drivers that get installed by the Emsisoft Internet Security installer. This is done to make product updates easier and faster, since our developers don't have to maintain the two programs separately.

I have tried to turn off "Explorer integration", and then to turn it on. But this bug still exists.

When you turned off the "Explorer integration", did the context menu entry disappear?

  • Upvote 1

Share this post


Link to post
Share on other sites

Interesting. It looks like you sent your message to our support e-mail address from an Outlook.com mail address. Can you send me a Private Message on these forums to confirm that e-mail address, and I'll go ahead and contact our server admin to see if he can find any issues.

There is a very good reason for this. Both products share the same files, with the major exception being the firewall drivers that get installed by the Emsisoft Internet Security installer. This is done to make product updates easier and faster, since our developers don't have to maintain the two programs separately.

When you turned off the "Explorer integration", did the context menu entry disappear?

 

I have sent you my email address through "Private Message".

 

Yes, when I turned off the "Explorer integration", the corresponding entry actually disappeared.

Then, when I turned it on, it appeared again, but was still "Scanning with Emsisoft Anti-malware"...

Share this post


Link to post
Share on other sites

I find the context menu item has been repaired when I woke up in the morningsmile.png

It's possible that Windows Explorer needed to reload before the change in name would happen.

As for the e-mail issue, Microsoft was blocking messages from our helpdesk. Our system admin has gone through the steps to get it unblocked, but Microsoft moves our mail server from a list of blocked mail servers to a list of mail server marked for "conditional mitigation", which is a fancy way of saying that they may still refuse to deliver some e-mails from our mail server based most likely on some sort of automated analysis. This "conditional mitigation" is also sort of like a "probation", where if any of our messages are marked as spam by an Outlook.com user our mail server will most likely be blocked again.

I guess what I'm saying is, if you use Outlook.com/Hotmail.com/Live.com for e-mail, then our forums may be a more reliable way to contact us. ;)

  • Upvote 1

Share this post


Link to post
Share on other sites

It's possible that Windows Explorer needed to reload before the change in name would happen.

As for the e-mail issue, Microsoft was blocking messages from our helpdesk. Our system admin has gone through the steps to get it unblocked, but Microsoft moves our mail server from a list of blocked mail servers to a list of mail server marked for "conditional mitigation", which is a fancy way of saying that they may still refuse to deliver some e-mails from our mail server based most likely on some sort of automated analysis. This "conditional mitigation" is also sort of like a "probation", where if any of our messages are marked as spam by an Outlook.com user our mail server will most likely be blocked again.

I guess what I'm saying is, if you use Outlook.com/Hotmail.com/Live.com for e-mail, then our forums may be a more reliable way to contact us. wink.png

 

Thank you for your effort in solving this problem.smile.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.