Pethy

a2service.exe High Cpu @ Memory Usage

Recommended Posts

Is it normal that this process use usually 10-25% of my cpu time and take 500mb ram?

 

After reboot and 0 program started it's still use 10% cpu. It's anoying. :(

 

I attached a processmonitor log file.

Logfile.zip

Share this post


Link to post
Share on other sites

In to log you are running uTorrent. What happens if you close uTorrent? Does the system load go back to normal?

If I close it than a little bit better, but still the cpu time is around 10%. Alsoe I tried to exclude utorrent port, and the application too, but again I don't think that cause the problem.

 

If I turned off the firewall completly there are no cpu usage at all (maybe it's kill the process). 

 

edit: So I reinstalled the Emsisoft IS and now utorrent isn't running then the cpu usage is gone, but when it's running it is around 5% now.

Is this normal or still above normal?

Share this post


Link to post
Share on other sites

That is more than it should be. Can you try to enable the beta updates and update to the latest beta version of Emsisoft Internet Security? You can do so by enabling the "Enable beta updates" option under "Settings"/"Updates" and then running an update manually. You will likely have to reboot afterwards as well.

 

We did add a lot of performance improvements in the current beta version. So that may already fix the issue you are experiencing.

Share this post


Link to post
Share on other sites
53 minutes ago, Ludy said:

 a2services.exe shows 11.3% usage on idle and 94% during a scan

Can you give a bit more info such as your operating system?

Also is this a new thing and you have had EAM installed for a while?

Have you recently done a restart of your machine to see if that makes a difference?

Share this post


Link to post
Share on other sites

Windows 10 pro

4 gb ram

Intel(R) Celeron(R) CPU N3450 @ 1.10GHz

scans run daily, and cpu usage spikes during scans daily, and computer is switched of at night i have browes forums here and have seen it pulls high grade cpu's usage also quite high

Share this post


Link to post
Share on other sites

Also emsisoft has been installed for a while, this is a daily issue when scanning its only now after reading forums on emsisoft support that i decided to register, and report it as it has happend as early as 2015 to my knowledge and may even have earlier cases than 2015, someone posted in a2start.exe about a2services.exe high cpu usage but cant remember where and when

Share this post


Link to post
Share on other sites

High cpu use in a2service.exe (which is the part of EAM that does the work) when doing a scan is normal - EAM is by default set up to try to get through the scan as fast as possible.

You can change that by going to the Scan page in the GUI, then scroll down to "Scanner Settings", and change "Perfomance impact" to the "Reduced" option.  Scans will then leave two cpu cores (you have four in your Celeron cpu) free for the other tasks on the machine.

The discussions you've seen earlier about eg a2start.exe high cpu were all in the "Customer Support - Emsisoft Anti-Malware Home" part of the forum which is where all the EAM issues are normally discussed.

What sort of scan are you doing every day?  Is it of all files on the whole machine?   I'd wonder why?  Here (although I'm the only user, and careful about what I do - so eg no children using the machine) I only scan the whole machine once per week - and only one week in four do I have it set to be really thorough (eg looking inside archives).

Share this post


Link to post
Share on other sites
20 hours ago, Ludy said:

Intel(R) Celeron(R) CPU N3450 @ 1.10GHz

That's a fairly slow processor from 2016, so you're going to see higher CPU usage on it than you would an Intel Core i3 or an Intel Core i5. That being said, 11% does seem a bit high for idle usage. Do you have any other security software (Anti-Virus, Firewall, Anti-Spyware, Anti-Malware, etc) on the computer?

As for the CPU usage during a scan, that's completely normal. Our scanner attempts to use all available CPU cores in order to scan as many files at the same time as possible. This helps reduce scan times.

Share this post


Link to post
Share on other sites

Hi thanks there is only emsisoft on the computer, I changed the setting for scanning but it still idles a bit high, but not killing the CPU thanks to changing the  but now I have another issue, do I start a new discussion?

Share this post


Link to post
Share on other sites

> ... another issue...

Yes, start a new topic.   Put it in the "Customer Support - Emsisoft Anti-Malware Home" forum though, not here.

Share this post


Link to post
Share on other sites
20 hours ago, Ludy said:

now I have another issue, do I start a new discussion?

If it's not related to this topic, then that would be best. Everyone who's following this topic gets an e-mail notification when someone adds a new post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.