haiku

Two problems associated with the Emsisoft Network Filter

Recommended Posts

I am current running version 5561 of EIS, reinstalled on the 2nd August.

 

Problem 1: No Internet access on computer start

  1. Power up the computer, The network icon (in the task bar) shows no Internet connection.
  2. Disable the Emsisoft Network Filter (in the network adapter properties) and save.
  3. Wait a short while for the Internet connection to be established.
  4. Re-enable the Emsisoft Network Filter (in the network adapter properties) and save.
  5. All OK until the next computer power-up.

 

Problem 2: "Interrupts" process hits 50% CPU utilisation during downloads causing machine-wide hassles

  1. The "Interrupts" process normally runs at a maximum 1.4% CPU utilisation.
  2. Start a download via NNTP [sABnzbd] or torrents [uTorrent].
  3. The "Interrupts" process hits 50% CPU utilisation.
  4. Disable the Emsisoft Network Filter (in the network adapter properties) and save.
  5. The "Interrupts" process returns to normal i.e. maximum 1.4% CPU utilisation.
  6. Also occurs with streaming e.g. YouTube videos.

 

Any assistance appreciated

Share this post


Link to post
Share on other sites

Assuming this is happening on Windows 7, have you tried the latest beta version? It has an updated firewall driver, which while intended to add Windows 10 compatibility, may function a little differently on Windows 7 as well. If you'd like to try it, then here's what to do:

  • Open Emsisoft Internet Security.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top.
  • On the left, under Update Settings, select the option for Enable beta updates.
  • Click on the Update now button on the right side.

Share this post


Link to post
Share on other sites

The machine on which EIS is installed is, as per my details, running Windows 7 Ultimate.

 

I followed your instructions to update to the current beta version of EIS.

 

Unfortunately EIS refused to start - due to a process not running - so I ended up uninstalling the beta version & reinstalling the current release version.

 

NB: The update to beta did not install the Emsisoft Network Filter. Was this intentional ?

Share this post


Link to post
Share on other sites

If the network filter driver did not install, then there was a problem with the beta. It is possible to install it manually if you would like to try it.

Share this post


Link to post
Share on other sites

Does the beta reduce interaction with downloading / streaming files ?

 

If yes it may be worth the trouble: if not I think that I will give it a miss.

 

What do you suggest ?

Share this post


Link to post
Share on other sites

There was some indication that CPU usage caused by the firewall driver may be less with the current beta version.

If after installing the beta the service won't start due to a missing dependency, then you can try the following:

  • Hold down the Windows key on the keyboard (the one with the Windows logo on it, usually between the Ctrl and Alt keys) and tap R to open the Run dialog.
  • Type in control netconnections and click OK.
  • Right-click on the network adapter, and select Properties.
  • Click on the Install button in the connection properties for the network adapter.
  • Click on Service to select it, and click Add.
  • Select the Emsisoft Network Filter from the list, and click OK.
If you don't see Emsisoft Network Filter in the list, then you will have to click on the Have disk button, and look for a file named fwndislwf in one of the following locations:

C:\Program Files\Emsisoft Internet Security

C:\Program Files (x86)\Emsisoft Internet Security

Once you find the fwndislwf file, just double-click on it, and then click the OK button. After that you should be able to find an Emsisoft Network Filter or Emsisoft NDIS Filter in the list, so you can click on it to select it, and then click OK.

You may also want to try the following to manually start the service after installing the fwndislwf driver:

  • Hold down the Windows key on your keyboard (the one with the Windows logo on it, usually between the Ctrl and Alt keys) and tap R to open the Run dialog.
  • Type in services.msc and click OK.
  • Find the Emsisoft Protection Service in the list.
  • Right-click on it and select Start.

Share this post


Link to post
Share on other sites

We don't have an ETA. So far the current beta version appears to be doing well, but that doesn't necessarily mean that it will be released as stable right away. There could be issues that we are not aware of yet, or other things that our developers decide need to be fixed before the current beta can be moved to stable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.