AlphaSigna

EIS Probleme Netzwerkumgebung in Windows 10 und automatische Regeln höhere Ports

Recommended Posts

Hallo,

 

ich habe unter Windows 10, 64-Bit, mit EIS einigne Probleme.

 

1. Beim erstellen von automatischen Regeln

Bei dem Programm SABnzbd wurden von der Firewall automatisch ordnungsgemäß die Ports 80 und 443 nachgefragt aber später nicht die höheren Ports im Bereich von 55000-56000, sodaß der Download nicht gestartet wurde. Nach dem manuellen hinzufügen des genannten Portbereichs funktionierte dies jedoch.

So ist es sehr mühsam genaue Regeln anzulegen da man bei vielen Programmen mit CurrPorts ermitteln muss welche Ports man noch manuell hinzufügen muss (einfach alles bei ausgehenden Reglen zuzulassen ist auch keine Lösung, da man ein "großes Scheunentor" öffnet)

 

2. Windows 10 Netzwerkumgebeung

Wenn der Rechner startet und ich die Netzwerkumgebung öffne wird mir nur mein eigener Computer angezeigt.

Wechsle ich in die Firewall Einstellungen von EIS und entferne den Hacken bei "Firewall aktivieren" und setze diese sofort wieder, werden mir alle Netzwerkgeräte meines Netzwerkes ordnungsgemäß angezeigt (siehe Bilder im Anhang).

Dieses Problem tritt nach jedem Reboot und nach jedem Neustart auf.

 

 

Gruß

Andreas

post-2826-0-44487800-1445944773_thumb.png
Download Image

post-2826-0-85988300-1445944788_thumb.png
Download Image

Share this post


Link to post
Share on other sites

Hallo Christian,

 

der Netzwerkadapter ist als "Privates Netzwerk" eingestellt und "Windows-Einstellungen für neue Verbindungen verwenden" ist deaktiviert.

Unter "Erweiterter Konfiguration" -> "Automatische Regelerstellung" sind alle vier Einstellungen auf "Fragen" eingestellt.

 

Gru?

Andreas

Share this post


Link to post
Share on other sites

Hallo,

 

dann sollte Punkt 2 eigentlich nicht auftreten. Haben Sie bis auf die Ports für SABnzbd noch andere Regeln Firewallregeln hinzugefügt oder verändert?

 

Wenn nein benötigen wir Debuglogs um den Fehler nachstellen zu können. Herzu gebe ich Ihnen dann eine Anleitung wie die Logs erstellt werden können.

Share this post


Link to post
Share on other sites

Hallo,

 

ich könnte die Logs erstellen, werde dann die bestehenden Regeln löschen und dann neu von EIS anlegen lassen (nach rückfrage).

Manuell habe ich keine weiteren Regeln hinzugefügt oder bearbeitet.

Share this post


Link to post
Share on other sites

Hallo,

 

mir geht es erstmal darum Problem 2 einzugrenzen da Problem 1 nicht auftreten sollte in den Standardeinstellungen (Ausgehende Verbindungen für Unbekannte Programme Erlauben).

 

Bitte als erstes unter Einstellungen Untersektion Allgemein über den Schalter Werkseinstellungen alle Optionen anhaken und OK klicken. Software wird dann auf Standardeinstellungen zurückgesetzt.

 

Dann bitte von http://download1.emsisoft.com/debug_output.zip die debug_output.zip herunterladen und die enthaltenen Skripts an einen Ort der Wahl entpacken. Dann bitte das Skript enable_debug_output.bat ausführen, mit rechter Maustaste -> Als Administrator ausführen, um den Registryeintrag zu setzen. Dann den Rechner bitte neustarten. Jetzt ein wenig warten so eine Minute. Dann die Netzwerkumgebung aufrufen und wieder eine Minute warten.

 

Dann bitte das Skript disable_debug_output.bat ausführen, mit rechter Maustaste -> Als Administrator ausführen, und den Rechner neustarten um das Debug Logging wieder zu deaktivieren.

Unter dem Ordner C:\ProgramData\Emsisoft\Logs sind jetzt alle Debuglogs vorhanden. Den Ordner Logs bitte zu einer ZIP Datei hinzufügen.

Als letztes die Windowstaste + R gleichzeitig drücken und msinfo32 eintippen und mit OK bestätigen. Im Systeminformations-Tool auf Datei und Speichern gehen und die Datei auf Ihrem Rechner abspeichern. Die Sysinfo-Datei und die ZIP Datei mit den Logs bitte mit Verweis auf dieses Topic an [email protected] schicken.

Share this post


Link to post
Share on other sites

Hallo,

 

habe gerade die Files per eMail versendet.

Die Netzwerkumgebung sieht noch immer nicht so aus wie sie sollte (siehe Bilder).

 

Das Problem 2 unter diesen Einstellungen nicht mehr existent ist, ist auch kein Wunder.

Wenn ich alles ausgehende Erlaube ist klar das es funktioniert! Das ist ja auch nicht das Problem, das Problem war das EIS die Verbindungen zu den hohen Ports (55000-56000) nicht abgefragt hat sindern "nur" die Ports 80 und 443!

 

Wenn ich eine (Desktop-)Firewall einsetzte möchte ich den ganzen Verkehr (eingehend und ausgehend egal ob Vetrauenswürdig oder unbekannt) kontrollieren und bei Bedarf zulassen, das funktioniert aber nicht vernünftig wenn nicht alle Verbindungen nachgefragt werden.

Ein "gutes" und "sicheres" Firewallset wird immer wie folgt aufgbaut erst ALLES verbieten und nach und nach die Ports für Programme Freigeben die benötigt werden.

 

Warum soll ich einem Program das z.B. nur Port 80 und 443 benötigt noch die anderen ca. 65000 Ports aufmachen? Das ist ja löchriger als ein Schweizer Käse.

 

Die Werkseinstellungen sind für den unbedarften User und dem Support die bequemste aber nicht die optimalste Lösung (in meinen Augen).

 

 

Gruß
Andreas

post-2826-0-46249500-1446032696_thumb.png
Download Image

post-2826-0-81769400-1446032704_thumb.png
Download Image

Share this post


Link to post
Share on other sites

Hallo Andreas,

 

über die Funktionsweise läßt sich natürlich streiten. Ich gebe Deine Anmerkungen gerne an unsere Entwickler weiter.

 

Nochmal zu Problem 2. Auch mit den Firewall-Werkseinstellungen werden also unter Netzwerk nicht alle Geräte angezeigt?

Share this post


Link to post
Share on other sites

Hallo Christian,

 

genau, Bild 1 (Netzwerk2.png) ist ohne Firewall bzw. kurz Hacken bei EIS Firewall entfernen und gleich wieder setzen.

Bild 2 (Netzwerk3.png) ist mit den Stnadard Einstellungen von EIS.

 

Trotzdem besteht noch immer das Problem das EIS nicht alle Ports abfragt wenn die Einstellungen auf "Fragen" stehen.

 

 

Gruß

Andreas

Share this post


Link to post
Share on other sites

Hat sich erledigt, mache jetzt von der "Geld-zurück-Garantie" gebrauch.

 

Vor 11 Tage den Log eingesendet und bis jetzt keine Reaktion, Reife Leistung Emisoft!

 

Die Grundeinstellung von EIS beherschen heute alle Router, da diese NAT bzw. PAT beherschen (alles darf rein, was VORHER rausging und alles andere darf nicht rein). Die Grundeinstellung von EAM finde ich sehr bedenklich, da diese für 90% der Nutzer keinen Mehrwert bringt (da diese einen Router nutzen), es aber den Support vor vielen Anfrage schützt.

 

Klar läßt sich über die Funktionsweise streiten aber jeder der sich mit Netzwerken und Firewalls auskennt, weiß wie man ein "vernüftiges" Ruleset erstellt.

 

Ich werde in Zukinft auf EAM + Outpost Firewall Pro setzen.

 

 

Gruß

Andreas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.