Firewall blocking network drive (and wireless printing)

Recommended Posts

Just installed an Epson XP-420 wireless all-in-one printer.  The Epson setup software maps its memory card slot as network drive 'Z:'.  The problem is that on PC startup, I get a message that my computer can't connect to Z: and I can't print anything wirelessly.  The EIS firewall is apparently blocking access to both the drive and the printer - everything only works when I disable the firewall.  I've checked the firewall log and it doesn't show anything being blocked..  I haven't added any custom firewall rules and I set my local network as private when I installed EIS.     


Would modifying an existing firewall rule fix this, or can I set a rule permitting traffic in/out to the IP address of my printer?


Running EIS 10 on Win 10 Pro x64.

Share this post

Link to post
Share on other sites

Have you tried the version 11 beta to see if it resolves this issue? A few firewall related issues were fixed in this version. If you haven't and you'd like to try it, then here's what to do:

  • Open Emsisoft Internet Security.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top.
  • On the left, under Update Settings, select the option for Enable beta updates.
  • Click on the Update now button on the right side.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.