xopx

Firewall Blocks Without Alert When Set to "Ask"

Recommended Posts

Is this a joke that you have released such a bugged version as stable?

Emsisoft Internet Security 11.0.0.5911 is working perfectly fine for me, so I don't know what you mean by "bugged" version?

Share this post


Link to post
Share on other sites

If Firewall is set to "Ask" it blocks most of the programs that I've used from running properly, without any information. It looks like a lot of people are using EIS in fully automatic mode. That's not my case, I'd like to be able to decide on my own. In other security suits this option is easily accessible and works fine but for some reason EIS developers have focus on making EIS friendly only for beginners, inexperienced users and people look like to set everything to automatic mode.

Share this post


Link to post
Share on other sites

I can try this out once I get home tonight, and let you know whether or not I'm able to reproduce the issue.

Share this post


Link to post
Share on other sites

Is this a joke that you have released such a bugged version as stable?

Please don't hijack other peoples' topic. You already have several open topics on our forums, and this comment could have been left in one of those rather than here.

 

... for some reason EIS developers have focus on making EIS friendly only for beginners, inexperienced users and people look like to set everything to automatic mode.

That's the target audience for EIS. The average person who doesn't know how to answer alerts. This is why they are suppressed by default.

I'll let our QA Manager know that there appears to be an issue with setting the alerts for 'Ask' so that he can look into it. May I ask what exactly you set to 'Ask'? Such as incoming or outgoing, trusted or unknown.

Share this post


Link to post
Share on other sites

Lets get some debug logs from Emsisoft Internet Security. In order to do this, you will first need to run a batch file to enable debug logging. This batch file is contained in the ZIP archive at this link (this ZIP archive also contains a batch file to disable debug logging).

Please save that ZIP archive on your desktop, extract its contents, and then follow these instructions:

  • Run the enable_debug_output batch file (if your computer has Windows Vista, Windows 7, or Windows 8 then please right-click on the batch file and select Run as administrator).
  • You will see a black window pop up, and then disappear very quickly. After that happens, please restart your computer.
  • Reproduce the issue you are having.
  • Once you have reproduced the issue, hold down the Windows key on the keyboard (the one with the Windows logo on it, usually in between the Ctrl and Alt keys) and tap the R key to open the Run dialog.
  • Type the following into the Run dialog, and then click OK:

    %ALLUSERSPROFILE%\Emsisoft
  • A window should open and you should see a Logs folder. Right-click on that Logs folder, go to Send to, and select Compressed (zipped) folder.
  • Move the new ZIP archive you created with the logs folder in it to your desktop.
  • Send the ZIP archive containing the logs to me in a Private Message.
Note: If you get an error message when trying to send the Logs folder to a Compressed (zipped) folder then you may need to try a utility such as 7-Zip or WinRar to compress the folder. Both 7-Zip and WinRar have options to create an archive and save it in another location (such as on your desktop), which should prevent the error message. Here are links to the download pages for 7-Zip and WinRar.

After sending me the debug logs, you can run the disable_debug_output batch file (be sure to run it as administrator as well) and restart your computer again to disable debug logging.

Share this post


Link to post
Share on other sites

Firewall blocks without Alert when set to "Ask"

 

Well, I have had in some cases where I wasn't provided an

"Ask" dialog, but I usually fixed the issue by deleting the

application rule entirely, and running the program again.

 

Which got me thinking about the firewall [Remove Rule] not updating

in real-time, and requiring an application restart to take effect.

Could be mistaken for not blocking correctly.

 

Also... are we talking about blocking Firewall Ports or Firewall Programs?


If Firewall is set to "Ask" it blocks most of the programs that I've used from running properly, without any information.

 

Because if it was blocking most the programs, Windows probably wouldn't even start.

 

I do agree there needs to be more verbose information provided about what is being allowed/blocked

instead of just SHA hash information.

Share this post


Link to post
Share on other sites

Because if it was blocking most the programs, Windows probably wouldn't even start.

Windows will start without network access. Some functions will be unavailable without networking, however it should be the same as the adapter being disconnected.

Share this post


Link to post
Share on other sites

Because if it was blocking most the programs, Windows probably wouldn't even start.

When you boot Windows in any Safe Mode, "most programs" (in fact, every third-party ones) aren't launched, yet Windows still boots fine. It's when it starts blocking critical Windows processes that an issue will arise, but it doesn't seems to be the case here.

Share this post


Link to post
Share on other sites

Technically it is possible for programs to run automatically in Safe Mode, however it requires doing special things to get Windows to run them in Safe Mode (certain registry entries tell Windows to load services and drivers in Safe Mode, for instance).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.