Aoud

Фаервол.Редактор сетей.

Recommended Posts

Здравствуйте!Не могу разобраться.Сразу после установки ЕИС в редакторе сетей два подключения по локальной сети(скр.1),одно из которых TAP-Windows Adapter V9 анонимайзера и общая сеть.При этом в параметрах общей сети почему-то прописывается IPv4-адрес(169.254. . .) из TAP-Windows Adapter V9.При этом сам анонимайзер не запущен-работает только его адаптер.Так остается все до первого запуска анонимайзера.После этого в редакторе сетей видно всегда только одно подключение по локальной сети и общая сеть,но теперь в параметрах общей сети IPv4-адрес(192.168. . .),который я прописываю изначально в Atheros AR8152 PCI-E Fast Ethernet при первоначальной настройке сети,как это предписано провайдером.Впоследствии все остается как на скр.2,независимо от использования анонимайзера.

Так и должно быть?Почему так происходит?Сначала 2 подключения по локалке определяется,потом всегда одно.

 

Нужен ли чекбокс на фильтре Емсисофт(5 скриншот)?По умолчанию его там нет.

 

Спасибо.

post-42170-0-08078100-1451405768_thumb.png
Download Image

post-42170-0-25920900-1451405780_thumb.jpg
Download Image

post-42170-0-14790600-1451405793_thumb.jpg
Download Image

post-42170-0-04820400-1451405801_thumb.jpg
Download Image

post-42170-0-50476200-1451405812_thumb.jpg
Download Image

post-42170-0-28478200-1451405825_thumb.jpg
Download Image

Share this post


Link to post
Share on other sites

Добрый день,

 

Адрес 192.168 является верным и основным подключением.

 

Адреса 169.254 (адреса APIPA) могут прописываться в том случае, если если есть проблемы с DHCP-сервером (задача которого выдавать адреса). Либо, если такие IP адреса не могут быть получены с роутера. Если роутер принадлежит провайдеру, то следует обратиться к нему.

 

Настройки анонимайзера у Вас верны? Так как прописан в настройках статический IP адрес и пустые DNS. Обычно анонимайзеры получают IP адрес и DNS автоматически.

 

В целом, причин может быть много, но в Вашем случае предположу, что такая ситуация из-за анонимайзера (виртуального адаптера).

 

Можете поставить чекбокс на этом адаптере.

Share this post


Link to post
Share on other sites
Адреса 169.254 (адреса APIPA) могут прописываться в том случае, если если есть проблемы с DHCP-сервером (задача которого выдавать адреса).

 

Так почему он прописывается в редакторе сетей в общую сеть при установке ЕИС?Получается так,что ЕИС подхватывает при установке не 192.168....,а адрес вирт.адаптера.У меня модем,а не роутер.

Настройки анонимайзера у Вас верны? Так как прописан в настройках статический IP адрес и пустые DNS. Обычно анонимайзеры получают IP адрес и DNS автоматически.

 

Да,верны.Там не стат.адрес 169.254....у анонимайзера,он меняется сам по себе после перезагрузки(последние цифры),и это нормально-Винда сама назначает,если DHCP выключен.Сам анонимайзер в автозагрузке отсутствует и не запущен.Включен только адаптер-по умолчанию так всегда.

Share this post


Link to post
Share on other sites

Чекбокс не фиксируется.Я ставлю его,сохраняю-снова появляется в редакторе сетей 2ое локальное подключение,как на 1м скриншоте.Запускаю анонимайзер-работаю-выхожу-закрываю его-открываю редактор сетей-там опять одно локальное подключение,как на 2м скриншоте.Открываю свойства адаптера анонимайзера-чекбокса нет.Сегодня ради эксперимента снес ЕИС и поставил Аутпост фаервол-по умолчанию чекбоксы сразу стоят на обоих адаптерах.

Share this post


Link to post
Share on other sites

Хорошо.

Сообщите, пожалуйста, какой анонимайзер Вы используете, чтобы разработчики смогли протестировать данное поведение приложения.

Share this post


Link to post
Share on other sites

Проблема была  как на F-Secure Freedome VPN(удалил из-за этой проблемы),так и на CyberGhost VPN(проблема такая же),который стоит сейчас.TAP-Windows Adapter V9 они ставят одинаковый.

Share this post


Link to post
Share on other sites

Решения нет,как и комментариев от разработчиков.Прошел по сути месяц.Я не отстану,пока не получу ответы на все вопросы.Если есть баги-признайте,будем ждать исправлений.Мне нужно пользоваться анонимайзером,но ввиду описанных проблем неясно,что,как и почему.

Share this post


Link to post
Share on other sites

Добрый вечер,

Прошу прощения, что ответа не последовало. Получил инструкции по этой ситуации.

В самом низу нажмите "Включить расширенное ведение отчетов". Воспроизведите ошибку/поведение, с который столкнулись. После того, как все воспроизведется описанное выше, то обязательно отключите расширенное ведение отчетов.

Пуск - Выполнить - ввести %ALLUSERSPROFILE%\Emsisoft

Откроется папка Emsisoft. Запакуйте папку Logs в архив и пришлите нам обязательно на [email protected]

Заранее, спасибо!

Share this post


Link to post
Share on other sites

Ок.Все это ,конечно,хорошо.Но возникает вопрос-тестеры как там?Сами не могут-2 недели прошло?Все перекладывается на пользователя,купившего продукт.Я понимаю,когда заражение-тут ясно.А теперь мне нужно ставить анонимайзер на свежеустановленную чистую систему,чтобы сделать отчеты.Я его не ставлю,так как жду решения,ну или разъяснения почему  возникают ошибки.Где гарантия,что непонятка с определением сетей не повлияет на безопасность?Это во-первых.

Во-вторых,Вы не написали как и с какого момента делать отчет-включать расширенное ведение отчетов сразу перед установкой анонимайзера,после или во время работы??? В постах подробно описана проблематика,возможно Вы невнимательно прочитали написанное мной.Потому уточните.И в-третьих,вот интересно,как в отчетах отобразится слетающий  с вирт.адаптера чекбокс,которого там по умолчанию нет,хотя должен быть?

 

Merci.

Share this post


Link to post
Share on other sites

Кстати,в том же Online Armor всегда определялось 3(2+сеть) подключения(как на 1-м скриншоте) и никуда ничего не исчезало.Все было в константе-сеть и 2 адаптера.Я так полагаю,что разработчики уже в курсе и этого бага,потому молчат как партизаны.Жду ответа.

Share this post


Link to post
Share on other sites

Добрый день!

Дело в том, что тестированием занимаются разработчики. Чтобы проанализировать именно ситуацию в Вашем случае - необходимо получить отчеты. Так как на разных конфигурациях они могут быть разные, и не факт, что проанализировав одну систему (только тестеров), можно будет выяснить причину.

Расширенные отчеты необходимо включать до установки анонимайзера, чтобы был процесс записи в отчеты: начала, процесс и конец работы. Этим же и проверится установка отметок на виртуальных адаптерах.

-вкл расширенные отчеты

-запуск EIS - редактор сетей - закрыть

-установка анонимайзера

-запуск EIS - редактор сетей - закрыть

-запуск анонимайзера

-запуск EIS - редактор сетей - закрыть

-откл. анонимайзер

-запуск EIS - редактор сетей

-откл расширенные отчеты

Заранее, спасибо!

Share this post


Link to post
Share on other sites

Допустим,что так.Мне неясно"-запуск EIS - редактор сетей - закрыть"-для чего?Что закрыть?Смысл в открытии редактора?И еще.Если комп перезагрузить после всего не выключая расширенный режим отчеты будут писаться так же в расширенном или сбросятся в обычное логирование?

Share this post


Link to post
Share on other sites

для чего?Смысл в открытии редактора?

Обновление конфигурации в EIS (взаимодействие интерфейса и служб)

Что закрыть?

Окно EIS

так же в расширенном

В расширенном режиме

Share this post


Link to post
Share on other sites

Ок.Возможно это связано с изменением версии(описанная выше проблема касалась 11.0.0.5984),но теперь все еще круче!При установке анонимайзера и после его установки ЕИС вообще не видит новый адаптер.Его попросту нет в редакторе сетей  ни во время,ни после запуска анонимайзера.Все так,как на скриншоте 2(первый пост топа).После перезагрузки системы-так же.Это явный баг.

Далее.

Анонимайзер не запущен.Я захожу в центр управления сетями и общим доступом-открываю свойства вирт.адаптера-ставлю чекбокс на фильтре Емсисофт(5 скриншот)-закрываю настройки адаптера-открываю редактор сетей ЕИС и там уже(!!!) есть вирт.адаптер и всё как на скриншоте 1,в том числе и в общей сети смена адреса на 169.........запускаю анонимайзер-чекбокс слетает сразу-в редакторе сетей снова все как на скриншоте 2(исчез вирт.адаптер) и адрес в общей сети на 192....как всегда.

 

Касаемо логов,которые я выслал.В одной папке по вашему сценарию+перезагрузка и ручная установка чекбокса.В другой папке логи по моему сценарию с воспроизведением ошибки.

 

Поясняю одномоментно и следующее:система с нуля,все обновления стоят-версия ЕИС стабильная 6054.Анонимайзер Cyberghost VPN переустанавливал дважды(и дважды делал логи),чтобы исключить ошибки установки,но ситуация и поведение ЕИС  не изменились.

 

Мяч на вашей стороне.

Share this post


Link to post
Share on other sites

Добрый день,

Получил некоторые комментарии по данной ситуации от тестировщиков.

Вероятно, на данный момент имеются проблемы с распознаванием виртуальных драйверов/адаптеров. Поэтому, EIS может некорректно распознавать их в системе. В ходе тестирования выяснились еще некоторые недоработки при одновременной работе файрволла и CyberGhost.

Поэтому, будут собраны дополнительные отчеты (от тестировщиков) и отправлены на исследование разработчикам.

Share this post


Link to post
Share on other sites

Добрый день!Следовательно очередной баг(и) и я не ошибся.На других анонимайзерах такие же проблемы,не только с CyberGhost.Фаервол такой фаервол.По сути анонимайзером невозможно пока пользоваться.Весело.

 

 

Спасибо за ответ,Владимир.

Share this post


Link to post
Share on other sites

Доброго всем... проблемы с фаерволом действительно есть, пинг блокирует полностью, не хорошо

C: \ WINDOWS \ system32> пинг emsisoft.ru

Обмен пакетами с emsisoft.ru [5.9.109.74] с 32 байтами данных:
Общий сбой.
Общий сбой.
Общий сбой.
Общий сбой.

Статистика Ping для 5.9.109.74:
    Пакетов: отправлено = 4, получено = 0, потеряно = 4
    (100% потерь)

C: \ WINDOWS \ system32> пинг google.ru

Обмен пакетами с google.ru [2a00:1450:400d:807::2003] с 32 байтами данных:
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.

Статистика Ping для 2a00:1450:400d:807::2003:
    Пакетов: отправлено = 4, получено = 0, потеряно = 4
    (100% потерь)

C: \ WINDOWS \ system32> пинг yandex.ru

Обмен пакетами с yandex.ru [2a02:6b8:a::a] с 32 байтами данных:
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.
Превышен интервал ожидания для запроса.

Статистика Ping для 2a02:6b8:a::a:
    Пакетов: отправлено = 4, получено = 0, потеряно = 4
    (100% потерь)

C: \ WINDOWS \ system32> пинг comss.ru

Обмен пакетами с comss.ru [72.251.241.146] с 32 байтами данных:
Общий сбой.
Общий сбой.
Общий сбой.
Общий сбой.

Share this post


Link to post
Share on other sites

 Mafioza,здравствуйте.Я тоже  это заметил и давно,но с учетом других найденных важных багов,которые еще не исправлены,на пинг уже не обращаю внимания.

Share this post


Link to post
Share on other sites

 Mafioza,здравствуйте.Я тоже  это заметил и давно,но с учетом других найденных важных багов,которые еще не исправлены,на пинг уже не обращаю внимания.

Приветствую, у меня на данный момент никаких багов , да ещё и важных багов, в системе больше нет, лишь вот только практически бесполезный фаер, подумываю обратно на EAM перейти

система у меня 10-ка последняя инсайдерская, и с Эмсом дружат отлично, а что у вас за баги важные? поделитесь, может как-то обсудим, проверим.

Share this post


Link to post
Share on other sites

В системе и у меня их нет.А вот в ЕИС нашлось аж 4-поддержка их подтвердила.Стоит только копнуть и потратить время.Все описано в моих топиках(и в этом тоже)-ознакомьтесь,если интересно.Только вот когда их исправят-неизвестно.Пока не торопятся.А  вот переходить на EAM не спешите,уж даже в этом виде фаерволл ЕИС лучше системного.

Share this post


Link to post
Share on other sites

Читал на форумах , что у фаервола Emsisoft Internet Security нету HIPS , у него вместо HIPS_а  стоит слабенький Behavior Blocker , а самым лучшим HIPS_ом , обладает фаервол Emsisoft Online Armor .

Share this post


Link to post
Share on other sites

Aoud, возникли еще некоторые тонкие вопросы от тестировщиков по поводу работы анонимайзера и файрволла

Подскажите:

1. Вы использовали CyberGhost платную или бесплатную версию?

2. Система была чистая (как я понял), никаких установок других программ между установкой EIS и CyberGhost не было?

3. Когда модуль файрволла EIS был активен и CyberGhost работал, связь с интернетом не обрывалась?

Спасибо.

Share this post


Link to post
Share on other sites

Здравствуйте,Владимир!С праздником!

 

1.В логах-бесплатная,но проблема на обеих версиях,такая же и с F-Secure Freedome VPN.Адаптер то один и тот же,что в платной,что в бесплатной.

2.Чистая.Все обновления.Никаких установок "между" не было.У меня вообще минимум программ в системе.

3.Сама не обрывалась ни разу..Но при выходе из анонимайзера я естественно сам прерывал его соединение(отключение)-а логирование все еще было включено.

 

 

А что по другим темам,Владимир?Особенно интересуют эти:http://support.emsisoft.com/topic/19460-%D0%B2%D0%BE%D0%BF%D1%80%D0%BE%D1%81-%D0%BF%D1%80%D0%BE-%D0%BF%D0%BE%D1%80%D1%82%D1%8B/ и http://support.emsisoft.com/topic/19492-%D0%B1%D0%BB%D0%BE%D0%BA%D0%B8%D1%80%D0%BE%D0%B2%D0%BA%D0%B0-ip/

Share this post


Link to post
Share on other sites

Добрый день,

По поводы первой темы, я уверен, Андрей обязательно отпишется по ее решению. Что касается второй, вчера вышло исправление для EIS :)

Вся работа идет по приоритетам задач.

Share this post


Link to post
Share on other sites

Есть ли новости по этой теме?Или как всегда?Проблеме 3 месяца.Не пора ли разработчикам фаервола пошевелиться и дать ответ,а к нему и исправления!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.