solhuebner

Notifications look blurry on high DPI

Recommended Posts

I am using the latest Windows 10 with a 17 inch 4k screen. So I use the 150% setting as the text is otherwise too small. Unfortunately my Emsisoft Internet Security notifications looks blurry... Also the UI looks blurry. Can you maybe fix this? As I otherwise appreciate your great product :) Thanks and a happy new year!

Share this post


Link to post
Share on other sites

You should be able to fix this by going to the Emsisoft Internet Security folder (C:\Program Files\Emsisoft Internet Security), right-clicking on a2guard, selecting Properties from the list, going to the Compatibility tab, and selecting the option that says Disable Display Scaling On High DPI Settings (be sure to click OK afterwards).

Your computer may need to be restarted after doing that.

Share this post


Link to post
Share on other sites
On 1/5/2016 at 10:04 AM, GT500 said:

You should be able to fix this by going to the Emsisoft Internet Security folder (C:\Program Files\Emsisoft Internet Security), right-clicking on a2guard, selecting Properties from the list, going to the Compatibility tab, and selecting the option that says Disable Display Scaling On High DPI Settings (be sure to click OK afterwards). Your computer may need to be restarted after doing that.

This works, but unfortunately after the second restart that a2guard compatibility setting is automatically disabled/unticked and the blurriness comes back (W10 x64). Hope you can fix this.

Share this post


Link to post
Share on other sites

Unfortunately that's how the DPI scaling feature in Windows 10 works. They changed the scaling method in Windows 10, and it causes that annoying blurring effect.

This tool does claim to resolve that issue by forcing Windows 10 to use the older scaling method that Windows 7, 8, and 8.1 used. Keep in mind that while it appears to be safe, it does need to run on startup since Windows 10 always changes the DPI scaling method back to the default Windows 10 method.

Share this post


Link to post
Share on other sites

Thanks GT500, I know about the general blurring issue but the particular problem of the a2guard compatibility setting auto-disabling itself (and thus causing the blurriness that can be bypassed) seems specific only to Emsisoft. I don't recall other exe's not maintaining the "Disable scaling" setting, unless you are saying that that's how Windows 10 works for some programs, and that setting is not retained after a restart in some cases. If that setting was retained as one would expect (and it does on the programs I've tried), we could bypass the problem for Emsisoft software, too.

About the blurring issue in general: that tool has been very helpful but now is only rarely required because after the W10 Anniversary Update, selecting a custom scaling level in W10's settings, achieves the same effect as that tool and solves the problem. Using the older scaling method in Windows 10 (described as "custom"), might cause other issues with some programs but that's irrelevant here.

 

Share this post


Link to post
Share on other sites
On 12/15/2016 at 9:39 AM, CBMman said:

... the particular problem of the a2guard compatibility setting auto-disabling itself (and thus causing the blurriness that can be bypassed) seems specific only to Emsisoft.

More than likely it is caused by the files being replaced during updates. New files means new file properties. The only way around this would be a way of automating re-creating the file property that disables DPI scaling for a2guard.exe and a2start.exe, however I'm not able to find any information on how to easily do that. If I manage to find a way, I'll post the info here.

  • Upvote 1

Share this post


Link to post
Share on other sites

You are right, that's probably the cause. Perhaps adding an option within EIS itself would be easier to implement than using Windows' file properties system?

Share this post


Link to post
Share on other sites
On 12/17/2016 at 8:08 PM, CBMman said:

Perhaps adding an option within EIS itself would be easier to implement than using Windows' file properties system?

Assuming you mean adding support for DPI scaling, then the answer is unfortunately "no". The UI was specifically designed to not support scaling, and changing that wouldn't be easy or quick. On top of that, there were good reasons for the original decision to prevent the UI from being scaled (UI layout can become rather difficult to keep working properly once it becomes fluid like that, and would more than likely break frequently as the window was scaled to different sizes).

I have submitted the suggestion that EAM/EIS automatically try to enable the option to prevent scaling themselves, that way you won't have to manually toggle it on each time there is an update. I don't have any way to know if or when such a change may be made, however if it is added then it would at least resolve this issue for you. ;)

  • Upvote 1

Share this post


Link to post
Share on other sites

I meant the latter (for EIS to enforce scaling prevention on its own, perhaps via a user-selectable option) but anyway, thanks for looking into it.

I re-enabled custom scaling which solves the issue for all applications (including EIS) and Windows components, and only rarely revert to standard/default scaling for the one application that needs it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.