grzegorz

VPN + L2TP + Windows 10 = PROBLEM

Recommended Posts

Hi

I have a problem on Windows 10 with the EIS (default settings, new installation).

I cannot connect to VPN server with firewall enabled. With firewall disabled, everything is OK.

Mservers is using L2TP protocol with encryption.

 

I saw a forum thread about problems with VPN and the last answer was "We are looking into it".

About mid of 2014.....

Any updates?

 

The second issue - a cannot ping anything through VPN (after enabling it while connected to VPN) - "General failure". The only resolution for huis is to enable ALL ICMP traffic (inbound/outbound).

 

regards

Greg

Share this post


Link to post
Share on other sites

May I ask what VPN software you are having trouble with? Recent versions of OpenVPN are working, as are a few other popular VPN solutions that use common protocols for connecting to VPN servers.

Also, have you tried resetting the global firewall rules to defaults? If not, then here's how to do that:

  • Open Emsisoft Internet Security.
  • Click on Settings in the menu at the top.
  • Click on the Factory defaults button near the upper-right.
  • Make sure that only the option labeled Global firewall rules is selected.
  • Click the OK button to apply the changes.

Share this post


Link to post
Share on other sites

My VPN server runs on a Mikrotik routerboard.

The protocol is L2TP/IPSEC with preshared key encryption.

With the firewall turned off - no problem, i can also turn on the FW when the VPN connection is established.

 

I dont have Emsisoft NDIS packet filter installed on this connection (cant find files required...) - I've tried to install, but with no success.

Share this post


Link to post
Share on other sites

The Emsisoft NDIS packet filter should only be installed for your physical network adapter, and not for virtual network adapters such as VPN's or for virtualization software.

We can try getting some debug logs for this issue. Here's what to do:

  • Open Emsisoft Internet Security from the icon on your desktop.
  • In the 4 little gray boxes at the bottom, move your mouse into the one that says Support, and click anywhere in that gray box.
  • At the bottom, turn on the option that says Enable advanced debug logging.
  • Either click on Overview in the menu at the top, or close the Emsisoft Internet Security window.
  • Reproduce the issue you are having with not being able to connect to your VPN.
  • Once you have reproduced the issue, open Emsisoft Internet Security again, and click on the gray box for Support again.
  • Click on the button that says Send an email.
  • Select the logs in the left that show today's dates.
  • Fill in the e-mail contact form, and be sure to mention who was helping you, and if possible please leave a link to the topic on the forums that the logs are related to in your message.
  • If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  • Click on Send now at the bottom once you are ready to send the logs.
Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.