Jump to content

Emsisoft IS control panel disappeared after beta update of 21 January


Recommended Posts

Dear Emsi team,


yesterday night I installed the latest beta of 21 January (V. updated v.  and restarted the pc as requested (windows 10).

Emsi control panel disappeared as the icon close to the clock.

I tryed to start Emsi but nothing happened nor changed.

Under start manager, Emsi seems to be active.


Can you please check?


Any already  known solutions?


thank you


Link to comment
Share on other sites

I am seeing something similar with EAM. After the beta restart I lose a few tray icons including EAM. Tried reinstall but uninstaller just hangs. Basically system is hosed now and I will go back to a backup image and turn off beta updates (if I can before it tries to update again). I notice a2guard process is suspended, trying shortcut just starts further suspended processes.

Link to comment
Share on other sites

If you download Process Hacker, run it, and type a2 in the search field in the upper right of the Process Explorer window, does it show a2start.exe running after you try to open Emsisoft Internet Security from the icon on your desktop or the System Tray icon and it never appears?

Here's what the search results should look like:


Link to comment
Share on other sites

Hello GT500,

after starting my laptop I see:



After double clicking the icon on my desktop:




Emsi control panel is not visible....don't know if Emsi is updating, cannot change settings, dtart scans...

With a2service and a2guard.exe is the system protected?



Link to comment
Share on other sites

With a2service and a2guard.exe is the system protected?

Yes. a2service.exe does all of the work, and a2guard.exe draws the icon in the System Tray and displays alerts and notifications. As long as the System Tray icon is working, then everything should be OK.

As for the issue with a2start.exe not displaying its UI when it opens, lets get a log from FRST, and see if it shows the cause of the issue. Please download Farbar Recovery Scan Tool (FRST) from one of the following links, and save it to your Desktop (please note that some web browsers will automatically save all downloads in your Downloads folder, so in those cases please move the download to your desktop):

For 32-bit (x86) editions of Windows:

For 64-bit (x64) editions of Windows: Note: You need to run the version compatible with your computer. If you are not sure which version applies to your computer, then download both of them and try to run them. Only one of them will run on your computer, and that will be the right version.
  • Run the FRST download that works on your computer (for Windows Vista, Windows 7, and Windows 8 please right-click on the file and select Run as administrator).
  • When the tool opens click Yes for the disclaimer in order to continue using FRST.
  • Press the Scan button.
  • When the scan is done, it will save a log as a Text Document named FRST in the same place the tool was run from (if you had saved FRST on your desktop, then the FRST log will be saved there).
  • Please attach the FRST log file to a reply using the More Reply Options button to the lower-right of where you type in your reply to access the attachment controls.
  • The first time the FRST tool is run it saves another log (a Text Document named Addition - also located in the same place as the FRST tool was run from). Please also attach that log file along with the FRST log file to your reply.
Link to comment
Share on other sites

I've probably asked this before in the past, however is Malwarebytes Anti-Exploit configured to monitor/protect Emsisoft Internet Security? If so, then I recommend excluding Emsisoft Internet Security in Malwarebytes Anti-Exploit to avoid issues.

Link to comment
Share on other sites

I didn't configure Malwarebytes Anti-Exploit to protect Emsi. I cannot see Emsi in the list of monitored programs.

I disabled Malwarebytes Anti-Exploit and then killed it with Process hacker.

Launched Emsi...still nothing visible....same after restarting the laptop (Malwarebytes Anti-Exploit disabled but in memory)

It is not blocked by Zemana nor by Voodooshield.

HMP alert is in free mode and shouldn't monitor it.

Since I'm not sure Emsi is 100% functional I decided to test it with the Eicar test file.

It was blocked but I'm not sure by what program.

It wasn't Zemana, it detected it before and I terminated it.

I also disabled fast start as suggested in another thread....nothing changed....

What do we do now?


Link to comment
Share on other sites

Emsi IS uninstall doesn't work..it starts, oprns the Emsi IS Uninstall window but then nothing happens.

It worked in safe mode.

Pc restarted 2x, staus bar tells me I m connected but control panel says no connections.

Cannot download new Emsi...no internet connection.

Run Emsi removal tool.

Restarted 3x, still no internet connection...

Found the culprit. .Emsi NDIS Protocol Driver...unchecked it in access point settings and now I can access internet.

Downloaded Emsi IS and started to install it.

After some seconds, the window disappeared.

The icon was already created on desktop, double clicked it and got the following.

Install window appeared and told me the pc is safe now but when I clicked to close the window it told me the install was not completed.

then 2 error messages (see attached files)....

Uninstalled, restarted 2x. Run Emsi clean..nothing found this time.


After it finishes installing all files and the icon on the desktop is created, the install windows disappears.

After many minutes (4-5) a new window pops up and I can choose to join the AM network and to enable PUP.

During this time a pop up informed me a service rimng was created followed 1 min later by another one statin it was deleted....(pls check attached pics)

Then again the final window that tells me all was installed ans Ems is protecting me. If I click "finish installation" it tells me it still needs to finish all setup...as before.

Than again, after again 4-5 minutes, the window "a major problem prevents application start....."

To be on the safe® side and to save time I'll post the FBAR logs at the malware removal page.

I uninstalled Emsi and Zemana, run Emsi clean and reinstalled Emsi.

Same problems as before.

Same after uninstalling also HMPro alert and MB antiexploit.

Voodoshield always in disable/install mode.

What's going on and what do you want me to do?

thank you






Link to comment
Share on other sites

Emsi IS uninstall doesn't work..it starts, oprns the Emsi IS Uninstall window but then nothing happens.

Install/uninstall problems are not uncommon when other security software is installed. Safe Mode is usually an easy workaround, as you already discovered, however some security software does run in Safe Mode and would need to be disabled to resolve such an issue.


What's going on and what do you want me to do?

The first thing we should try, with Emsisoft Internet Security uninstalled, is the following:

  • Hold down the Windows key on the keyboard (the one with the Windows logo on it, usually between the Ctrl and Alt keys) and tap R to open the Run dialog.
  • Type in control ncpa.cpl and click OK.
  • Right-click on the network adapter, and select Properties.
  • Look for the Emsisoft Network Filter or Emsisoft NDIS packet filter in the list.
  • If you find one of them, click on it to select it, and click on the Uninstall button (if both are there, then do this one at a time for each of them).
The issue you had when reinstalling was that the service (a2service.exe) was not starting. That leftover NDIS packet filter driver is the cause, as if there is anything wrong with it the service won't start. It needs to be removed before there can be a successful reinstall.

After that you can try reinstalling again.

Link to comment
Share on other sites

Hello Arthur,

I had unchecked it before since it was blocking my internet access but didn't uninstall it.

Great news, problem solved, Emsi is intalling correctly now! :-)

I could update the databases too.

No problem also to install beta updates and v. 11.0.0 6131.

Thank you!

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...