Sign in to follow this  
XIII

EIS allows AirParrot 2 to stream to Apple TV but not to Philips Fidelio speakers

Recommended Posts

AirParrot 2 is a program that allows streaming video and/or audio to one or more external speakers (at the same time!). I was hoping to use this as a cheap Sonos system...

 

Unfortunately I can't get it to work properly with Emsisoft Internet Security's firewall. AP2 streams fine to my Apple TV, but not to my Philips Fidelio speakers. However, AP2 also streams fine to the Fidelio speakers if I completely disable the EIS firewall.

 

Does EIS have a learning mode so that I can teach it to allow AP2 streaming to my Fidelio speakers?

 

If not, how can I configure it manually so that it works without disabling the firewall? (Creator Squirrels has some info on ports used by AP2)

 

 

Here's (what I think is the relevant part) of the AP2 log of a succesfull connection to the Fidelio speakers, with the EIS firewall disabled:

[2016-04-10 21:46:48.243] mDNS getAddress for Fidelio.local. was 192.168.1.203
[2016-04-10 21:46:48.243] Converted: Fidelio.local. to ip: 192.168.1.203
[2016-04-10 21:46:48.243] Connect to service: 192.168.1.203 video port: 7100 audio port: 1024 media port: 7000
[2016-04-10 21:46:48.247] APOAudioConnection: Set Address: 192.168.1.203 and port: 1024
[2016-04-10 21:46:48.247] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:46:48.250] Resolved to 192.168.1.203..
[2016-04-10 21:46:48.250] APAudioCapture: Setting Encoder Modes: ALAC: 1 ELD: 0 AAC: 0 L16: 0 Opus: 0
[2016-04-10 21:46:48.251] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:46:48.254] Resolved to 192.168.1.203..
[2016-04-10 21:46:48.264] Main Audio Connection Established: V2

Here's (what I think is the relevant part) of the log where EIS blocks the AP2 connection to the Fidelio speakers:

[2016-04-10 21:49:08.630] Connect to service: 192.168.1.203 video port: 7100 audio port: 1024 media port: 7000
[2016-04-10 21:49:08.634] APOAudioConnection: Set Address: 192.168.1.203 and port: 1024
[2016-04-10 21:49:08.634] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:49:08.638] Resolved to 192.168.1.203..
[2016-04-10 21:49:08.638] APAudioCapture: Setting Encoder Modes: ALAC: 1 ELD: 0 AAC: 0 L16: 0 Opus: 0
[2016-04-10 21:49:08.638] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:49:08.640] Resolved to 192.168.1.203..
[2016-04-10 21:49:27.485] SQMDNSBrowser time expired stopping browsing.
[2016-04-10 21:49:29.657] Client audio connection failed (Unable to Connect: Firewall?): 12293
[2016-04-10 21:49:29.657] AirPlay Audio attempting to re-connect to port: 5000 previous port: 1024
[2016-04-10 21:49:29.657] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:49:29.661] Resolved to 192.168.1.203..
[2016-04-10 21:49:30.666] Client audio connection failed (Unable to Connect: Firewall?): 12293
[2016-04-10 21:49:30.666] AirPlay Audio attempting to re-connect to port: 47000 previous port: 5000
[2016-04-10 21:49:30.666] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:49:30.671] Resolved to 192.168.1.203..
[2016-04-10 21:49:31.675] Client audio connection failed (Unable to Connect: Firewall?): 12293
[2016-04-10 21:49:31.675] AirPlay Audio attempting to re-connect to port: 49192 previous port: 47000
[2016-04-10 21:49:31.675] Resolving 192.168.1.203 to final IP...
[2016-04-10 21:49:31.679] Resolved to 192.168.1.203..
[2016-04-10 21:49:32.685] Client audio connection failed (Unable to Connect: Firewall?): 12293
[2016-04-10 21:49:32.686] Stopping AirPlay Audio Connection.

And for the Apple TV it works just fine with the firewall enabled:

[2016-04-10 21:31:11.261] Converted: Apple-TV.local. to ip: 192.168.1.108
[2016-04-10 21:31:11.262] Connect to service: 192.168.1.108 video port: 7100 audio port: 7000 media port: 7000
[2016-04-10 21:31:11.265] APOAudioConnection: Set Address: 192.168.1.108 and port: 7000
[2016-04-10 21:31:11.285] Connect audio only
[2016-04-10 21:31:11.387] Main Audio Connection Established: V2

 

 

Any tips on how to solve this?

Share this post


Link to post
Share on other sites

I assume you've already verified that it does work then the firewall is off?

If it does work with the firewall off, then make sure that there is an Application Rule for the program in question, and that both Firewall Incoming and Firewall Outgoing are set to All allowed.

If that doesn't help, then you can try creating an allow rule for the ports in question in the global firewall rules. Just be sure to put the rule above the one for Application Rules.

Are you having the issue with the latest stable, or the beta? If it's the beta, then you can also try reverting to the stable just to see if that has any effect.

Share this post


Link to post
Share on other sites

I assume you've already verified that it does work then the firewall is off?

 

Yes, see my original post.

 

 

If it does work with the firewall off, then make sure that there is an Application Rule for the program in question, and that both Firewall Incoming and Firewall Outgoing are set to All allowed.

If that doesn't help, then you can try creating an allow rule for the ports in question in the global firewall rules. Just be sure to put the rule above the one for Application Rules.

 

 

I only tried the second thing (which did not help), since the incoming and outgoing were already allowed for this program to get streaming to the Apple TV to work.

 

 

If it does work with the firewall off, then make sure that there is an Application Rule for the program in question, and that both Firewall Incoming and Firewall Outgoing are set to All allowed.

If that doesn't help, then you can try creating an allow rule for the ports in question in the global firewall rules. Just be sure to put the rule above the one for Application Rules.

Are you having the issue with the latest stable, or the beta? If it's the beta, then you can also try reverting to the stable just to see if that has any effect.

 

The latest beta indeed... I'll try the stable version.

Share this post


Link to post
Share on other sites

Downgraded to latest stable version (11.6.1.6315). Same problem.

 

Audio streams fine if I disable the firewall. Does not stream at all if I enable the firewall. No logging of any blocked activity though.

 

How can I investigate this further?

Share this post


Link to post
Share on other sites

Yes, see my original post.

Your original post does not appear to mention whether or not you tried disabling the firewall. ;)

Share this post


Link to post
Share on other sites

Your original post does not appear to mention whether or not you tried disabling the firewall. ;)

 

I think it did:

 

AirParrot 2 is a program that allows streaming video and/or audio to one or more external speakers (at the same time!). I was hoping to use this as a cheap Sonos system...

 

Unfortunately I can't get it to work properly with Emsisoft Internet Security's firewall. AP2 streams fine to my Apple TV, but not to my Philips Fidelio speakers. However, AP2 also streams fine to the Fidelio speakers if I completely disable the EIS firewall.

 

However, rather than discussing whether it did or didn't, I would like to discuss how I can solve this.

 

What else can I try?

Share this post


Link to post
Share on other sites

Is Windows configured for a Public network, or is it configured for a Home or Work network?

Does changing your network from Public to Private have any effect on the issue?

Share this post


Link to post
Share on other sites

Is Windows configured for a Public network, or is it configured for a Home or Work network?

Does changing your network from Public to Private have any effect on the issue?

 

Windows is configured as Public as well.

 

I currently don't have time to experiment with this, but I will put it on my todo-list and report back later (though I'm afraid that any other option will be more restrictive than Public/Public)

Share this post


Link to post
Share on other sites

After changing the network to Private in EIS I got an EIS popup informing me that program AirParrot2.exe wanted to receive incoming data on port UDP:51965.

 

After I chose "Allow all connections" (Allow the program to receive any data via the network) AirParrot 2 did stream to my Philips Fidelio speakers!

 

However, with setting Public for the network (instead of Private) in EIS streaming still does not work. Why? How can we solve that as well?

 

And, which setting for the network is more appropriate/secure?

Share this post


Link to post
Share on other sites

Did you create a rule to allow port 51965 (either incoming or both) in the Global Firewall Rules, and then move it to the top of the list? That should allow it through the firewall.

post-18745-0-85429100-1461047170_thumb.p
Download Image

Share this post


Link to post
Share on other sites

Did you create a rule to allow port 51965 (either incoming or both) in the Global Firewall Rules, and then move it to the top of the list? That should allow it through the firewall.

attachicon.gifrule_for_port_51965.png

 

No. Tried that now though. No difference: streaming only works when network is set to Private (not when set to Public).

Share this post


Link to post
Share on other sites

Make sure that the application in question doesn't also require other ports to be open, or TCP ports opened in addition to UDP ports, and if you still can't get it to work then collect debug information and create a bug report for the issue so that Andrey or one of the other devs can take a look at it. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.