Gergely

EIS and OpenVPN issue

Recommended Posts

Dear EmsiSoft,

 

I have issues with using OpenVPN through EIS. The sypmtoms are the following:

 

1. I connect to the OpenVPN network and it does not seem to work

2. I need to go to Firewall and Manage networks and set the VPN network from Public to Private

3. It is clear and acceptable, I also set to New connections to be Private

4. This does not seems to work.

 

5. When I disconnect from OpenVPN and reconnect it shows Private but does not work. Example ping shows General failure.

6. I need to go to Firewall - Manage networks and set the VPN from Private to Public - OK - then go back and set it from Public to Private

7. And It works

8. I need to repeat 5-6 after each reconnection

 

- When I completly disable Firewall it works like a charm.

- I have tested it with several OpenVPN setup, and clients and it does not work with any of them.

 

I can attach EIS firewall debug logfile if you want.

 

Colud you please advise.

 

Regards,

Gergely

Share this post


Link to post
Share on other sites

Just found something in:

 

http://support.emsisoft.com/topic/19580-vpn-l2tp-windows-10-problem/?hl=openvpn#entry144800

 

The Emsisoft NDIS packet filter should only be installed for your physical network adapter, and not for virtual network adapters such as VPN's or for virtualization software.

 

-------------

 

But when I uninstall it removes from all network connections - so it seems like turning off the firewall. How to remove it only from virtual network adapters?

Share this post


Link to post
Share on other sites

You can uninstall the Emsisoft NDIS packet filter from a single network adapter. Just open the run dialog by holding down the Windows key on your keyboard and tapping R, type in control netconnections and click OK, right-click on the network adapter for OpenVPN and select Properties, click on Emsisoft NDIS packet filter in the list, and then click on the Uninstall button. This should only remove it from the adapter you are modifying.

Share this post


Link to post
Share on other sites

You can uninstall the Emsisoft NDIS packet filter from a single network adapter. Just open the run dialog by holding down the Windows key on your keyboard and tapping R, type in control netconnections and click OK, right-click on the network adapter for OpenVPN and select Properties, click on Emsisoft NDIS packet filter in the list, and then click on the Uninstall button. This should only remove it from the adapter you are modifying.

 

Unfortunately not. If I do this it removes Emsisoft NDIS packet filter from each and every network adapter.

post-43248-0-39640200-1460638305_thumb.png
Download Image

post-43248-0-65166900-1460638305_thumb.png
Download Image

Share this post


Link to post
Share on other sites

Does it work if you reinstall it and then just uncheck the box for the Emsisoft NDIS packet filter in the TAP adapter?

Share this post


Link to post
Share on other sites

Have you created rules in the global firewall rules to allow the port the VPN connection uses, and then moved it to the top of the list?

Share this post


Link to post
Share on other sites

Yes ports are allowed, I have no issue connecting to the VPN server. The issue starts when I try to reach something on the remote network. So I get an address from the VPN server succesfully. But when I try to reach something on the remote network I have no response, only if I go to the Firawall and set the VPN adapter network from Private to Public and then back to Private.

Share this post


Link to post
Share on other sites

Lets go ahead and get the debug logs for this so that I can forward it to our developers. Here's the instructions for doing it in the latest version:

  • Open Emsisoft Internet Security from the icon on your desktop.
  • In the 4 little gray boxes at the bottom, move your mouse into the one that says Support, and click anywhere in that gray box.
  • At the bottom, turn on the option that says Enable advanced debug logging.
  • Either click on Overview in the menu at the top, or close the Emsisoft Internet Security window.
  • Reproduce the issue you are having.
  • Once you have reproduced the issue, open Emsisoft Internet Security again, and click on the gray box for Support again.
  • Click on the button that says Send an email.
  • Select the logs in the left that show today's dates.
  • Fill in the e-mail contact form with your name, your e-mail address, and a description of what the logs are for (if possible please leave a link to the topic on the forums that the logs are related to in your message).
  • If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  • Click on Send now at the bottom once you are ready to send the logs.
Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Please note that if you have a lot of debugs logs, then you should not send all of them. There is a size limit, and currently there is no error if the message is rejected due to the size being too large. Normally we only need one copy of the 4 or 5 different logs that have been saved after the time you reproduced the issue (the list shows what time each log was saved). Those logs have the following names:

  • Security Center
  • Protection Service
  • Real-Time Protection
  • Firewall
  • Logs database (contains the logs you can view in Emsisoft Internet Security by clicking on Logs at the top of the window).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.