JeremyNicoll

CLOSED Re-installing v11.7.0.6394, can't contact servers then can't set 'Private Network'

Recommended Posts

W8.1, 64-bit, reinstalling EIS v11.7.0.6394, as advised in: http://support.emsisoft.com/topic/20057-possible-virtual-memory-problem-with-a2serviceexe/

 

I did a very thorough uninstall of EIS, several restarts, ran the Emsi diagnostic .bat file several times - before uninstall, during and after, and also made full registry backups before, during and after.    I used Emsiclean  to get rid of registry entries not removed by the ordinary installer. 

 

During the following install (using an installer I downloaded at 1356 on 20160519, it all went well until it tried to contact your servers to get uptodate signatures, when it said it couldn't connect.  I ran your diagnostic .bat file at that point and all three of its traceroutes worked fine, and with similar routes & timings to the tracerts done before I started the uninstall.  I continued on past this stage.

 

When EIS started at the end of the install, the GUI showed up in orange saying the product was out of date.  I noted at that point that ping/tracert issued from a command window failed (as I'd found several months ago, discussed at: http://support.emsisoft.com/topic/19819-new-to-eis-and-dont-understand-why-an-app-is-being-blocked/ ). 

 

As was true then, I have Windows set up thinking that I'm always (even at home) using a public network.  Previously I'd eventually told EIS to set itself up as a Priivate network, so that ping etc issued from a command window would work.  So I tried to do that again.  I didn't work.  Even with a reboot, and despite the 'Manage Networks' option "Use Windows settings for new connections" being unset, and "Category for new connections" being set to: Private network, the top part of the display still says that EIS thinks I'm on a Public Network.  

 

Before I tried the reboot with those settings, I also tried a slightly less drastic option:  I unplugged the LAN cable, turned on debug logging, closed the GUI, reconnected the cable,  re-opened the GUI, checked debugging was still on (yes), and went to Manage Networks... and observed the incorrect setting.  Then I 

turned off that debug logging.  Do you want those logs?

 

 

Clicking on 'update now' in the GUI simply produces a message saying it can't connect to the servers.

Share this post


Link to post
Share on other sites

I noticed last night that the EIS shield had suddenly turned green, having been
amber for a couple of days.  Logs - Update shows 'Connection error' many times
from around 10am on 23rd, to early afternoon on the 24th, then starts working &
has worked since then.

Protection - Firewall - Manage Networks STILL shows that I'm on a Public Network
even though I wanted 'new connections' to be Private & Windows isn't supposed to
be making that decision.

And, kernel non-paged pool memory use for the first day or so (while EIS was not
uptodate) did grow, but only very slowly, staying around 720 KB for five hours then
over 6 hours increasing to 2 MB.  But later yesterday it went up to 350 MB and now
it's up to just over one GB.

Interestingly, for the first day or so of the newly-installed EIS, I was logged-in
as my admin id, which I don't normally use for day-to-day stuff, but do use when I'm
uninstalling & installing things.  I stayed logged in as that for a day or so after
I hit the problem bringing signatures uptodate, and classifying the network properly,
hoping there would be a quick fix.  It wasn't until 1311 on 24th that I logged-out &
then in as my ordinary user... and it looks as if the next update attempt after that
was the first of the ones that worked.

I have made no manual changes to any rules or settings, so far, except for trying to
get the network type to accept Private, and having debug logs on for a while.

Share this post


Link to post
Share on other sites

I've asked one of our developers about your logs. I didn't see anything in the firewall log that may explain this, so it may be something else causing the issue. We'll have to wait and see what the developer says before we know more.

Share this post


Link to post
Share on other sites

Thank-you.  The memory thing I'll pursue on the other thread, but wait until this oddity is fixed in case it's somehow related or you want me again to uninstall and re-install.

 

Do you have any thoughts about the installer/EIS being unable to contact update servers during the install, even though the tracert's in the diagnostic .bat that I ran while

in th emiddle of the install, before trying again and finally continuing past that stage, worked just fine.  (See screenshot for "can't connect".)  Output from them was:

 

-----------------------------
- Traceroute Update Servers -
-----------------------------

Checking update.emsisoft.com:

Tracing route to update.emsisoft.com [136.243.128.18]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2    23 ms    22 ms    21 ms  cpc9-sgyl32-2-0-gw.18-2.cable.virginm.net [82.44.24.1]
  3     6 ms     7 ms     7 ms  sgyl-core-2a-xe-212-0.network.virginmedia.net [82.13.247.21]
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7    14 ms    28 ms    15 ms  nrth-bb-1c-ae0-0.network.virginmedia.net [62.254.42.134]
  8    32 ms    32 ms    34 ms  fran-ic-2-ae0-0.network.virginmedia.net [62.254.42.178]
  9    37 ms    35 ms    36 ms  decix-gw.hetzner.de [80.81.192.164]
 10    39 ms    40 ms    39 ms  core23.hetzner.de [213.239.203.154]
 11    44 ms    41 ms    42 ms  ex9k2.rz21.hetzner.de [213.239.203.190]
 12    42 ms    40 ms    42 ms  api1.emsisoft.com [136.243.128.18]

Trace complete.

Server:  cache1.service.virginmedia.net
Address:  194.168.4.100

Name:    update.emsisoft.com
Address:  136.243.128.18



Checking dl.emsisoft.com:

Tracing route to gs1.wpc.v2cdn.net [93.184.221.133]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2     8 ms     8 ms    15 ms  cpc9-sgyl32-2-0-gw.18-2.cable.virginm.net [82.44.24.1]
  3     5 ms     7 ms     7 ms  sgyl-core-2b-xe-212-0.network.virginmedia.net [82.13.247.57]
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7    21 ms    22 ms    22 ms  tcl5-ic-5-ae0-0.network.virginmedia.net [62.254.84.66]
  8    18 ms    19 ms    28 ms  195.66.236.62
  9    20 ms    20 ms    19 ms  93.184.221.133

Trace complete.

Server:  cache1.service.virginmedia.net
Address:  194.168.4.100

Name:    gs1.wpc.v2cdn.net
Address:  93.184.221.133
Aliases:  dl.emsisoft.com
      wpc.AC4D.edgecastcdn.net



Checking cdn.emsisoft.com:

Tracing route to cds.z9k5w6b8.hwcdn.net [205.185.216.42]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2    23 ms     9 ms     7 ms  cpc9-sgyl32-2-0-gw.18-2.cable.virginm.net [82.44.24.1]
  3     7 ms     7 ms     8 ms  sgyl-core-2a-xe-212-0.network.virginmedia.net [82.13.247.21]
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8    19 ms    22 ms    17 ms  tele-ic-8-ae5-0.network.virginmedia.net [62.252.224.94]
  9    24 ms    24 ms    24 ms  m398-mp2.cvx3-a.ltn.dial.ntli.net [213.104.85.142]
 10    20 ms    19 ms    19 ms  ae0.r3.lo.hwng.net [209.197.0.229]
 11    16 ms    19 ms    19 ms  209.197.10.122
 12    19 ms    19 ms    19 ms  map2.hwcdn.net [205.185.216.42]

Trace complete.

Server:  cache1.service.virginmedia.net
Address:  194.168.4.100

Name:    cds.z9k5w6b8.hwcdn.net
Addresses:  205.185.216.10
      205.185.216.42
Aliases:  cdn.emsisoft.com
 

post-25439-0-25946800-1464187232_thumb.jpg
Download Image

Share this post


Link to post
Share on other sites

If you ran the diagnostic batch file while you were having the issue, and you still have a copy of the log, then go ahead and send it to me in a PM so that I can take a look at it. It's possible there's an explanation for the issue in the log.

Share this post


Link to post
Share on other sites

I received your logs, and I don't see any problems in them. Our QA Manager let me know that there is a known issue where updates can fail for a couple of days without any obvious cause, and we think that may be what happened here. We've experienced it internally and a bug report is open for the issue, however it seems to be completely random and relatively rare, so I don't know how easy it will be to debug. We'll get it fixed as quickly as we can.

As for the logs you sent, they have been passed on to our QA Manager, and bug reports should be open for them.

I assume you're still having the issue with the firewall and changing between public/private?

Share this post


Link to post
Share on other sites

> I received your logs, and I don't see any problems in them...

 

OK; I think it's interesting that when the GUI fails to contact the servers it decides very quickly that such contact 

is impossible.  IIRC each time I clicked on the retry button, it was only a second or so later that it said it couldn't

make contact.  Maybe there's just a far-too-short timeout somewhere?

 

> I assume you're still having the issue with the firewall and changing between public/private?

 

Yes.  EIS here updated to v11.8.0.6465 about 25 hours ago, and the PC has been switched off between then and

earlier today, so has had a reboot and (presumably) a 'new connection', but still shows me as being on a Public

network despite the settings saying: "Category for new connections" Private, and "Use Windows settings" not

being selected.  

 

I did, just now, try changing the "Category" value to Public, then clicking OK, then exiting the GUI, unplugging &

replugging the LAN cable & going back to that dialog - to see it said Public (which of course proves nothing), then

changing "Category" back to Private. clicking OK, exiting the GUI, unplug/replug... etc... but after that it still says Public.

Share this post


Link to post
Share on other sites

OK, go ahead and uninstall EIS again, and after a couple of restarts run FRST and the Emsisoft Diagnostic Batch File, and send me the logs.

Here's instructions for FRST:

Please download Farbar Recovery Scan Tool (FRST) from one of the following links, and save it to your Desktop (please note that some web browsers will automatically save all downloads in your Downloads folder, so in those cases please move the download to your desktop):

For 32-bit (x86) editions of Windows:

For 64-bit (x64) editions of Windows:Note: You need to run the version compatible with your computer. If you are not sure which version applies to your computer, then download both of them and try to run them. Only one of them will run on your computer, and that will be the right version.
  • Run the FRST download that works on your computer (for Windows Vista, Windows 7, and Windows 8 please right-click on the file and select Run as administrator).
  • When the tool opens click Yes for the disclaimer in order to continue using FRST.
  • Press the Scan button.
  • When the scan is done, it will save a log as a Text Document named FRST in the same place the tool was run from (if you had saved FRST on your desktop, then the FRST log will be saved there).
  • Please attach the FRST log file to a reply using the More Reply Options button to the lower-right of where you type in your reply to access the attachment controls.
  • The first time the FRST tool is run it saves another log (a Text Document named Addition - also located in the same place as the FRST tool was run from). Please also attach that log file along with the FRST log file to your reply.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.