smf6199

GPU clock idle spikes with latest beta 11.8.0.6451

Recommended Posts

Hi, thanks for looking but I am talking about GPU clocks and not GPU usage.  The beta started spiking the GPU & memory clocks to full speed from the low idle clocks while the stable release kept them at idle speeds.

I've not had a chance to test latest beta as PC is out of action for a few days. 

Share this post


Link to post
Share on other sites

Hm...

post-18745-0-29638500-1464857033_thumb.p
Download Image post-18745-0-52825100-1464857038_thumb.p
Download Image

It's possible it's due to the changes to the automatic Game Mode. I'll ask about it, and see if our developers know why it's happening.

As an interesting note, when I moved my GPU monitor back to my second monitor with version 11.7 installed, the GPU clock fluctuations started again (although they were less frequent and more dramatic than when 11.8 was installed). I also had a YouTube video playing on the second monitor at the time, but it was not interrupted when downgrading/upgrading versions of EIS and it continued playing undisturbed through the test.

Share this post


Link to post
Share on other sites

Thanks for confirming this.  Away from my PC for the next week so can't test anything new but hopefully only a short term issue with the beta.  

 

P.S. I only use one monitor.

Share this post


Link to post
Share on other sites

OK. Since I am seeing this on my computer, I should be able to supply our developers with any information they need.

Share this post


Link to post
Share on other sites

I can confirm I am getting the exact same thing, if i shut down the anit-maleware it stops.

The gap at the start is the brief period i closed down the Emsisoft anti-maleware software.

gpu_spikes.jpg

Share this post


Link to post
Share on other sites

Mine has a stock overclock. It could just be the driver version, or specific cards which have this issue.

Share this post


Link to post
Share on other sites

This only happened since Emsisoft updated, olso seems to be causing odd slowdowns in some games too. If i close down emsisoft all is good again.... i hope this si fixed as i really like emsisoft but this will be a deal breaker for me

Share this post


Link to post
Share on other sites

Yes, you can switch to the Delayed update feed:

  • Open Emsisoft Anti-Malware.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top.
  • On the left, under Update Settings, click on the box to the right of Update feed and select Delayed from the list.
  • Click on the Update now button on the right side.
  • Upvote 1

Share this post


Link to post
Share on other sites

Yes, you can switch to the Delayed update feed:

  • Open Emsisoft Anti-Malware.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top.
  • On the left, under Update Settings, click on the box to the right of Update feed and select Delayed from the list.
  • Click on the Update now button on the right side.

 

Thank you so much for your help, I just want to confirm for yourself and the Original Poster. doing these steps has fixed it for me.

So not sure what is different from the Delayed update im now using and the standard but the current standard version was the cause of the GPU spikes ever couple seconds

Share this post


Link to post
Share on other sites

fix works, but the dev's need to find a way to fix it as I assume this broken code will eventually make it to delayed feeds.

 

I also consider it a deal breaker like the above poster, everything else with EAM I am happy with.

Share this post


Link to post
Share on other sites

So not sure what is different from the Delayed update im now using and the standard but the current standard version was the cause of the GPU spikes ever couple seconds

As far as I know it has to do with the changes that allow Game Mode to turn on automatically when a fullscreen application is running. We hope to have a fix for this in the next beta version that we have ready for public release.

Share this post


Link to post
Share on other sites

As far as I know it has to do with the changes that allow Game Mode to turn on automatically when a fullscreen application is running. We hope to have a fix for this in the next beta version that we have ready for public release.

Perhaps add to EAM an option to disable this feature? Not all of us are gamers ..............................

  • Upvote 2

Share this post


Link to post
Share on other sites

Perhaps add to EAM an option to disable this feature? Not all of us are gamers ..............................

 

Even as a gamer, I will likely disable this feature if the option is added.

 

Please emsisoft announce when this is fixed, as I plan to switch back to stable feed after its fixed given the discovery delayed rolls back all the way to 11.0.

Share this post


Link to post
Share on other sites

Perhaps add to EAM an option to disable this feature? Not all of us are gamers ..............................

I've passed the request on to our QA Manager.

Please emsisoft announce when this is fixed, as I plan to switch back to stable feed after its fixed given the discovery delayed rolls back all the way to 11.0.

If you'd like to be automatically notified when there are new versions of our software available (beta and stable), then please feel free to subscribe to the RSS feed for our Changeblog.

  • Upvote 1

Share this post


Link to post
Share on other sites

How high priority is it to fix this? I brought emsisoft a couple of weeks ago, and it doesnt bode well there has been no patch to address this in the stable feed yet.  All they need to do is reverse the change they made in the latest update until they figure out how to do it properly.

 

The delayed feed is showing buggy behaviour on my system and so I want to switch back as soon as possible.

Share this post


Link to post
Share on other sites

I'm not sure what priority the issue has been assigned, although the priority isn't always as important as things like release schedules and the time it takes to debug an issue or figure out a better way of doing something. ;)

Share this post


Link to post
Share on other sites

A simple rule is if there is no quick way to fix the code then simply rollback the code changes.

 

I have now raised this officially via support.

Share this post


Link to post
Share on other sites

A simple rule is if there is no quick way to fix the code then simply rollback the code changes.

Rolling back changes isn't always simple. It depends on how extensive the changes were, how many functions in the code were effected, etc. All I can ask is that you try to bear with us as we work on this. ;)

I have now raised this officially via support.

Actually, you did that when posting on the forums. While the helpdesk can often be faster (depending on who replies), the support forums are an official support service offered by our company, and at least in the sections that are in German and English we will make sure that everyone gets a reply and do our best to assist.

Share this post


Link to post
Share on other sites

Good news.  Hopefully we will get an official statement on whether there are any more fixes on the way or not.  I'll wait a bit longer before I reinstall EAM though.

Share this post


Link to post
Share on other sites

I've updated Emsisoft to the latest beta , which was released today. Most of the spikes are gone but still happen from time to time.

Yes, we have reduced the frequency that EAM checks for fullscreen applications running to once every 60 seconds, so the spikes should only happen once each minute now.

Good news.  Hopefully we will get an official statement on whether there are any more fixes on the way or not.  I'll wait a bit longer before I reinstall EAM though.

I've passed on the requests I've received to change the functionality (find a new way to check for fullscreen applications that doesn't cause the spikes, add an option to turn off automatic Game Mode, or remove the feature). Ultimately it's up to our management how to proceed from here, and they will may want some time to consider all of the options before making a decision.

Share this post


Link to post
Share on other sites

I've reverted to 11.0 release on the postponed? channel (I have the product in Russian)

 

No lagspikes when idle at all, of course when launching any program it will raise a spike.

https://postimg.org/image/7te6jrso7/

 

 

Update:

 

Reverted to 11.9 beta.  For a test - I've set a gaming mode in the software as a default setting - to see if it will change anything. It did not. it keeps searching for a fullscreen mode every 45-60 seconds,

to change into gaming mode, while being activated as "gaming mode" on the start.

Share this post


Link to post
Share on other sites

Reverted to 11.9 beta.  For a test - I've set a gaming mode in the software as a default setting - to see if it will change anything. It did not. it keeps searching for a fullscreen mode every 45-60 seconds, to change into gaming mode, while being activated as "gaming mode" on the start.

Yes, it will continue checking when in Game Mode. It needs to know when to turn Game Mode back off. ;)

Share this post


Link to post
Share on other sites

Thank you for raising it again GT500, its just sad tho no one apart from you is commenting on it.

 

When I raised it directly, I had a quick reply from someone who clearly didnt know how to respond and he told me he escalated it up the management chain, however after that nothing, zilch no comment from emsisoft.

 

I also tried 11.9 again and am still on it now and can confirm the spikes are less frequent, but they do still occur, no mention of this in the changelog, everything changed in this manner should be in the changelog, I subscribed to the rss feed to see when it is fixed and it was not mentioned.

 

So what we have now is a sort of workaround that partially mitigates the problem but it still has to be fixed, emsisoft cannot just pretend its no issue.

 

Also how do I raise bug reports?  I see ways to contact support, but not ways to report bugs directly to developers like a bug database or something.

Share this post


Link to post
Share on other sites

Thanks as well GT500 for updating us on this, I really want to reinstall EAM.  Even the 60 second gap in spikes is still not a fix and would hope that they find a way to check game mode without having to set a GPU to full speed while the system is still idling at the desktop.   I not certain why the game mode code needed to be changed anyway, I never had any problem when playing games with EAM installed. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Why not assign the 'Game Mode' manually, per application rule basis for example? Such global, automatic operations are bound to cause some problems and possibly overburden the software (of course this is only theory, you have the technical background).

 

Perhaps add to EAM an option to disable this feature? Not all of us are gamers ..............................

 

Totally agree. More control to the users is always a good thing. I wouldn't like an unnecessary (for me ofc) feature forced upon.

Share this post


Link to post
Share on other sites

When I raised it directly, I had a quick reply from someone who clearly didnt know how to respond and he told me he escalated it up the management chain, however after that nothing, zilch no comment from emsisoft.

There were two reasons for that:

  • There haven't been any real updates, aside from a small change to the period of time that EAM checks for a fullscreen application.
  • Since you're already posting here on the forums as well, and subscribed to this forum topic, you'll see anything I (or anyone else) post as a reply to this topic.

... no mention of this in the changelog, everything changed in this manner should be in the changelog, I subscribed to the rss feed to see when it is fixed and it was not mentioned.

Not every change is listed in the changelog. The change to the frequency that EAM checks for fullscreen applications was a minor change, and we don't usually mention small changes like that unless they were to fix something that effected a lot of users.

Also how do I raise bug reports?  I see ways to contact support, but not ways to report bugs directly to developers like a bug database or something.

Bug reports are created by our developers and members of our QA team. When you report issues to members of our support team, we usually forward anything that we feel a bug report or feature request should be opened for to our QA Manager, and then he handles managing any testing that needs to be done and adding these things to our system so that our developers can see them and start working on them.

Share this post


Link to post
Share on other sites

GT500, again thanks for keeping this issue up.

Unfortunately i'm still staying on 11.0 version to avoid all this issue.  I still have hopes for a complete fix to this issue, even every 60 seconds the videocard's lifespan getting much shorter.

Share this post


Link to post
Share on other sites

even every 60 seconds the videocard's lifespan getting much shorter.

That sounds really bad. I recommend you use Windows Defender or Avast Free AV until Emsisoft solve this issue.  

Share this post


Link to post
Share on other sites

That sounds really bad. I recommend you use Windows Defender or Avast Free AV until Emsisoft solve this issue.

I'm not sure how much damage it could be doing, especially since it isn't causing any spikes in the GPU's operating temperature.

Share this post


Link to post
Share on other sites

It can cause damage to videocard's performance. Also in my case is causing trouble with spiking the videocard's power requirements which is bad for computer's power supply.

  • Upvote 1

Share this post


Link to post
Share on other sites

How dramatic are the voltage spikes? For my card I would believe it was about 150 millivolts (if my math is right, that should be 0.15 volts).

Share this post


Link to post
Share on other sites

I know it is not a big issue power/voltage wise,  though we all have a duty to be as green as possible.  From experience no other vendor has to 'blip' the clocks to test for full screen apps.  As an analogy it probably does not harm my car (or cost much extra fuel)  to rev it every 60 secs while idling but I'd rather not do it. 

 

Anyway hoping that the devs find another way to accomplish this. 

  • Upvote 1

Share this post


Link to post
Share on other sites

... From experience no other vendor has to 'blip' the clocks to test for full screen apps. ...

It's more than likely that the normal API for checking for this sort of information doesn't perform the function in the best way possible. We just need to find the proper alternative to it.

Share this post


Link to post
Share on other sites

How dramatic are the voltage spikes? For my card I would believe it was about 150 millivolts (if my math is right, that should be 0.15 volts).

Its a pretty nasty bug hence the pushing we giving you guys, this is not a minor issue.

 

It spikes to maximum voltage.

 

Nvidia have added a new optimised power profile to their latest drivers, but sadly it doesnt improve the emsisoft problem.

  • Upvote 1

Share this post


Link to post
Share on other sites

any updates?

 

I will be asking on a weekly basis.  I fear this will drag on for months, it seems either to be treated as some kind of low priority minor issue or maybe emsisoft think its acceptable to not fix this in a timely manner.

 

1 - Specifically, is this assigned to a developer who is actively working on it now?

2 - Are you adding an option to allow the end user to set gamer mode manually?

3 - Why was this added in the first place?

4 - If no action why do you feel it doesnt merit action?

  • Upvote 1

Share this post


Link to post
Share on other sites

1 - Specifically, is this assigned to a developer who is actively working on it now?

2 - Are you adding an option to allow the end user to set gamer mode manually?

We don't normally give out internal information about our bug fixing process or who's working on what. We also don't normally make statements about new features or exactly what changes are going to take place until there is a public beta, as any proposed features can be changed at any time as we discuss and test them internally.

3 - Why was this added in the first place?

There were complaints about alerts and notifications interrupting games, and updates can cause lag in online games as well as general performance issues as they are installed (there's lots of CPU usage caused by database decryption, decompression, recompression, and re-encryption).

4 - If no action why do you feel it doesnt merit action?

Please note that no one has (at least to my knowledge) made any decision to do nothing about this. I understand that it may seem like we're just ignoring it, since nothing has happened yet, however from what I have been told the bug report has not been rejected. It's just going to take some time.

Share this post


Link to post
Share on other sites

I haven't actually seen the bug report in our system, so I can't say for certain whether or not anyone is actively working on it at the moment.

Share this post


Link to post
Share on other sites

Actually, as I am reading some information I was sent about the changes to Game Mode, we no longer check for fullscreen applications periodically, so there should no longer be GPU spikes regardless of the state of the above option. We now check if it is appropriate to display notifications in a completely different way, which shouldn't have any bearing on GPU activity or clock speed.

There's also an option in the settings for Notifications to toggle displaying notifications when in Game Mode.

  • Upvote 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.