alexashka

Unable to access windows 10 over rdp as of 6/21/2016 EST emsisoft update

Recommended Posts

Greetings EMSISOFT,

 

About few hours ago id say around 5 p.m. EST 06/21/2016 i've noticed a message from internet security software during RDP session to reboot windows 10 as there has been some sort of update requiring reboot, I've proceeded and rebooted my laptop.

 

Immediately after reboot i was unable to access windows 10 on my laptop.

 

I've came home from work and checked things up. I tried to connect from external and internal network, RDP just refused to work. Then i took drastic action and turned off firewall completely. RDP started working without any issues. Then i turned firewall on and RDP stopped working.

 

Please note that my RDP was working with emsisoft for quite a while, 3389 has been "plugged" into firewall rules for quite a while. Id say definitely a few months if not longer. Then i decided to proceed with equally drastic action and turned off everything in firewall short of disabling checkbox that turns firewall on/off. All rules set to allow, network switched to private e.t.c. Essentially i've attempted to relax firewall as much as i can without turning it off completely.

 

RDP still would not work.

 

I would be very grateful if your team could please take a look at your earliest convenience.

 

Greatly appreciate your time and efforts. Alex.

Share this post


Link to post
Share on other sites

This is the update in question. The only changes to the firewall were a fix for a memory leak in a driver and a fix for, under certain conditions, it being possible to reestablish your Internet connection while Offline Mode was on.

Lets try the following first, and see if it helps (please feel free to make a backup of your settings first if you would like to):

  • Open Emsisoft Internet Security.
  • Click on Settings in the menu at the top.
  • Click on the Factory defaults button near the upper-right.
  • Make sure that only the option labeled Global firewall rules is selected.
  • Click the OK button to apply the changes.

Share this post


Link to post
Share on other sites

Arthur,

 

I've done as you've instructed. Still no luck. (i've reset firewall settings and in TCP/UDP rules i've taken out 3389 out of the list of the ports to be blocked. I believe that done the trick last time i've set it up some months ago)

 

Please advice.

 

Thank you. Alex.

Share this post


Link to post
Share on other sites

OK, before we do anything else, lets get some debug logs. Please reset the firewall rules back to factory defaults again, and then follow the instructions below:

  • Open Emsisoft Internet Security from the icon on your desktop.
  • In the 4 little gray boxes at the bottom, move your mouse into the one that says Support, and click anywhere in that gray box.
  • At the bottom, turn on the option that says Enable advanced debug logging.
  • Either click on Overview in the menu at the top, or close the Emsisoft Internet Security window.
  • Reproduce the issue you are having.
  • Once you have reproduced the issue, open Emsisoft Internet Security again, and click on the gray box for Support again.
  • Click on the button that says Send an email.
  • Select the logs in the left that show today's dates.
  • Fill in the e-mail contact form with your name, your e-mail address, and a description of what the logs are for (if possible please leave a link to the topic on the forums that the logs are related to in your message).
  • If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  • Click on Send now at the bottom once you are ready to send the logs.
Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Please note that if you have a lot of debugs logs, then you should not send all of them. There is a size limit, and currently there is no error if the message is rejected due to the size being too large. Normally we only need one copy of the 4 or 5 different logs that have been saved after the time you reproduced the issue (the list shows what time each log was saved). Those logs have the following names:

  • Security Center
  • Protection Service
  • Real-Time Protection
  • Firewall
  • Logs database (contains the logs you can view in Emsisoft Internet Security by clicking on Logs at the top of the window).

Share this post


Link to post
Share on other sites

I'm having the same problem. Has been working fine up till 21/6/2016

 

had to reset my homegroup as well.  still cannot rdp unless EIS firewall disabled.

 

Looking forward to your reply as to how to fix this.  

 

Mike

Share this post


Link to post
Share on other sites

Same problem as alex since yesterday.

After an update & restart firewall blocks incoming RDP on 2 systems (Windows7 64 / Windows 10 64). It also blocks outgoing VPN connections.

 

Uninstalled Emsisoft Internet Security to get things working.

Share this post


Link to post
Share on other sites

There is currently a bug in the firewall in EIS which is causing some applications to be unable to connect to the network. Our developers are working on a fix to this issue. Right now the only workaround is to turn off the firewall when needed.

  • Upvote 1

Share this post


Link to post
Share on other sites

Arthur,

I was juust about to send your team the logs however could not replicate the issue as RDP started to work again.

I safely suspect issue gotten solved with today's (06/23/2016) update.

Apologies for the delay as I could not replicate the issue without being physically at home as replicating the issue would screw RDP.

Please confirm tho successful resolution when get a moment.

Eager to turn off Windows firewall heh.

With best regards. Alex.

Share this post


Link to post
Share on other sites

As far as I know there were no firewall related changes in 11.9.0.6500. Let me know if the problem really does seem to have been resolved.

Share this post


Link to post
Share on other sites

Interesting.

Ok, I'm at home and will give another shot at reproducing I may have botched something somewhere.

EDIT:

Ok, I've sent firewall logs a minute ago when attempted (and connected) to my laptop from iPad.

Thank you. Alex.

Share this post


Link to post
Share on other sites

Our developers think they know what is causing this now, and we hope to be able to have a beta soon.

Share this post


Link to post
Share on other sites

We have just published a new beta that we hope will address these issues with the firewall blocking things it shouldn't. Here's how to install it if you would like to try it:

  • Open Emsisoft Internet Security.
  • Click on Settings in the menu at the top.
  • Click on Updates in the menu at the top.
  • On the left, under Update Settings, click on the box to the right of Update feed and select Beta from the list.
  • Click on the Update now button on the right side.

Please be sure to let us know if you have any feedback about the beta.

Share this post


Link to post
Share on other sites

The beta was published as a stable update, so anyone who wants to switch back to the Stable update feed may do so.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.