Speedster159

How to allow program in Local network only?

Recommended Posts

You can easily do this using Application Rules. Open Emsisoft Internet Security, click on Protection, and find the program you want to restrict in the list (or create a new rule for it).

In the Firewall Incoming and Firewall Outgoing (assuming you want to block both inbound and outbound), delete the default rule, and create rules similar to the following screenshots:

 

post-18745-0-44618300-1467106100.png post-18745-0-65980500-1467106107.png

post-18745-0-96580000-1467106107.png post-18745-0-26916300-1467106108.png

After creating these rules, make sure that they are in the order in the following screenshot:

 

post-18745-0-55821400-1467106108.png

post-18745-0-44618300-1467106100_thumb.p
Download Image

post-18745-0-65980500-1467106107_thumb.p
Download Image

post-18745-0-96580000-1467106107_thumb.p
Download Image

post-18745-0-26916300-1467106108_thumb.p
Download Image

post-18745-0-55821400-1467106108_thumb.p
Download Image

Share this post


Link to post
Share on other sites

You can easily do this using Application Rules. Open Emsisoft Internet Security, click on Protection, and find the program you want to restrict in the list (or create a new rule for it).

In the Firewall Incoming and Firewall Outgoing (assuming you want to block both inbound and outbound), delete the default rule, and create rules similar to the following screenshots:

 

post-18745-0-44618300-1467106100.png post-18745-0-65980500-1467106107.png

post-18745-0-96580000-1467106107.png post-18745-0-26916300-1467106108.png

After creating these rules, make sure that they are in the order in the following screenshot:

 

post-18745-0-55821400-1467106108.png

 

 

 

 

 

Adobe CC 2015 doesn't seem to like being routed that way both online and offline. When I put it on "All Allowed" with the network disabled and enabled it starts in less than a minute and everything works fine, but when I do the Custom setting with 127.0.0.1 instead of the local address, it starts in 3 - 5 minutes and they can't communicate with each other.

 

Any ideas?

Share this post


Link to post
Share on other sites

Adobe CC 2015 doesn't seem to like being routed that way both online and offline. When I put it on "All Allowed" with the network disabled and enabled it starts in less than a minute and everything works fine, but when I do the Custom setting with 127.0.0.1 instead of the local address, it starts in 3 - 5 minutes and they can't communicate with each other.

It's possible that some applications will react badly to that sort of setup. I only tested this on a web browser, and while it worked OK, that is no guarantee that another program will be able to handle running properly.

I also tested it with the beta version of EIS installed, which has now been published as a stable update, so you may want to try it again after verifying that version 11.9.0.6513 of EIS is installed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.