Jump to content

a2framework.dll kann nicht gefunden werden


Recommended Posts

Seit dem letzten Update der Programmversion, in dem auch das Icon geändert wurde, wird mir folgender Fehler beim Starten des Programmes angezeigt:

2009-10-10132345.png

Die DLL befindet sich aber im Ordner. Bei Windows XP auf dem gleichen Computer funktioniert das Programm ohne Probleme, die Meldung wird bei mir nur bei Windows Vista (32 Bit) angezeigt. Dies ist aber wie gesagt erst seit dem Update so. Ich benutze die USB-Version von a-squared Free, welche ich manuell geupdated habe (habe auch schon a-squared Free komplett gelöscht). Bei meiner Google-Suche bin ich auf einen Thread im alten Forum gestoßen, nur leider gab es dort auch keine wirkliche Lösung. Ich hoffe, jemand kann mir helfen :-)!

Link to comment
Share on other sites

Naja, ich habe das Update schon vor ein paar Tagen manuell heruntergeladen und auf den USB-Stick kopiert. Seitdem wurde der Computer ja auch neu gestartet. Das komische ist aber, dass diese Meldung nur erscheint, wenn das Programm vom USB-Stick aus gestartet wird. Wenn ich die portable Version auf dem Desktop starte, funktioniert es :huh: . Ich werde dann wohl noch einmal die Version herunterladen.

Link to comment
Share on other sites

Die Verzeichnisstruktur der portablen Version habe ich nicht geändert. Komisch ist auch, dass auf dem USB-Stick keine ini-Datei (und auch die anderen Ordner) erstellt wird; dies ist nur auf dem Desktop oder Windows XP der Fall. Ich werde aber jetzt erst einmal die Datei noch einmal herunterladen und schauen, ob das etwas bringt. Seltsam ist das schon alles, vor diesem Update hat nämlich alles einwandfrei funktioniert :blink:.

Link to comment
Share on other sites

So, ich habe es nun mal mit der neuen Datei ausprobiert (Datum der Dateien in der ZIP-Datei: 9.10.09). Leider funktioniert es immer noch nicht. Kann es vielleicht etwas mit dem Service zu tun haben? Ich habe nämlich die a2service.exe (sowie die DLLs für das Kontextmenü) aus dem Verzeichnis entfernt, da ich den Dienst bisher noch nie gebraucht habe (hat auch vorher immer funktioniert). Auch ein Starten mit Admin-Rechten bringt nichts. Folgendermaßen sieht es nun aus:

Starten vom USB-Stick von Windows XP aus: funktioniert

Starten vom Desktop von Windows Vista aus: funktioniert

Starten vom USB-Stick von Windows Vista aus: a2framework.dll wird nicht gefunden

Woran könnte es noch liegen? Kann man dem Programm vielleicht sagen, wo es die DLL suchen soll?

Link to comment
Share on other sites

So, nun scheint es zu funktionieren ... Zuerst habe ich die fehlenden Dateien manuell in den Ordner kopiert, hat aber nicht funktioniert. Habe dann anschließend alles gelöscht und noch einmal neu auf den USB-Stick kopiert und siehe da: a-squared Free startete :D! Es wird sogar der Dienst nicht installiert (erkennt das Programm, dass es von einem USB-Stick aus läuft?), was beim Starten vom Desktop sehr wohl der Fall ist. Dann danke nochmals für die Hilfe :)!

Link to comment
Share on other sites

  • 8 months later...

Guten Tag habe das gleiche Problem mit der engine.dll und a2framework.dll. Habe alles deinstalliert und neuinstalliert, Neustart, wieder das gleiche problem. A2-free heruntergeladen und installiert -> läuft auch nicht. In den Ordner geschaut -> scheinen alle dll's vorhanden zu sein. Nochmals AM installiert -> Problem bleibt. Alles wieder deinstalliert, registry bereinigt, neustart, wieder AM installiert -> keine Lösung

Jetzt weiss ich nicht mehr weiter, was tun ???

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...