Sign in to follow this  
Wavenero

Emergency Kit 1.0 Under Bart PE

Recommended Posts

Hey everyone.

I was just wondering if anyone might have any suggestions as to why i am receiving this error when i try and run the emergency kit under bart pe.

c479dd925e18b3b6b3b82e3783d6ee382g.jpg

The other included applications work, just not the Emergency Kit Scanner.

Thanks in advance.

Wavenero

Share this post


Link to post
Share on other sites

Hi Wavenero, welcome to the forum

Please submit that report (depicted) to Emsisoft developers

By "The other included applications work" ... do you mean any other apps. included in Bart PE or other apps by Emsisoft like Command Line Scanner (CLS); BlitZBlank or HiJackFree?

My regards

Share this post


Link to post
Share on other sites

thankyou very much lynx for your fast response :) and thankyou for the welcome.

The other applications that worked in my PE environment were the commandline scanner, blitzbank and hijackfree. the only one that does not work is the Emergency Kit.

I know that this is going to sound really silly, but how would be the best way to submit the report to the developers? in a certain section of the forum? :)

thanks very much

Wavenero

Share this post


Link to post
Share on other sites

Nothing sounds silly... if that is consistently failing & reproducible that is a legit question that has to be addressed by developers & it will be

Cheers!

Share this post


Link to post
Share on other sites

Great :)

Does that mean they already know about the issue i am having, or do i have to make another post in a different section of the forum? :)

thanks

wavenero

Share this post


Link to post
Share on other sites
Guest James

Assuming that the developers don't require any special information from it, when you next see the window click on "Send Bug Report". It will require that you have internet though ;)

Share this post


Link to post
Share on other sites

Hello,

Just wanted to add to the thread. I also tried running Emergency Kit under BartPE and received an error. I also tried HijackFree and BlitzBlank with the same results. The only app I can run is the command line scanner. I am trying to run the apps from a folder on the C: drive so I know it is not a write protect issue. I used to run the A-Squared Free app with no problems under BartPE. I ran Dependency Walker on all the executables to make sure there were no missing .dll's. I submitted the bug report so hopefully we will here some news soon. My old A-Sqaured plugin always worked well, I miss it now...

Assuming that the developers don't require any special information from it, when you next see the window click on "Send Bug Report". It will require that you have internet though ;)

Share this post


Link to post
Share on other sites

I have the same problem, and I'm also trying anti-malware.. According to process explorer, it seems to crash with a buffer overflow during a "filenameinformation" operation.

I have installed the a2 anti malware service in my test PE plugin, along with the A2acc filter service. The A2service starts for me, and I can run hijackfree and blitzbank fine..

A2wizard and A2start.exe crash instantly though. I also ran dependency walker, and I have zip here. It all checks out...

I'm open to further debugging if anyone has any ideas.

Share this post


Link to post
Share on other sites

Just FYI, I sent the bug report from bart pe... i gave all the information, but did not receive a confirmation in the email.. Is there a way to tell if it failed or not?

Share this post


Link to post
Share on other sites

Hi Nick R., welcome to the forum

Can you please be more specific & clarify why you are installing "a2 anti malware service" (actually the name was changed - there is no "a2" anymore)... "A2wizard and A2start.exe"; etc.

... when EEK is in question here - the portable version that specifically does not require any installation, any service any a2start.exe ... and so on

All you have to do, as described, - is unzip & run a2emergencykit.exe

Neither A2wizard nor A2start.exe are present :blink:

My regards

Share this post


Link to post
Share on other sites

Hi Nick R., welcome to the forum

Can you please be more specific & clarify why you are installing "a2 anti malware service" (actually the name was changed - there is no "a2" anymore)... "A2wizard and A2start.exe"; etc.

... when EEK is in question here - the portable version that specifically does not require any installation, any service any a2start.exe ... and so on

All you have to do, as described, - is unzip & run a2emergencykit.exe

Neither A2wizard nor A2start.exe are present :blink:

My regards

Sorry if I was unclear.. I was saying that the same thing happens for your free anti-malware product under PE.. essentially it crashes the same was as your emergency kit. I figured this might be of some use to know that it occurs across the product line.

The services installed by these programs are a2acc (a-squared mini filter) and Emsisoft anti-malware service (a2service.exe).

A2stasrt and a2wizard crash the same was as the emergency kit...

All products seem to suffer from a buffer overflow shortly after executing according to procmon..

Share this post


Link to post
Share on other sites

Thanks for the reply, Nick R.

Let's leave this case for the "EEK + PE" request only

I hope that you've submitted the crash report as it was suggested above & in the reply #6 by James

==============

As for the installation and crashes of full EAM Suite (the 2nd part of your post),

I would suggest that you create the separate thread and / or just submit the crash report as well

I have EAM installed on several PCs and few Mamutus (how's that sound? :) )

That was a loooong time ago when any crash occurred... and there were no recent reports from other users

Therefore, in that new request - please provide more detailed information about your System Environment as in Forum Posting Rules #2)

and submit the report to the developers as well

Probably you will be asked to run fltmc as in #7 here

and some other info like ">sc query a2acc"

and whatever else the developers will find necessary

My regards

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.