Quirky

Logging works even if disabled?

Recommended Posts

Hello everyone,

 

I usually turn logging off (and had it off for quite some time), but today I've enabled it for a bit of troubleshooting. I now see in the logs that there are many entries from several days back. Does this mean that logging keeps... logging even when disabled? I thought turning it off -completely- might be a good idea for an SSD.

Share this post


Link to post
Share on other sites

You mean the logging setting in the following screenshot?

post-18745-0-83313000-1472679159.png

If so, then certain types of logs are not controlled by that setting. I would believe that all of the logs that you can view within the UI are controlled by it, so if there are logs that you could see that were still being saved, then let me know which ones.

post-18745-0-83313000-1472679159_thumb.p
Download Image

Share this post


Link to post
Share on other sites

That's the setting. I can see older logs in: Behavior Blocker, Firewall and Scan. It's a recent Windows install so the other categories could be 'affected' too, not 100% sure.

Share this post


Link to post
Share on other sites

Were logs saved during the time you had logging disabled, or is it just that old logs were kept even though logging was turned off?

Share this post


Link to post
Share on other sites

Wasn't 100% sure so I cleared all logs yesterday (always from within the UI) and disabled the setting. I've turned it on now and several entries from yesterday appear.

Share this post


Link to post
Share on other sites

Perhaps it may be something to do with having fast boot enabled on Windows 10?

 

I know a2service logs can persist with fast boot turned on because the system isn't really turned off when you shut down, it just sort of suspends so that you can have a faster boot.

Share this post


Link to post
Share on other sites

.... I've turned it on now and several entries from yesterday appear.

In which category? Just Firewall, or others as well?

Share this post


Link to post
Share on other sites

To my knowledge, scan logs are always saved. Behavior Blocker and Firewall entries will appear in the logs because certain information is always saved in the logs that the Behavior Blocker and Firewall logs are drawn from, and I'm fairly certain that this is intended behavior. I will check to be certain.

Share this post


Link to post
Share on other sites

I now see logs in the UI (same three categories) with the option still disabled. I hope you can make this work as described (logging disabled), to prevent them from both displaying and saving to the HDD.

Share this post


Link to post
Share on other sites

Hm... You're right, it does still write to and display the logs when logging is disabled. I'll have to ask our QA Manager if that's a known issue.

Share this post


Link to post
Share on other sites

After disabling logging, try right-clicking on the Start button, go to Shut down or sign out, and selecting Restart to restart your computer (don't restart the normal way in Windows 8.1 or Windows 10). Does the issue still happen after that?

Share this post


Link to post
Share on other sites

I recommend exporting all of your settings, and then resetting all of your settings to factory defaults. After that you can check and see if the issue persists, and then import any rules or settings that you need.

Share this post


Link to post
Share on other sites

Please don't ask me to do more testing on this... I thought the issue was confirmed. I tried yet one more time on a fresh Windows (and of course EIS) installation. I disabled the logging option, cleared all logs (within the UI as usual) and only imported a host file I usually use in Surf Protection and changed a few settings in File Guard (Scan level: fast and unticked "Only scan files with specific..." and "Protect the computer even...").

 

Give EIS a few minutes (or just restart the PC) and logs will start to appear in the UI. The "disable logging" setting clearly doesn't work, there's nothing more I can do.

Share this post


Link to post
Share on other sites

Our QA Manager tried testing this himself, and he says the setting works as expected for him. I'll send him some more information, and we'll see if he can reproduce it after that.

Share this post


Link to post
Share on other sites

Ok thank you. You mentioned earlier that this could be intended behaviour, so if this setting is expected to work like that (as the QA Manager also said) I hope you'll reconsider and make the logging=off setting to indeed disable logging completely. Currently, it doesn't work as described at all (at least on my system).

Share this post


Link to post
Share on other sites

Our QA Manager has confirmed the issue now. I expect the logs appearing in the window is at the very least not intended, however I can't say for certain whether or not all logging will ever actually be stopped when the option is turned off. There is information written to the logs that is not displayed in the Logs in EAM, and I know that the setting for "maximum records" does not control those entries.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.