Jump to content

Recommended Posts

Hi,

ich habe heute früh ein Update gehabt, bei dem verschiedene Module aktualisiert wurden:

a2cmd.exe (355474 Bytes) - geupdated

a2framework.dll (413579 Bytes) - geupdated

engine.dll (682879 Bytes) - geupdated

Nachdem Neustart des Wächters begann mein W7 x64 in Stocken zu kommen und reagierte schließlich gar nicht mehr. Einzelne Programme ließen sich noch schließen, aber W7 sich nicht mehr herunterfahren. Ich schätze mal das u. A. der "Windows-Fenster-Manager" abtestürzt war.

Beim erneuten Hochfahren fror der PC kurz nach dem Anmelden des Nutzeraccounts ein.

Starten im Abgesicherten Modus funktioniert problemlos.

Was soll ich tun? Auf das nächste Update warten und bis dahin den Wächter & Co. abschalten?

MfG NoxCivi

Link to post
Share on other sites

Danke fuer den Report. Derzeit scheint die einzige Loesung zu sein EAM temporaer zu deaktivieren. Da die fuer's Debugging notwendigen Speicherdumps noch nicht vollstaendig verfuegbar sind, kann ich derzeit nicht viel mehr zu den Ursachen sagen. Gegen Abend sollten mehr Informationen verfuegbar sein.

Link to post
Share on other sites

In Zusammenhang mit diesem Problem ist mir zusätzlich aufgefallen, dass die Ausnahmen-Liste des Guard wahrscheinlich überläuft.

Ich habe relativ viele Prozesse ausgeschlossen, und sobald ich einen weiteren Eintrag des Typs "Prozess" hinzufügen will, bekomme ich eine Fehlermeldung vom internen Debugger. Leider habe ich es bis jetzt nur einmal geschafft, die Debug-Meldung zu senden, denn danach ist sehr schnell Sendepause, wenn ich den Guard nicht sofort beende.

Da das Problem einigermaßen heftig ist, wäre eine zeitnahe Lösung unbedingt erforderlich.

Link to post
Share on other sites
  • 2 weeks later...

Um zu testen, ob die Ausnahmeliste nun mit dem Beta Update vom 30. funktioniert, habe ich die Beta-Updates mal aktiviert. Daraufhin wurde ein größeres Update geladen:

Allgemeine Informationen:

Update Beginn: 31.08.2010 19:31:53
Update Ende: 31.08.2010 19:32:28
Dauer: 0:00:35

Update erfolgreich

Detail-Informationen:

15 Module, 7997317 Bytes

a2acc.dll (36368 Bytes) - geupdated
a2accx64.sys (32415 Bytes) - geupdated
a2accx86.sys (28415 Bytes) - geupdated
a2dix64.sys (21787 Bytes) - geupdated
a2dix64.dll (41644 Bytes) - geupdated
a2dix86.sys (18723 Bytes) - geupdated
a2dix86.dll (36024 Bytes) - geupdated
a2cmd.exe (355528 Bytes) - geupdated
a2framework.dll (694036 Bytes) - geupdated
a2start.exe (1917339 Bytes) - geupdated
a2update.dll (760641 Bytes) - geupdated
a2wizard.exe (1465976 Bytes) - geupdated
engine.dll (682824 Bytes) - geupdated
a2service.exe (652806 Bytes) - geupdated
a2guard.exe (1252791 Bytes) - geupdated

Daraufhin hatte ich, allerdings erst heute zum ersten mal, wieder einen "deadlock":

Name der fehlerhaften Anwendung: a2service.exe, Version: 5.0.0.54, Zeitstempel: 0x4c7c8af6
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7600.16385, Zeitstempel: 0x4a5bdbdf
Ausnahmecode: 0x0eedfade
Fehleroffset: 0x0000b727
ID des fehlerhaften Prozesses: 0x684
Startzeit der fehlerhaften Anwendung: 0x01cb49cd2126d8d5
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Emsisoft Anti-Malware\a2service.exe
Pfad des fehlerhaften Moduls: C:\Windows\syswow64\KERNELBASE.dll
Berichtskennung: 22bd3eaf-b5cb-11df-bad0-00261863708b

Zur gleichen Zeit lief PDEngine wegen der Defragmentierung, allerdings auf einer Datenplatte ohne OS.

Vermutlich ist der Deadlock in der Beta noch drinnen?

Link to post
Share on other sites

Ja, habe ich. Nachdem ich auf Laufwerk "E" dann folglich chkdsk durchführen musste, ist es nochmals passiert:

Name der fehlerhaften Anwendung: a2service.exe, Version: 5.0.0.54, Zeitstempel: 0x4c7c8af6
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7600.16385, Zeitstempel: 0x4a5bdbdf
Ausnahmecode: 0x0eedfade
Fehleroffset: 0x0000b727
ID des fehlerhaften Prozesses: 0x5d0
Startzeit der fehlerhaften Anwendung: 0x01cb49da9a0a8e3f
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Emsisoft Anti-Malware\a2service.exe
Pfad des fehlerhaften Moduls: C:\Windows\syswow64\KERNELBASE.dll
Berichtskennung: 3f150ab6-b5d4-11df-b807-00261863708b

Ich habe den Verdacht, dass es auftritt, wenn die Bereitstellung eines Volume im laufenden Betrieb aufgehoben wird. Das würde PerfectDisk genauso machen wie chkdsk.

Beta Update ist jetzt rückgängig gemacht. Damit ist das Problem hoffentlich vorerst behoben...

[bin jetzt für drei Stunden ausser Haus und kann erst später antworten...]

Edited by The_Preacher
Link to post
Share on other sites

Ich habe den Verdacht, dass es auftritt, wenn die Bereitstellung eines Volume im laufenden Betrieb aufgehoben wird. Das würde PerfectDisk genauso machen wie chkdsk.

Beta Update ist jetzt rückgängig gemacht. Damit ist das Problem hoffentlich vorerst behoben...

Kann ich bei mir jetzt nicht nachvollziehen. Hab mal das Laufwerk via chkdsk /x dismounted waehrend eines Scans und diversen anderen Szenarien und der Service ist nicht gecrashed in der aktuellen Beta.

Was befindet sich auf E, irgendwas Spezielles wie Userprofile z.B.?

Kannst Du auch mal schauen ob in Deinem EAM Ordner evtl. eine oder mehrere ELF Datei zu finden ist? Wenn ja schick sie bitte an [email protected]

Link to post
Share on other sites

Kann ich bei mir jetzt nicht nachvollziehen. Hab mal das Laufwerk via chkdsk /x dismounted waehrend eines Scans und diversen anderen Szenarien und der Service ist nicht gecrashed in der aktuellen Beta.

Was befindet sich auf E, irgendwas Spezielles wie Userprofile z.B.?

Kannst Du auch mal schauen ob in Deinem EAM Ordner evtl. eine oder mehrere ELF Datei zu finden ist? Wenn ja schick sie bitte an [email protected]

Also auf E befindet sich kein Userprofile, nur der symbolic link für den Benutzerordner "Musik". Ansonsten wüsste ich nicht.

ELF-Dateien waren leider keine zu finden. Dummerweise kann ich auch keinen dump erstellen, eben wegen dem Deadlock...

Link to post
Share on other sites

Also auf E befindet sich kein Userprofile, nur der symbolic link für den Benutzerordner "Musik". Ansonsten wüsste ich nicht.

ELF-Dateien waren leider keine zu finden. Dummerweise kann ich auch keinen dump erstellen, eben wegen dem Deadlock...

Welche Parameter benutzt Du bei chkdsk? Welche Waechtereinstellungen sind aktiv? Vielleicht bekomm ichs ja doch noch reproduziert irgendwie.

Link to post
Share on other sites

seit heute habe ich auf "Freezes". Sie treten wahlos nach ca. 30 Minuten nach Systemstart auf. Etwa bei Nutzung von Firefox etc. Die Programme reagieren nicht mehr, die Fenster nehmen die übliche "Blässe" an und es hilft nur noch der Resetknopf.

Habe den Wächter deaktiviert, seitdem geht es ohne Problem!

Der Betablog gibt leider nichts aktuelles her, gabs ein Betaupdate heute?

Link to post
Share on other sites

seit heute habe ich auf "Freezes". Sie treten wahlos nach ca. 30 Minuten nach Systemstart auf. Etwa bei Nutzung von Firefox etc. Die Programme reagieren nicht mehr, die Fenster nehmen die übliche "Blässe" an und es hilft nur noch der Resetknopf.

Das kann ich bestätigen. Ich hatte in beiden Fällen Firefox offen, und als erstes blieb der hängen. Auch von den Win7-Gadgets war als erstes die Traffic-Anzeige vom "Network Meter" von AddGadget.com tot.

Link to post
Share on other sites

Welche Parameter benutzt Du bei chkdsk? Welche Waechtereinstellungen sind aktiv? Vielleicht bekomm ichs ja doch noch reproduziert irgendwie.

Hallo,

chkdsk /f /x /v

Im Wächter ist "Scanne zusätzlich auch alle Dateien, wenn sie erstellt oder veränder werden" aktiv, Riskware melden und unbekannte Malware melden. Standard-Aktion ist "Alarmieren".

Regel anlegen und Intelligente Alarm-Reduktion deaktiviert, community-basierte ist aktiv, bei erlauben 95%, bei blocken 90%, paraniod-Modus ist aus.

Surf Schutz ausser Werbe/Tracking-Hosts (nicht blockieren) alles auf "Blockieren mit Info".

Verhaltensanalyse alles aktiv.

Ausnahmen und Anwendungsregeln habe ich aber SEHR viele...

Link to post
Share on other sites

Mmmh.. es scheint bisher wieder stabil zu laufen. Es gab aber nur ein kleines Update wie ich sehe... :)

Geht es bei dir auch wieder?

Ich habe das Beta-Update nicht mehr drinnen. Trau mich momentan nicht. Wenn der Freeze während chkdsk oder PD auftritt, hat man gute Chancen, die Platte unlesbar zu machen. Ich hoffe, der Bug schafft es nicht in die Release-Version...

Link to post
Share on other sites

Ich habe vorher die ganze Zeit vergessen, dass ich "CWDIllegalInDllSearch" global auf "0xFFF..." gesetzt habe. Daran könnte es natürlich auch liegen. Ich könnte die betroffene .exe von Emsisoft AM auch in die Ausnahmen stellen, und dafür "0", "1" oder "2" definieren.

P.S. bis Ende nächster Woche bin ich nicht mehr erreichbar, vielleicht ist das Problem bis dahin ja auch so schon gefixt...

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...