TheErzengel

Problem with PureVPN

Recommended Posts

I'm having trouble connecting to my VPN (PureVPN) that manages a L2TP protocol.

 

Try to connect with the firewall enabled and it is impossible. I have all the processes is PureVPN whitelist all allowed traffic. I can only connect if I disable the Firewall (although after connecting I can activate it again)

 

 

:mellow:

Share this post


Link to post
Share on other sites
Just I saw a topic talked about this problem. One solution is to leave open port 1701 (where it connects to the VPN).

 

Not sure if it is this. But now my VPN works without problem.

 

 

PS: I'm sure I searched the forum and did not find anything about it, but today I went back to look and I found it, sorry.

Share this post


Link to post
Share on other sites

Hi there,

I am also their user and this is what their support had to offer about your issue:

 

"Usually Firewalls do not block Virtual Private Networks but if you are facing trouble, all you need to do is to create relevant exception in your firewall settings. PureVPN supports following protocols:

PPTP VPN, which requires port 1723 opened on your firewall for both UDP/TCP. GRE 45
L2TP VPN, which requires port 1701 opened on the firewall for both UDP/TCP, and;
SSTP VPN, which requires port 443 opened on the firewall for both UDP/TCP.
OpenVPN UDP: 53
OpenVPN TCP: 80"

Share this post


Link to post
Share on other sites

I'm having trouble connecting to my VPN (PureVPN) that manages a L2TP protocol.

 

Try to connect with the firewall enabled and it is impossible. I have all the processes is PureVPN whitelist all allowed traffic. I can only connect if I disable the Firewall (although after connecting I can activate it again)

I recommending adding a rule to the Global Firewall Rules in Emsisoft Internet Security for the port your VPN is using. As JeffyDune and TheErzengel mentioned, the default port number for L2TP should be 1701, and PureVPN support says the rule should be for both TCP and UDP. Some sources mention that L2TP can also use UDP ports 500 and 4500, so you may need to open those as well.

Here are some instructions for adding a rule to the Global Firewall Rules in Emsisoft Internet Security:

  • Open Emsisoft Internet Security.
  • Click on Protection.
  • Click on Firewall in the menu at the top.
  • Click the Add rule button near the lower-right.
  • Give the rule a name so that it is easy to identify what it does when looking through the list of firewall rules.
  • Make sure the Action is set to 'Allow'.
  • Set Direction to IN/OUT.
  • Set Protocol to TCP/UDP.
  • Enter your port number in the field for Ports (you should be able to enter multiple port numbers if you separate them with commas).
  • Make sure that Addresses is set to All.
  • Click OK at the bottom to save your new firewall rule.
  • Click on your new firewall rule in the list to select it.
  • Click the Move up button to move your new firewall rule above the two block rules at the bottom of the list.
Note that you should go slowly when moving a firewall rule, as sometimes when you click too quickly you can accidentally move more than one rule. Just keep an eye on which rule is highlighted before you click the "Move up" and "Move down" buttons, as it will be safe to click them when your rule is highlighted in the list.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.