Jump to content

EIS 12 doesn't start up after fresh installation


Recommended Posts

Clean install on Win 7 x64 Pro with all the critical and important Windows updates installed, including the recommended hotfixes for EIS v11.

I also used emsiclean.exe prior to EIS v12 installation to get rid of earlier EAM stuff, although it left some orphaned folders at C:\ProgramData and C:\Program Files that I removed manually).

EIS wizard didn't start up after installation for 10 or more minutes so I restarted and tried to manually run the application. No go. Displays a message:

"Emsisoft Protection is waiting for a component (service) to start..."

a2start.exe and a2guard.exe are visible in the Windows Task Manager but the main application UI never comes up.

After some time, another dialog window is shown where it says:

"A major problem has prevented the application from starting. Emsisoft Security can't connect to the service application. Please restart you computer and try again or contact support if the problem persists."

Looking around the forums, I see this has affected several other people, so I suggest there might be a bigger underlying issue.


EDIT: Now even Emsisoft Anti-Malware doesn't work properly. After uninstalling EIS, I did a fresh install and now EAM refuses to do the first update post-install.

"An unexpected internal processing error occurred. Please contact the support team."


I'm currently connecting to the internet via a cell phone tether and while the speed isn't great, all other applications on this PC (Steam, Chrome, Firefox) seem to be able to use the internet connection just fine, but EIS/EAM refuses to do so.


Link to comment
Share on other sites

My understanding is that this is only happening with new installations of version 12 of Emsisoft Internet Security. It might be possible to install version 11 and allow it to upgrade to version 12, and thus bypass the issue.

You should be able to get the most recent version of Emsisoft Internet Security 11 from FileHippo at this link (the download will start automatically shortly after clicking the link) (edit: link is for wrong product). Please be sure to disconnect your Internet before installing it in order to prevent it from updating to version 12 before the installation is finished. Once installed and working, you can reconnect your Internet and allow the update to take place.

In regards to the "Internal Processing Error", that's usually caused when there was an unexpected problem trying to connect to our servers (such as when checking for updates or when verifying the safety of a running program with our Anti-Malware Network). This can be caused by Internet connection problems, and it can also be caused when another program on your computer is interfering with the update process.

Link to comment
Share on other sites

The installation and first start-up issue has indeed been fixed for me, but the first update problem still remains ("An unexpected internal processing error occurred.")

Is EIS unable to recognize a mobile phone tethered internet connection (3G tethered on a Sony Xperia M2 - Android v5.1.1)? Because EIS/EAM v12 seem to be the only apps that have trouble fetching updates from the tethered internet connection.

I want to stress that I don't have any other applications that might be causing this lack of connectivity, as all other installed programs work just fine (browsers, windows update, steam, etc.). Windows Firewall is correctly disabled after EIS installation and EIS is the only thing controlling the internet access.

I'm in the process of switching ISPs and due to some issues, I can't have land based internet for a couple of weeks, hence the 3G tether.

EDIT: And I forgot to mention, that EAM v11 updated just fine over this connection before.

Link to comment
Share on other sites

The "Internal Processing Error" isn't necessarily a problem connecting. It's a problem processing the information received when trying to communicate with one of our servers. This could simply mean that the information has been corrupted or altered in some way. The best way to tell what is going on is to try running the update through a debugging proxy such as Fiddler. Here's some instructions for running Fiddler:

Please download and install Fiddler 2 from this link (this is the version that requires the Microsoft .NET Framework 2.0), and then follow the instructions below:

  • After installing Fiddler, please open it from the Start Menu.
  • Launch Emsisoft Anti-Malware.
  • Click on Settings in the menu at the top.
  • Click on Privacy in the menu at the top.
  • Turn off the option that says Use SSL encryption for all server communication (this is necessary for Fiddler to be able to record the update process).
  • Click on Updates in the menu at the top
  • Click on the Proxy settings button on the right side, in the middle.
  • Check the box that says Use proxy.
  • Enter localhost in the Server field, and then enter 8888 in the Port field.
  • Click OK.
  • Click the Update now button above the Proxy settings button.
  • After the update fails, go back to Fiddler, and to File, then Save, and select All Sessions (please save it on your desktop).
  • Please send me the Fiddler log in a Private Message (do not post it in a reply).
Note that you may need to ZIP the log to be able to attach it to a Private Message. If you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to Send To, and clicking on Compressed (zipped) Folder.
Link to comment
Share on other sites

All the Fiddler log shows is an error message indicating that there might be a problem with how our license servers are handling the mapping for your license key. I'm going to send you a test license to see if the issue goes away when you activate it.

Link to comment
Share on other sites

I couldn't activate EIS with your test licence either. It really seems EIS is unable to access the tethered internet connection at all.

I tried it both with EIS firewall disabled and Windows firewall enabled and other way around with EIS firewall enabled and Windows Firewall disabled. Even with both firewalls turned off, but no success.

Once again, all other applications on my system can access the internet without an issue.

"Mapping license with your computer failed. Please check your internet connection settings or contact support."



So in the end, I tried activating a trial licence and got 3 days, but that seems to be a built-in function not requiring an internet connection, so the updates still don't work and I receive an unexpected internal processing error, same as before. That's why, IMO, the issue has nothing to do with a licence check.


I'm going to try another uninstall, followed by emsiclean.exe in Safe Mode and reinstall, but if that doesn't work, I'll just have to install some other security suite.

This has taken far too much of my time and effort, especially considering that EAM/EIS v11 and before had no such issues using a tethered USB internet connection.


EDIT: ...and nothing. Except the same unexpected error message. I've also reset my Windows Firewall to its defaults, just to be 100% positive it's not interfering with EIS internet access, in any way shape or form. Sigh, looks like no Emsisoft products for me any longer.


EDIT 2: Curiosity got the better of me and just to make sure my memory didn't go to hell in the last couple of weeks, I downloaded Emsisoft Emergency Toolkit v11.9.0.6508. And guess what?


EEK updates without problems


Seems to me Emsisoft broke something in v12.

Link to comment
Share on other sites

EIS is connecting. It's just not receiving the right response from our servers. As I said before, I'm fairly certain that this is a server-side issue that our developers will need to fix.

For now, are you able to activate the free trial in EIS?

Link to comment
Share on other sites

Just now, I was able to at least get my original licence working, so the UI now shows I have over 300 days left on the licence.


However, all attempts at performing an initial update still fail.


Is there a way to update EIS offline?


EDIT: Sent you another Fiddler log in a PM that is larger in size than previous one and may contain more info than before.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...