Allow batch file to run always

Recommended Posts

Low-level question I'm sure: I have a long batch file that I run every month which just copies a ton of files. I need it to play a sound file when it finishes (since it takes a good half-hour or so to run). Emsisoft doesn't like the final line, which simply opens the .midi file. The message says the batch file has changed.


First, is there a way to make (only) that file immune from this monitoring?  Second, on several occasions I've been certain the batch file has *not* changed but Emsisoft still says it has (and won't play the sound file until I answer its rule query). Why is that? Is it just the length of time since the last rule approval?


Thanks for any clues.  I'm running EIS on WIn10 64bit

Share this post

Link to post
Share on other sites

Open Emsisoft Anti-Malware, click on Protection, find your batch file in the list, and double-click on it to edit the rule. Click on Custom monitoring and change it to All allowed, select Don't alert when this file changes in the lower-left, and then click OK to save the changes.

If that isn't enough, then you can add an exclusion for the batch file as well. Just open Emsisoft Anti-Malware, click on Settings at the top, then click on Exclusions in the menu that appears right below that, and you'll want to add it to the list on the bottom (Exclude from monitoring).

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.